summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.5.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index baee864c7fc7..6d272c57c403 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.1.0.tar.gz 6054311 BLAKE2B c0eef436e89e1de56d47713b2c5685d15cddc08d744926b69e6d0d1d7bd7548614009f489d6ae2579482d4d770b62e51cc76734ab3866451ec4fd4d51c84d59b SHA512 7d1b8d0761bdd71a3c72a60d59e0f7f1c94c8c8863b2a1cfb4ed7742060482500d43d7f71bc328a50628a9c116297695813651d7712b88cf7e8594118c4b339f
DIST ibus-typing-booster-2.5.1.tar.gz 6232907 BLAKE2B 60fa4b287eb61b509e938d7570dcd9db3160ed66dde56ebae17cb3f46c1862d626dede4dca330b292585fb7db86ee97ed5cd020431a300eaf864a35cad76b99a SHA512 69ba68d6da262762df6db3c98ff947d189463eea761aed42b62cc02dee4c6f7badd533300203a4c6d81e53874ff80da2829a3c82a7acdddf4b1cd99556b0eda1
+DIST ibus-typing-booster-2.5.3.tar.gz 6463060 BLAKE2B c1053f2e9536ee1dd1c243702150e7f0d1dce1651a196a705395890d3d6274a369c718c66c62d96bd317862d831da8195e70bddcde53fef27c1531e5525193ae SHA512 6d7f033919223522c9b0fcef5af4d8368f126c2da1acbbb0403c0575cdedaddd1de7d5cbcdf15dda63b05a871f35708586628195c3da4cfd86ca12bfde452672
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.5.3.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.5.3.ebuild
new file mode 100644
index 000000000000..5e80b23f3f31
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.5.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit python-single-r1
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-libs/m17n-lib
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-db/m17n-db-1.7"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"