summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jupyter_packaging/Manifest2
-rw-r--r--dev-python/jupyter_packaging/jupyter_packaging-0.10.2.ebuild42
-rw-r--r--dev-python/jupyter_packaging/jupyter_packaging-0.10.3.ebuild47
3 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/jupyter_packaging/Manifest b/dev-python/jupyter_packaging/Manifest
index 1ed0d03c617c..a72858129706 100644
--- a/dev-python/jupyter_packaging/Manifest
+++ b/dev-python/jupyter_packaging/Manifest
@@ -1,3 +1 @@
-DIST jupyter_packaging-0.10.2.tar.gz 21735 BLAKE2B 92de31e6835a2228f85b008b0fa3b3b8b5ebd175399fa82ee79d328f97b50c09a86dbc325e0378a7f946de34522d4af12fa5997507895ff6d85e77d4e7d38e3c SHA512 c1f5562b8fd72d64998d32d1a85dd1af2b730fa7e4a0d9e2036ea4d5a607ce02b1e9c641f01997ea3b0d6e047fa797009ce3c2ca52ef866ec9c7492ef836e679
-DIST jupyter_packaging-0.10.3.tar.gz 21530 BLAKE2B 43392f938d40e859e79f42b7942a199f808218c1da697c48a8ae0b1c5a4e8a408f983196e9d148edbf17d1725186216ed79446bd42fe8f18baaf8fc9f66efe1c SHA512 7634a056d506328af6e963ac7a8d6ac5fdb5d5303a31495af2275a7feca3732b60aeebb332cdc009ab690aa4185f5b3687ae002300b4885620cb9f2da6d2c79e
DIST jupyter_packaging-0.10.4.tar.gz 21698 BLAKE2B 5490443e197861a53587fe744d749162e412b88bc5c1e5917cd6c145254e4feecbb8b3e3853bf5a3e360fc9ee20c3345af9c7a245aeb1b03639d99d1d69cb377 SHA512 066abaaa00be8154ea39cc3db0bfa4cfe03864c3e50a741f416606c2f8a2d2e0202943f390905ee46f99414168705b9c3519609c6ea16b3b7d54820631c3ba46
diff --git a/dev-python/jupyter_packaging/jupyter_packaging-0.10.2.ebuild b/dev-python/jupyter_packaging/jupyter_packaging-0.10.2.ebuild
deleted file mode 100644
index 593c51be660f..000000000000
--- a/dev-python/jupyter_packaging/jupyter_packaging-0.10.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Tools to help build and install Jupyter Python packages"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/deprecation[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Skip the tests that try to install things or call pip
- rm tests/test_build_api.py \
- tests/test_datafiles_install.py \
- tests/test_install.py || die
- # Permission Denied (tries to write to site_packages)
- sed -i -e 's/test_create_cmdclass/_&/' \
- tests/test_deprecated.py || die
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/jupyter_packaging/jupyter_packaging-0.10.3.ebuild b/dev-python/jupyter_packaging/jupyter_packaging-0.10.3.ebuild
deleted file mode 100644
index 7d5ef4959832..000000000000
--- a/dev-python/jupyter_packaging/jupyter_packaging-0.10.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Tools to help build and install Jupyter Python packages"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/deprecation[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # TODO: package "build"
- tests/test_build_api.py::test_build_package
- tests/test_build_api.py::test_deprecated_metadata
-
- # broken by Gentoo pip patch
- # TODO: retry when we finally make the patch less intrusive
- tests/test_datafiles_install.py
- tests/test_install.py
- )
-
- distutils_install_for_testing --via-venv
- epytest ${deselect[@]/#/--deselect }
-}