summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-extra/gucharmap/Manifest1
-rw-r--r--gnome-extra/gucharmap/gucharmap-11.0.3.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/Manifest b/gnome-extra/gucharmap/Manifest
index f6b82cc257d2..0a36ee5d7562 100644
--- a/gnome-extra/gucharmap/Manifest
+++ b/gnome-extra/gucharmap/Manifest
@@ -1,2 +1,3 @@
DIST gucharmap-10.0.3.tar.xz 1713960 BLAKE2B 0a0412c7a4d46c25112d9bb33d64e82b448e981a2ecb9a5ed5ce5e96657e5264e14262b15c4e5af6b3d023c20193a7471071c5d346f0d48e22583b07e92d51f7 SHA512 0815ca39311db4dc3ff5202f1303cad72bc204f4eef4d2ec83465123ff856eeb552a583666419ad4a3bf9d3ddcf294883fc8e24e32c30814916b41bc14a108fe
+DIST gucharmap-11.0.3.tar.xz 1766884 BLAKE2B fe92675494d5bf8e62f3b38356ecca59d4be515c8a08d6729d1bc3c7ba6c7b3e4ed802f4e1f79f2830f56f96a7d708d7d5a2bd1a79a36c9cd2bb0f1b6bfd1577 SHA512 281749d3fbea937ff6ce958a7216ead03fdf19cb303aef528a1456c5ab90be977f704ff65b2e665cbad58d2c14db51b0ad144fc6961aadbb7d95ec288d79402c
DIST gucharmap-3.0.1.tar.bz2 3275481 BLAKE2B 80dde7791abdc72677add9c65c59f810e6c6952116b92db34059c4c40d2657246b17844c105e68f32c86294e9b4e71e9d48e6f0522855465734d7c24e8d17608 SHA512 4d8a2276b5cb1a0b0fadca2a8522755c5884985a12d5b19341b9cefcd7f749ec1286c0271419e38ec84be7edcfa1293e7f0263eb682c75387d692792de3e1fb1
diff --git a/gnome-extra/gucharmap/gucharmap-11.0.3.ebuild b/gnome-extra/gucharmap/gucharmap-11.0.3.ebuild
new file mode 100644
index 000000000000..adb820d43f7e
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-11.0.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala versionator
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
+
+LICENSE="GPL-3"
+SLOT="2.90"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug +introspection test vala"
+REQUIRED_USE="vala? ( introspection )"
+
+UNICODE_VERSION=$(get_version_component_range 1-2)
+
+COMMON_DEPEND="
+ =app-i18n/unicode-data-${UNICODE_VERSION}*
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/pango-1.2.1[introspection?]
+ >=x11-libs/gtk+-3.16:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/gucharmap-3:0
+"
+DEPEND="${RDEPEND}
+ dev-util/desktop-file-utils
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1
+ >=dev-util/intltool-0.40
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( app-text/docbook-xml-dtd:4.1.2 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ # prevent file collisions with slot 0
+ sed -e "s:GETTEXT_PACKAGE=gucharmap$:GETTEXT_PACKAGE=gucharmap-${SLOT}:" \
+ -i configure.ac configure || die "sed configure.ac configure failed"
+
+ # avoid autoreconf
+ sed -e 's/-Wall //g' -i configure || die "sed failed"
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # unihan is not really conditional
+ # https://bugzilla.gnome.org/show_bug.cgi?id=768210#c5
+ # https://gitlab.gnome.org/GNOME/gucharmap/issues/13
+ gnome2_src_configure \
+ --disable-static \
+ --with-unicode-data=/usr/share/unicode-data \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}