summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-fs/cifs-utils/files/cifs-utils-6.10-ln_in_destdir.patch19
1 files changed, 15 insertions, 4 deletions
diff --git a/net-fs/cifs-utils/files/cifs-utils-6.10-ln_in_destdir.patch b/net-fs/cifs-utils/files/cifs-utils-6.10-ln_in_destdir.patch
index b2c00bf500db..6952d72cf5c4 100644
--- a/net-fs/cifs-utils/files/cifs-utils-6.10-ln_in_destdir.patch
+++ b/net-fs/cifs-utils/files/cifs-utils-6.10-ln_in_destdir.patch
@@ -1,14 +1,25 @@
+Fix sandbox violation caused by calling ln in /sbin instead of $(DESTDIR)/sbin
+
+Also fixed an inverted race condition when installing with MAKEOPTS="-j1"
+
+jer found this:
+ install-root_sbinPROGRAMS is called from install-data-am but
+ install-exec-hook is called from install-exec-am
+
+So moving the failing ln call into install-data-hook for now...
+
--- cifs-utils-6.10/Makefile.am
+++ cifs-utils-6.10/Makefile.am
-@@ -119,10 +119,10 @@
+@@ -118,11 +118,9 @@
+
SUBDIRS = contrib
- install-exec-hook:
+-install-exec-hook:
- (cd $(ROOTSBINDIR) && ln -sf mount.cifs mount.smb3)
-+ (cd $(DESTDIR)$(ROOTSBINDIR) && ln -sf mount.cifs mount.smb3)
-
+-
install-data-hook:
- (cd $(man8dir) && ln -sf mount.cifs.8 mount.smb3.8)
++ (cd $(DESTDIR)$(ROOTSBINDIR) && ln -sf mount.cifs mount.smb3)
+ (cd $(DESTDIR)$(man8dir) && ln -sf mount.cifs.8 mount.smb3.8)
uninstall-hook: