summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/tmuxp/Manifest1
-rw-r--r--app-misc/tmuxp/tmuxp-1.5.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/tmuxp/Manifest b/app-misc/tmuxp/Manifest
index 0487122df719..b21ebcfcb43e 100644
--- a/app-misc/tmuxp/Manifest
+++ b/app-misc/tmuxp/Manifest
@@ -1 +1,2 @@
DIST tmuxp-1.5.3.tar.gz 71095 BLAKE2B 37c62eb9d334e5cca47cb4687403ad73cfffa57919770d754fb595dc26f76d248001e62e82eb7246104b74e752701ce57fa56cc78e8eeec8dc49e1522fc6b72c SHA512 9d803e715b1b75aec8940996db579ef545f5d291e64c7d4551930ec5ad683d8a5f737cc22328f0d528e709da6f613c8b3451637ec3e93ac7e9d34aea64faa0e0
+DIST tmuxp-1.5.4.tar.gz 843048 BLAKE2B 863b428198e8bb2895802ba7365ac2ec43fc75c708b41929934b6803c79b8f6436b5233ad567f1ab010e6ae372d89261a7ee19953fa01ab9defd1e290b6da621 SHA512 f6fdecff23de883076461fcef3fb1555242d8a96f1c05c88fd0fb3216bbb99fb321680f484972b10f54ff87eb032d8627397f76960262612954eaab6bbf7c7a9
diff --git a/app-misc/tmuxp/tmuxp-1.5.4.ebuild b/app-misc/tmuxp/tmuxp-1.5.4.ebuild
new file mode 100644
index 000000000000..b801bfdbf430
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.5.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/kaptan[${PYTHON_USEDEP}]
+ >=dev-python/libtmux-0.8[${PYTHON_USEDEP}]
+ <dev-python/libtmux-0.9[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ <dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-4.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ SHELL="/bin/bash" pytest -vv || die "Tests fail with ${EPYTHON}"
+}