summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/netpbm/files/netpbm-10.66-failing-tests.patch28
-rw-r--r--media-libs/netpbm/files/netpbm-10.66-jasper-hack.patch41
-rw-r--r--media-libs/netpbm/files/netpbm-10.66-jbig-2.patch19
-rw-r--r--media-libs/netpbm/files/netpbm-10.66-jpeg-dirs.patch28
-rw-r--r--media-libs/netpbm/files/netpbm-10.66-options-case.patch105
-rw-r--r--media-libs/netpbm/files/netpbm-10.66-wordaccess_be_aligned.patch23
6 files changed, 0 insertions, 244 deletions
diff --git a/media-libs/netpbm/files/netpbm-10.66-failing-tests.patch b/media-libs/netpbm/files/netpbm-10.66-failing-tests.patch
deleted file mode 100644
index 63260de2e490..000000000000
--- a/media-libs/netpbm/files/netpbm-10.66-failing-tests.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-punt failing tests; already notified upstream
-
---- a/test/Test-Order
-+++ b/test/Test-Order
-@@ -50,7 +50,6 @@ pamditherbw.test
- pbmclean.test
- pamcut.test
- pnmcat.test
--pamflip.test
- pamenlarge.test
- pnminvert.test
- pamchannel.test
-@@ -70,7 +69,6 @@ ppmmix.test
-
- # Symmetry test
-
--symmetry.test
-
- # Format converter tests
-
-@@ -87,7 +85,6 @@ ppmdfont.test
- pnm-plain-roundtrip.test
- pnm-pam-roundtrip.test
- pnminvert-roundtrip.test
--pamflip-roundtrip.test
- pamdepth-roundtrip.test
- pad-crop-roundtrip.test
- cut-paste-roundtrip.test
diff --git a/media-libs/netpbm/files/netpbm-10.66-jasper-hack.patch b/media-libs/netpbm/files/netpbm-10.66-jasper-hack.patch
deleted file mode 100644
index 285475dab062..000000000000
--- a/media-libs/netpbm/files/netpbm-10.66-jasper-hack.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-https://bugs.gentoo.org/513240
-
-the jasper headers are horribly broken and break things like stdbool.h.
-re-order the includes to work around this.
-
---- a/converter/other/jpeg2000/jpeg2ktopam.c
-+++ b/converter/other/jpeg2000/jpeg2ktopam.c
-@@ -13,13 +13,14 @@
- #define _XOPEN_SOURCE 600
- #include <string.h>
-
-+#include <jasper/jasper.h>
-+
- #include "pm_c_util.h"
- #include "pam.h"
- #include "shhopt.h"
- #include "nstring.h"
- #include "mallocvar.h"
-
--#include <jasper/jasper.h>
- #include "libjasper_compat.h"
-
- enum compmode {COMPMODE_INTEGER, COMPMODE_REAL};
---- a/converter/other/jpeg2000/pamtojpeg2k.c
-+++ b/converter/other/jpeg2000/pamtojpeg2k.c
-@@ -13,13 +13,14 @@
- #define _XOPEN_SOURCE 600
- #include <string.h>
-
-+#include <jasper/jasper.h>
-+
- #include "pm_c_util.h"
- #include "pam.h"
- #include "shhopt.h"
- #include "nstring.h"
- #include "mallocvar.h"
-
--#include <jasper/jasper.h>
- #include "libjasper_compat.h"
-
-
diff --git a/media-libs/netpbm/files/netpbm-10.66-jbig-2.patch b/media-libs/netpbm/files/netpbm-10.66-jbig-2.patch
deleted file mode 100644
index f7e8cf80d6c4..000000000000
--- a/media-libs/netpbm/files/netpbm-10.66-jbig-2.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-fix building w/jbig-2.x
-
---- a/converter/other/jbig/jbigtopnm.c
-+++ b/converter/other/jbig/jbigtopnm.c
-@@ -230,8 +230,12 @@ int main (int argc, char **argv)
- if (ferror(fin))
- pm_error("Problem while reading input file '%s", fnin);
- if (result != JBG_EOK && result != JBG_EOK_INTR)
-- pm_error("Problem with input file '%s': %s\n",
-- fnin, jbg_strerror(result, JBG_EN));
-+ pm_error("Problem with input file '%s': %s\n", fnin,
-+#ifdef JBG_EN
-+ jbg_strerror(result, JBG_EN));
-+#else
-+ jbg_strerror(result));
-+#endif
- if (plane >= 0 && jbg_dec_getplanes(&s) <= plane)
- pm_error("Image has only %d planes!\n", jbg_dec_getplanes(&s));
-
diff --git a/media-libs/netpbm/files/netpbm-10.66-jpeg-dirs.patch b/media-libs/netpbm/files/netpbm-10.66-jpeg-dirs.patch
deleted file mode 100644
index fcf98211ba01..000000000000
--- a/media-libs/netpbm/files/netpbm-10.66-jpeg-dirs.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-use same -I style as converter/other/Makefile so people can disable these
-
---- a/converter/other/jbig/Makefile
-+++ b/converter/other/jbig/Makefile
-@@ -11,7 +11,9 @@ LIBJBIG_OBJECTS = jbig.o jbig_tab.o
-
- EXTERN_INCLUDES =
- ifneq ($(JBIGHDR_DIR),NONE)
-- EXTERN_INCLUDES += -I$(JBIGHDR_DIR)
-+ ifneq ($(JBIGHDR_DIR)x,x)
-+ EXTERN_INCLUDES += -I$(JBIGHDR_DIR)
-+ endif
- endif
-
- ifneq ($(JBIGHDR_DIR),NONE)
---- a/converter/other/jpeg2000/Makefile
-+++ b/converter/other/jpeg2000/Makefile
-@@ -11,7 +11,9 @@ include $(BUILDDIR)/config.mk
-
- EXTERN_INCLUDES =
- ifneq ($(JASPERHDR_DIR),NONE)
-- EXTERN_INCLUDES += -I$(JASPERHDR_DIR)
-+ ifneq ($(JASPERHDR_DIR)x,x)
-+ EXTERN_INCLUDES += -I$(JASPERHDR_DIR)
-+ endif
- endif
-
-
diff --git a/media-libs/netpbm/files/netpbm-10.66-options-case.patch b/media-libs/netpbm/files/netpbm-10.66-options-case.patch
deleted file mode 100644
index a865bc1f4514..000000000000
--- a/media-libs/netpbm/files/netpbm-10.66-options-case.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-r2175 | giraffedata | 2014-04-01 22:28:23 -0400 (Tue, 01 Apr 2014) | 1 line
-
-Fix bug: inconsistent use of upper and lower case Y and N in make file variables. Make it consistently upper case
-
---- buildtools/configure.pl (revision 2174)
-+++ buildtools/configure.pl (revision 2175)
-@@ -835,16 +835,16 @@ sub getLibTypes($$$$$$$$) {
- my $response = prompt("(y)es or (n)o", $default);
-
- if (uc($response) =~ /^(Y|YES)$/) {
-- $staticlib_too = "y";
-+ $staticlib_too = "Y";
- } elsif (uc($response) =~ /^(N|NO)$/) {
-- $staticlib_too = "n";
-+ $staticlib_too = "N";
- } else {
- print("'$response' isn't one of the choices. \n" .
- "You must choose 'yes' or 'no' (or 'y' or 'n').\n");
- exit 12;
- }
- } else {
-- $staticlib_too = "n";
-+ $staticlib_too = "N";
- }
- print("\n");
-
---- config.mk.in (revision 2174)
-+++ config.mk.in (revision 2175)
-@@ -503,7 +503,7 @@ LINUXSVGAHDR_DIR =
- #LINUXSVGALIB = /usr/lib/libvga.so
- #LINUXSVGAHDR_DIR = /usr/include/vgalib
-
--# If you don't want any network functions, set OMIT_NETWORK to "y".
-+# If you don't want any network functions, set OMIT_NETWORK to "Y".
- # The only thing that requires network functions is the option in
- # ppmtompeg to run it on multiple computers simultaneously. On some
- # systems network functions don't work or we haven't figured out how to
-@@ -512,11 +512,11 @@ OMIT_NETWORK =
- #DJGPP/Windows, Tru64:
- # (there's some minor header problem that prevents network functions from
- # building on Tru64 2000.10.06)
--#OMIT_NETWORK = y
-+#OMIT_NETWORK = Y
-
- # These are -l options to link in the network libraries. Often, these are
- # built into the standard C library, so this can be null. This is irrelevant
--# if OMIT_NETWORK is "y".
-+# if OMIT_NETWORK is "Y".
-
- NETWORKLD =
- # Solaris, SunOS:
-@@ -602,12 +602,12 @@ NETPBMLIBSUFFIX = so
- # Windows shared library:
- #NETPBMLIBSUFFIX = dll
-
--#STATICLIB_TOO is "y" to signify that you want a static library built
-+#STATICLIB_TOO is "Y" to signify that you want a static library built
- #and installed in addition to whatever library type you specified by
- #NETPBMLIBTYPE. If NETPBMLIBTYPE specified a static library,
- #STATICLIB_TOO simply has no effect.
--STATICLIB_TOO = y
--#STATICLIB_TOO = n
-+STATICLIB_TOO = Y
-+#STATICLIB_TOO = N
-
- #STATICLIBSUFFIX is the suffix that static libraries have. It's
- #meaningless if you aren't building static libraries.
---- GNUmakefile (revision 2174)
-+++ GNUmakefile (revision 2175)
-@@ -396,19 +396,19 @@ lib/install.hdr:
- $(MAKE) -C $(dir $@) -f $(SRCDIR)/lib/Makefile \
- SRCDIR=$(SRCDIR) BUILDDIR=$(BUILDDIR) $(notdir $@)
-
--ifeq ($(STATICLIB_TOO),y)
--BUILD_STATIC = y
-+ifeq ($(STATICLIB_TOO),Y)
-+BUILD_STATIC = Y
- else
- ifeq ($(NETPBMLIBTYPE),unixstatic)
-- BUILD_STATIC = y
-+ BUILD_STATIC = Y
- else
-- BUILD_STATIC = n
-+ BUILD_STATIC = N
- endif
- endif
-
- .PHONY: install.staticlib
- install.staticlib:
--ifeq ($(BUILD_STATIC),y)
-+ifeq ($(BUILD_STATIC),Y)
- $(MAKE) -C lib -f $(SRCDIR)/lib/Makefile \
- SRCDIR=$(SRCDIR) BUILDDIR=$(BUILDDIR) install.staticlib
- endif
---- lib/Makefile (revision 2174)
-+++ lib/Makefile (revision 2175)
-@@ -175,7 +175,7 @@ else
- ifeq ($(STATICLIB_TOO),Y)
- BUILD_STATICLIB = Y
- else
-- BUILD_STATICLIB = n
-+ BUILD_STATICLIB = N
- endif
- endif
-
diff --git a/media-libs/netpbm/files/netpbm-10.66-wordaccess_be_aligned.patch b/media-libs/netpbm/files/netpbm-10.66-wordaccess_be_aligned.patch
deleted file mode 100644
index 0da719ae07d4..000000000000
--- a/media-libs/netpbm/files/netpbm-10.66-wordaccess_be_aligned.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-https://bugs.gentoo.org/547252
-
-------------------------------------------------------------------------
-r2395 | giraffedata | 2015-01-23 13:51:17 -0500 (Fri, 23 Jan 2015) | 1 line
-
-Fix syntax error
-
-build: fix compile failure in wordint_access_be.h with
-Bigendian target platforms.
-
-Index: trunk/lib/util/wordaccess_be_aligned.h
-===================================================================
---- trunk/lib/util/wordaccess_be_aligned.h (revision 2394)
-+++ trunk/lib/util/wordaccess_be_aligned.h (revision 2395)
-@@ -24,7 +24,7 @@ bytesToWordint(wordintBytes bytes) {
- static __inline__ void
- wordintToBytes(wordintBytes * const bytesP,
- wordint const wordInt) {
-- uint16_t const hi = ((wordInt >> 48) & 0xFF)
-+ uint16_t const hi = ((wordInt >> 48) & 0xFF);
- uint16_t const mh = ((wordInt >> 32) & 0xFF);
- uint16_t const ml = ((wordInt >> 24) & 0xFF);
- uint16_t const lo = ((wordInt >> 0) & 0xFF);