summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/qutebrowser/qutebrowser-2.5.4.ebuild15
1 files changed, 15 insertions, 0 deletions
diff --git a/www-client/qutebrowser/qutebrowser-2.5.4.ebuild b/www-client/qutebrowser/qutebrowser-2.5.4.ebuild
index 30a3498c8cf8..59de8c56dd4a 100644
--- a/www-client/qutebrowser/qutebrowser-2.5.4.ebuild
+++ b/www-client/qutebrowser/qutebrowser-2.5.4.ebuild
@@ -131,6 +131,12 @@ python_install_all() {
einstalldocs
}
+pkg_preinst() {
+ xdg_pkg_preinst
+
+ has_version "${CATEGORY}/${PN}[qt6]" && QUTEBROWSER_HAD_QT6=
+}
+
pkg_postinst() {
xdg_pkg_postinst
@@ -139,4 +145,13 @@ pkg_postinst() {
elog "have additional dependencies not covered by this ebuild, for example"
elog "view_in_mpv needs media-video/mpv[lua] and net-misc/yt-dlp."
fi
+
+ if [[ -v QUTEBROWSER_HAD_QT6 ]]; then
+ ewarn "This is a downgrade from Qt6-based ${PN} to Qt5-based, and this"
+ ewarn "older version of ${PN} will /not/ warn on startup that this is"
+ ewarn "going to destroy some browsing data (e.g. cookies) when older chromium"
+ ewarn "version tries to use the newer ~/.local/share/${PN}/webengine."
+ ewarn
+ ewarn "It is recommended to backup in case or go back to Qt6."
+ fi
}