summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/multi_json/Manifest1
-rw-r--r--dev-ruby/multi_json/multi_json-1.11.3.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/multi_json/Manifest b/dev-ruby/multi_json/Manifest
index 7b69fb8e047c..c74d8e7ba7b7 100644
--- a/dev-ruby/multi_json/Manifest
+++ b/dev-ruby/multi_json/Manifest
@@ -1,2 +1,3 @@
DIST multi_json-1.11.2.tar.gz 24748 SHA256 656e92aa19d5e0fc08c1f30f30e328479631407d1dd893c058cac88dd0777313 SHA512 bb4b1835cd5d4355003dfc1085cbb71913766d6e8210dab93d8aed5e6612a29f60420efd550f566c63da5358e1ce2daf04049c1d635caf07244f117cff0f3794 WHIRLPOOL 8216b793687c0d1ec30eaaefce5320e6124468adb3bbd905455ecf0ae66e962d662f492f91854f00077e15d9ae9b15e43a58f10d79acc6469fc668462bcce59f
+DIST multi_json-1.11.3.tar.gz 24788 SHA256 3dc780a837b0ad85d0ffbfe876b04246ef7f544b22859262cce76a94a70ccdb3 SHA512 9afbcf30755b189c26e83f8a416115ab7c5b64875ca3508e5b4d4eff6636eba536896b2801e314187ce3ad44414934f6605fcbae4850d979d348952df0fd5e6e WHIRLPOOL ab843c487028ffa42b1b5786f93502b0f910ce8865f02e9ab205c090251a073b0635d1b97909e7589ee314a30b3e3852615027215cc4f407b1b8c2094390f552
DIST multi_json-1.9.3.gem 30720 SHA256 631390d4b6c3d3753a3df0c28339c8e7840704083dfdcefb1323a22ab97b2281 SHA512 7f06747e760a63b6421dfda480522924f12bd00ad63f95414f6624173b9b9b255b139f9dc33d2d2a8d19b232f99a005033e00e3a0b223be992f73d142a55b8b5 WHIRLPOOL a96f1c1e53865e153bc83079fc70b69af6c941c4995f4215317ca53567532d1406adb174683fc8c5229fdc3563f5e8d3c2c662d77cf9d9d55367aab2df5b34f0
diff --git a/dev-ruby/multi_json/multi_json-1.11.3.ebuild b/dev-ruby/multi_json/multi_json-1.11.3.ebuild
new file mode 100644
index 000000000000..4b2500f82c1d
--- /dev/null
+++ b/dev-ruby/multi_json/multi_json-1.11.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/intridea/multi_json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="https://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-1.0 =dev-ruby/activesupport-3* )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec:3 dev-ruby/yard )"
+
+ruby_add_bdepend "test? ( dev-ruby/json
+ dev-ruby/yajl-ruby )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die "Unable to remove bundler."
+
+ # Remove unimportant rspec options not supported by rspec 2.6.
+ rm .rspec || die
+
+ # Remove specs specific to oj since we don't package oj yet.
+ sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' \
+ -e '/Oj does not create symbols on parse/,/^ end/ s:^:#:' \
+ -e '/with Oj.default_settings/,/^ end/ s:^:#:' \
+ -e '/using one-shot parser/,/^ end/ s:^:#:' \
+ spec/multi_json_spec.rb
+
+ # Avoid simplecov which only works with ruby 1.9
+ sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/spec_helper.rb || die
+
+ # Remove unpackaged and for our purposes unneeded coveralls
+ sed -i -e '/coveralls/d' spec/spec_helper.rb || die
+
+ # Avoid testing unpackaged adapters
+ rm spec/{gson,jr_jackson,oj}_adapter_spec.rb || die
+}
+
+each_ruby_test() {
+ for t in spec/*_spec.rb; do
+ ${RUBY} -S rspec-3 ${t} || die
+ done
+}