summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/gnushogi/files/gnushogi-1.4.1-fno-common.patch20
-rw-r--r--games-board/gnushogi/gnushogi-1.4.1-r1.ebuild21
2 files changed, 34 insertions, 7 deletions
diff --git a/games-board/gnushogi/files/gnushogi-1.4.1-fno-common.patch b/games-board/gnushogi/files/gnushogi-1.4.1-fno-common.patch
new file mode 100644
index 000000000000..510590b82c09
--- /dev/null
+++ b/games-board/gnushogi/files/gnushogi-1.4.1-fno-common.patch
@@ -0,0 +1,20 @@
+--- a/gnushogi/cursesdsp.c
++++ b/gnushogi/cursesdsp.c
+@@ -71,7 +71,6 @@
+
+ unsigned short MV[MAXDEPTH];
+ int MSCORE;
+-char *DRAW;
+
+ /* Forward declarations. */
+ /* FIXME: change this name, puh-leeze! */
+--- a/gnushogi/rawdsp.c
++++ b/gnushogi/rawdsp.c
+@@ -48,7 +48,6 @@
+ int MSCORE;
+
+ int mycnt1, mycnt2;
+-char *DRAW;
+ extern char *InPtr;
+ extern short pscore[];
+
diff --git a/games-board/gnushogi/gnushogi-1.4.1-r1.ebuild b/games-board/gnushogi/gnushogi-1.4.1-r1.ebuild
index ebef0138a0f3..7d1bde2639a8 100644
--- a/games-board/gnushogi/gnushogi-1.4.1-r1.ebuild
+++ b/games-board/gnushogi/gnushogi-1.4.1-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils
+EAPI=7
+
+inherit desktop
DESCRIPTION="Japanese version of chess (commandline + X-Version)"
HOMEPAGE="https://www.gnu.org/software/gnushogi/"
@@ -13,12 +14,16 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="X"
-RDEPEND="sys-libs/ncurses:0
+RDEPEND="
+ sys-libs/ncurses:0=
X? ( x11-libs/libXaw )"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
>=sys-devel/bison-1.34
>=sys-devel/flex-2.5"
+PATCHES=( "${FILESDIR}"/${PN}-1.4.1-fno-common.patch )
+
src_prepare() {
default
@@ -40,11 +45,13 @@ src_install() {
dobin gnushogi/gnushogi
doman doc/gnushogi.6
doinfo doc/gnushogi.info
- if use X ; then
+
+ if use X; then
dobin xshogi/xshogi
doman doc/xshogi.6
make_desktop_entry xshogi XShogi
fi
- dolib gnushogi/gnushogi.bbk
+
+ dolib.a gnushogi/gnushogi.bbk
dodoc README NEWS CONTRIB doc/gnushogi/*.html
}