summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-laptop/mbpfan/mbpfan-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-laptop/mbpfan/mbpfan-9999.ebuild b/app-laptop/mbpfan/mbpfan-9999.ebuild
index 357bf95cf287..b530d9569fa7 100644
--- a/app-laptop/mbpfan/mbpfan-9999.ebuild
+++ b/app-laptop/mbpfan/mbpfan-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -29,6 +29,9 @@ src_compile() {
src_install() {
emake DESTDIR="${ED}" install
+ # Decompress the man page to enable PM auto compression
+ gzip -d "${ED}"/usr/share/man/man8/mbpfan.8.gz || die
+
# Remove the empty systemd unit directory
# It doesn't actually install the unit file
rmdir --ignore-fail-on-non-empty -p "${ED%/}/lib/systemd/system" || die