summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pendulum/pendulum-2.1.2-r1.ebuild28
1 files changed, 11 insertions, 17 deletions
diff --git a/dev-python/pendulum/pendulum-2.1.2-r1.ebuild b/dev-python/pendulum/pendulum-2.1.2-r1.ebuild
index 32b705122dca..602bea9a4764 100644
--- a/dev-python/pendulum/pendulum-2.1.2-r1.ebuild
+++ b/dev-python/pendulum/pendulum-2.1.2-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Drop-in replacement for the standard datetime class"
@@ -15,22 +15,16 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~x86"
-# Requires timezone information which is not installed by default
-# with dev-python/pytzdata, and otherwise approx. 50 out of 1600
-# tests are failing for now. Keeping the test dependencies
-# commented for future tests fixups
-RESTRICT="test"
-
DEPEND="
dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytzdata[${PYTHON_USEDEP}]"
+ dev-python/pytzdata[${PYTHON_USEDEP}]
+"
RDEPEND="${DEPEND}"
-
-#BDEPEND="
-# test? (
-# dev-python/babel[${PYTHON_USEDEP}]
-# dev-python/freezegun[${PYTHON_USEDEP}]
-# dev-python/pytz[${PYTHON_USEDEP}]
-# )"
-
-# distutils_enable_tests pytest
+BDEPEND="
+ test? (
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest