summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/iscan-plugin-gt-x820/iscan-plugin-gt-x820-2.2.0.1.ebuild47
1 files changed, 15 insertions, 32 deletions
diff --git a/media-gfx/iscan-plugin-gt-x820/iscan-plugin-gt-x820-2.2.0.1.ebuild b/media-gfx/iscan-plugin-gt-x820/iscan-plugin-gt-x820-2.2.0.1.ebuild
index ba7639fb7a51..a368e5a4192d 100644
--- a/media-gfx/iscan-plugin-gt-x820/iscan-plugin-gt-x820-2.2.0.1.ebuild
+++ b/media-gfx/iscan-plugin-gt-x820/iscan-plugin-gt-x820-2.2.0.1.ebuild
@@ -1,29 +1,26 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit rpm versionator multilib
+inherit rpm
-MY_PV="$(get_version_component_range 1-3)"
-MY_PVR="$(replace_version_separator 3 -)"
+MY_PV="$(ver_cut 1-3)"
+MY_PVR="$(ver_rs 3 -)"
DESCRIPTION="Epson Perfection V600 scanner plugin for SANE 'epkowa' backend"
HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
SRC_URI="amd64? ( https://dev.gentoo.org/~flameeyes/avasys/${PN}-${MY_PVR}.x86_64.rpm )
x86? ( https://dev.gentoo.org/~flameeyes/avasys/${PN}-${MY_PVR}.i386.rpm )"
+S="${WORKDIR}"
LICENSE="AVASYS"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
-
DEPEND=">=media-gfx/iscan-2.21.0"
RDEPEND="${DEPEND}"
-S="${WORKDIR}"
-
QA_PREBUILT="/opt/iscan/lib/libesintA1.so*"
src_configure() { :; }
@@ -41,50 +38,36 @@ src_install() {
doexe "${WORKDIR}/usr/$(get_libdir)/iscan/"*
}
-pkg_setup() {
- basecmds=(
- "iscan-registry --COMMAND interpreter usb 0x04b8 0x013a /opt/iscan/lib/libesintA1 /usr/share/iscan/esfwA1.bin"
- )
-}
-
pkg_postinst() {
elog
elog "Firmware file esfwA1.bin for Epson Perfection V600"
- elog "has been installed in /usr/share/iscan."
+ elog "has been installed in ${EROOT}/usr/share/iscan."
elog
# Only register scanner on new installs
- [[ -n ${REPLACING_VERSIONS} ]] && return
+ [[ -n "${REPLACING_VERSIONS}" ]] && return
# Needed for scanner to work properly.
- if [[ ${ROOT} == "/" ]]; then
- for basecmd in "${basecmds[@]}"; do
- eval ${basecmd/COMMAND/add}
- done
+ if [[ -z "${EROOT}" ]]; then
+ iscan-registry --add interpreter usb 0x04b8 0x013a /opt/iscan/lib/libesintA1 /usr/share/iscan/esfwA1.bin || die
elog "New firmware has been registered automatically."
elog
else
ewarn "Unable to register the plugin and firmware when installing outside of /."
ewarn "execute the following command yourself:"
- for basecmd in "${basecmds[@]}"; do
- ewarn "${basecmd/COMMAND/add}"
- done
+ ewarn "iscan-registry --add interpreter usb 0x04b8 0x013a /opt/iscan/lib/libesintA1 /usr/share/iscan/esfwA1.bin"
fi
}
pkg_prerm() {
# Only unregister on on uninstall
- [[ -n ${REPLACED_BY_VERSION} ]] && return
+ [[ -n "${REPLACED_BY_VERSION}" ]] && return
- if [[ ${ROOT} == "/" ]]; then
- for basecmd in "${basecmds[@]}"; do
- eval ${basecmd/COMMAND/remove}
- done
+ if [[ -z "${EROOT}" ]]; then
+ iscan-registry --remove interpreter usb 0x04b8 0x013a /opt/iscan/lib/libesintA1 /usr/share/iscan/esfwA1.bin || die
else
ewarn "Unable to register the plugin and firmware when installing outside of /."
ewarn "execute the following command yourself:"
- for basecmd in "${basecmds[@]}"; do
- ewarn "${basecmd/COMMAND/remove}"
- done
+ ewarn "iscan-registry --remove interpreter usb 0x04b8 0x013a /opt/iscan/lib/libesintA1 /usr/share/iscan/esfwA1.bin"
fi
}