summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/android-studio/Manifest1
-rw-r--r--dev-util/android-studio/android-studio-4.0.1.0.193.6626763.ebuild129
2 files changed, 130 insertions, 0 deletions
diff --git a/dev-util/android-studio/Manifest b/dev-util/android-studio/Manifest
index 62fe99761519..da67a9a2fede 100644
--- a/dev-util/android-studio/Manifest
+++ b/dev-util/android-studio/Manifest
@@ -3,3 +3,4 @@ DIST android-studio-ide-192.6200805-linux.tar.gz 803889418 BLAKE2B dcbfb2eef2994
DIST android-studio-ide-192.6241897-linux.tar.gz 803889879 BLAKE2B 5d2d24de5daa317c53513e2a8985e6998891043b1fe730fadd04c6f8ca9702e8be9f2444d73e47578e4d368951897003170ea7e96c569f038f18b98286478df0 SHA512 7ef878ecbc17f542b2faaf18965a294941424f835c21250ff7fde5e29ddc261b35e5e7391cc50803babdcfc98e25390b806f33d0f7dc0f0bcaf7a94feeeab82e
DIST android-studio-ide-192.6308749-linux.tar.gz 803133146 BLAKE2B 159192929a0cd526c789d915ad15bcc7f6d92e86f1e09f178548ae1055d3086e31f8fb88ceaff55d514728c755eacc84b2abe3c754542fea9e1f5ea117606df5 SHA512 86ce587c2e997dc623498fcf34060568fe58a26f8d287102fc458d963756ba98a4782709cb45f54e847658f64ad263ae2f59bbe1024a5a20be79be821ba9db00
DIST android-studio-ide-192.6392135-linux.tar.gz 810065819 BLAKE2B e133c346f7ee9ac775efc492f2f0d73a1f82bb95dcf2f108e20fa9201639bff79efa10d67b38187791e1473df3c1ac60c387e741bf5c5fa30b97766ca5f15107 SHA512 246e8b201b99e0d218699a21293c4c85ea334e04d2b13a0ea72e8595e253fe196af2ff9a20920d86a07348aaa64147a13a97a550debe6053d037b49821dc5c8f
+DIST android-studio-ide-193.6626763-linux.tar.gz 907569312 BLAKE2B 602170eea29e632dd5720ef364510a20056a4d98c61e77d5436a2f624a60e0cfa4e0533174613a74f359d8fdeb4e87489caeb5c34b292fcdc35843a76440a9a3 SHA512 7fba99efccdf3bbbfcbc94625aba3789b1bad0e830b2ac890bd681b9089e6789e87b2dbdc80c6ef3d8db2b2438678a8bb58aefb3c311f61f619042ab1ec9dfac
diff --git a/dev-util/android-studio/android-studio-4.0.1.0.193.6626763.ebuild b/dev-util/android-studio/android-studio-4.0.1.0.193.6626763.ebuild
new file mode 100644
index 000000000000..e9812c3699a7
--- /dev/null
+++ b/dev-util/android-studio/android-studio-4.0.1.0.193.6626763.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit desktop eutils java-pkg-2
+
+RESTRICT="strip"
+QA_PREBUILT="
+ opt/${PN}/bin/fsnotifier*
+ opt/${PN}/bin/libdbm64.so
+ opt/${PN}/bin/lldb/*
+ opt/${PN}/custom-jdk/*
+ opt/${PN}/lib/pty4j-native/linux/*/libpty.so
+ opt/${PN}/plugins/android/lib/libwebp_jni*.so
+ opt/${PN}/plugins/android/resources/installer/*
+ opt/${PN}/plugins/android/resources/perfetto/*
+ opt/${PN}/plugins/android/resources/simpleperf/*
+ opt/${PN}/plugins/android/resources/transport/*
+"
+
+VER_CMP=( $(ver_rs 1- ' ') )
+if [[ ${#VER_CMP[@]} -eq 6 ]]; then
+ STUDIO_V=$(ver_cut 1-4)
+ BUILD_V=$(ver_cut 5-6)
+else
+ STUDIO_V=$(ver_cut 1-3)
+ BUILD_V=$(ver_cut 4-5)
+fi
+
+DESCRIPTION="Android development environment based on IntelliJ IDEA"
+HOMEPAGE="http://developer.android.com/sdk/installing/studio.html"
+SRC_URI="https://dl.google.com/dl/android/studio/ide-zips/${STUDIO_V}/${PN}-ide-${BUILD_V}-linux.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="custom-jdk selinux"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-java/commons-logging:0
+ dev-java/log4j:0"
+
+RDEPEND="${DEPEND}
+ >=virtual/jdk-1.7
+ selinux? ( sec-policy/selinux-android )
+ >=app-arch/bzip2-1.0.6-r4
+ dev-java/commons-logging:0
+ dev-java/log4j:0
+ >=dev-libs/expat-2.1.0-r3
+ >=dev-libs/libffi-3.0.13-r1
+ >=media-libs/fontconfig-2.10.92
+ >=media-libs/freetype-2.5.5
+ >=media-libs/libpng-1.2.51
+ >=media-libs/mesa-10.2.8[X(+)]
+ || ( gnome-extra/zenity kde-apps/kdialog x11-apps/xmessage x11-libs/libnotify )
+ sys-libs/ncurses-compat:5[tinfo]
+ >=sys-libs/zlib-1.2.8-r1
+ >=x11-libs/libX11-1.6.2
+ >=x11-libs/libXau-1.0.7-r1
+ >=x11-libs/libXdamage-1.1.4-r1
+ >=x11-libs/libXdmcp-1.1.1-r1
+ >=x11-libs/libXext-1.3.2
+ >=x11-libs/libXfixes-5.0.1
+ >=x11-libs/libXrender-0.9.8
+ >=x11-libs/libXxf86vm-1.1.3
+ >=x11-libs/libdrm-2.4.46
+ >=x11-libs/libxcb-1.9.1
+ >=x11-libs/libxshmfence-1.1"
+BDEPEND="dev-util/patchelf"
+S=${WORKDIR}/${PN}
+PATCHES=( "${FILESDIR}/0001-use-java-home-before-bundled.patch" )
+
+src_prepare() {
+ eapply "${PATCHES[@]}"
+ eapply_user
+
+ # This is really a bundled jdk not a jre
+ # If custom-jdk is not set bundled jre is replaced with system vm/jdk
+ if use custom-jdk; then
+ mv -f "${S}/jre" "${S}/custom-jdk" || die "Could not move bundled jdk"
+ else
+ rm -rf "${S}/jre" || die "Could not remove bundled jdk"
+ fi
+ # Replace bundled jars with system
+ # has problems with newer jdom:0 not updated to jdom:2
+ cd "${S}/lib" || die
+ local JARS="commons-logging log4j"
+ local j
+ for j in ${JARS}; do
+ rm -v ${j/:*/}*.jar || die
+ java-pkg_jar-from ${j}
+ done
+
+ cd "${S}" || die
+
+ # bug 629404
+ echo "-Djdk.util.zip.ensureTrailingSlash=false" >> bin/studio64.vmoptions || die
+ echo "-Djdk.util.zip.ensureTrailingSlash=false" >> bin/studio.vmoptions || die
+}
+
+src_compile() {
+ patchelf --set-rpath '$ORIGIN' bin/lldb/lib/readline.so || die "Failed to fix insecure RPATH"
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+
+ insinto "${dir}"
+ doins -r *
+
+ # This is really a bundled jdk not a jre
+ # If custom-jdk is not set bundled jre is replaced with system vm/jdk
+ if use custom-jdk; then
+ dosym "custom-jdk" "${dir}/jre"
+ else
+ dosym "../../etc/java-config-2/current-system-vm" "${dir}/jre"
+ fi
+
+ fperms 755 "${dir}"/bin/{fsnotifier{,64},printenv.py,restart.py,format.sh,inspect.sh,studio.sh}
+ fperms -R 755 "${dir}"/bin/lldb/{android,bin}
+ if use custom-jdk; then
+ fperms -R 755 "${dir}"/jre/{bin,jre/bin}
+ fperms 755 ${dir}/jre/jre/lib/jexec
+ fi
+
+ newicon "bin/studio.png" "${PN}.png"
+ make_wrapper ${PN} ${dir}/bin/studio.sh
+ make_desktop_entry ${PN} "Android Studio" ${PN} "Development;IDE" "StartupWMClass=jetbrains-studio"
+}