summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-tex/tex4ht/Manifest1
-rw-r--r--dev-tex/tex4ht/tex4ht-20090611_p1038-r9.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-tex/tex4ht/Manifest b/dev-tex/tex4ht/Manifest
index 1043e163ed32..d9cb477c1f1f 100644
--- a/dev-tex/tex4ht/Manifest
+++ b/dev-tex/tex4ht/Manifest
@@ -1,2 +1,3 @@
DIST tex4ht-1.0.2009_06_11_1038.tar.gz 2576719 BLAKE2B d04fd7b5f614414a200b01f11bea9880ea12561873fc08cb2f5f6f62167d6128cc50abbeeee0c7eae5d80046f6d3b504493d66262153c5a534fd1b56bfa1dfcd SHA512 868961c16da63ef20a8af3ec3e56a2b6c518a291cdbc3974f701773dbb55b844f0df06aae4c7b481c96b9e2ba29cb0f1ed1279b6f32340e4708e31bb67170963
DIST tex4ht-texlive-2019-03-22.tar.xz 868992 BLAKE2B 662cc23de1b3b5f4e3d504655b5b3d87740fea045bef7987cbe2d81971e73375bd88d8ab111d48878ce1fe9d1eece4e4003e443ed0bc0f9b643b7e1653a5fc8c SHA512 44d9e2c4f92ae1ea1d7f14432d7fe1a9f11b30ec8602d55c4b8f3f46283671fb75b08641c8170bd46918e16db1bed696a613a0518acd4e195e173fe12e386833
+DIST tl-tex4ht-2020.tar.xz 909692 BLAKE2B ef566977a0a5a8d6ae5244fceac4ff378dc8adf86817e7bbbd1d0cd1931fc5fcb618b94353b044d461d94edd426ec3aa185e1b7d678490416bb1c122438046c3 SHA512 c385b90fcff5ba43884918bf616aa4beffc285def1a380b84909bf4dd44cffb479612268a37977adf87f8dc226394d3239503b5d6f2a083a9f078862f282f0c4
diff --git a/dev-tex/tex4ht/tex4ht-20090611_p1038-r9.ebuild b/dev-tex/tex4ht/tex4ht-20090611_p1038-r9.ebuild
new file mode 100644
index 000000000000..e5b3574cf7ea
--- /dev/null
+++ b/dev-tex/tex4ht/tex4ht-20090611_p1038-r9.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit latex-package toolchain-funcs java-pkg-opt-2 flag-o-matic
+
+TL_TEX4HT_VER="2020"
+
+# tex4ht-20050331_p2350 -> tex4ht-1.0.2005_03_31_2350
+MY_P="${PN}-1.0.${PV:0:4}_${PV:4:2}_${PV:6:2}_${PV/*_p/}"
+
+DESCRIPTION="Converts (La)TeX to (X)HTML, XML and OO.org"
+HOMEPAGE="http://www.cse.ohio-state.edu/~gurari/TeX4ht/
+ http://www.cse.ohio-state.edu/~gurari/TeX4ht/bugfixes.html"
+SRC_URI="http://www.cse.ohio-state.edu/~gurari/TeX4ht/fix/${MY_P}.tar.gz
+ https://dev.gentoo.org/~zlogene/distfiles/texlive/tl-${PN}-${TL_TEX4HT_VER}.tar.xz"
+
+LICENSE="LPPL-1.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="java"
+
+RDEPEND="app-text/ghostscript-gpl
+ media-gfx/imagemagick
+ dev-libs/kpathsea
+ java? ( >=virtual/jre-1.5 )"
+
+DEPEND="dev-libs/kpathsea"
+
+BDEPEND="virtual/pkgconfig
+ java? ( >=virtual/jdk-1.5 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cp -a "${WORKDIR}/texmf-dist/"* texmf/ || die
+ eapply_user
+ cd "${S}/texmf/tex4ht/base/unix" || die
+ sed -i \
+ -e "s#~/tex4ht.dir#${EPREFIX}/usr/share#" \
+ -e "s#tpath/tex/texmf/fonts/tfm/!#t${EPREFIX}/usr/share/texmf-dist/fonts/tfm/!\nt${EPREFIX}/usr/local/share/texmf/fonts/tfm/!\nt${EPREFIX}/var/cache/fonts/tfm/!\nt${EPREFIX}${TEXMF}/fonts/tfm/!#" \
+ -e "s#%%~#${EPREFIX}${TEXMF}#g" \
+ -e "s#/usr/share/texmf/#${EPREFIX}${TEXMF}/#" \
+ tex4ht.env \
+ || die "sed of tex4ht.env failed"
+
+ einfo "Removing precompiled java stuff"
+ find "${S}" '(' -name '*.class' -o -name '*.jar' ')' -print -delete || die
+}
+
+src_compile() {
+ has_version '>=dev-libs/kpathsea-6.2.1' \
+ && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+
+ cd "${S}/src" || die
+ einfo "Compiling postprocessor sources..."
+ for f in tex4ht t4ht htcmd ; do
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o $f $f.c \
+ -DENVFILE="\"${EPREFIX}${TEXMF}/tex4ht/base/tex4ht.env\"" \
+ -DHAVE_DIRENT_H -DKPATHSEA -lkpathsea \
+ || die "Compiling $f failed"
+ done
+ if use java; then
+ einfo "Compiling java files..."
+ cd java || die
+ ejavac *.java */*.java */*/*.java -d ../../texmf/tex4ht/bin
+ cd "${S}/texmf/tex4ht/bin" || die
+ # Create the jar needed by oolatex
+ jar -cf "${S}/${PN}.jar" * || die "failed to create jar"
+ fi
+}
+
+src_install() {
+ # install the binaries
+ dobin "${S}/src/tex4ht" "${S}/src/t4ht" "${S}/src/htcmd"
+ # install the scripts
+ if ! use java; then
+ rm -f "${S}"/bin/unix/oo*
+ rm -f "${S}"/bin/unix/jh*
+ fi
+ dobin "${S}"/bin/unix/mk4ht
+
+ # install the .4ht scripts
+ insinto ${TEXMF}/tex/generic/tex4ht
+ doins "${S}"/texmf/tex/generic/tex4ht/*
+
+ # install the special htf fonts
+ insinto ${TEXMF}/tex4ht
+ doins -r "${S}/texmf/tex4ht/ht-fonts"
+
+ if use java; then
+ # install the java files
+ doins -r "${S}/texmf/tex4ht/bin"
+ java-pkg_jarinto ${TEXMF}/tex4ht/bin
+ java-pkg_dojar "${S}/${PN}.jar"
+ fi
+
+ # install the .4xt files
+ doins -r "${S}/texmf/tex4ht/xtpipes"
+
+ # install the env file
+ insinto ${TEXMF}/tex4ht/base
+ newins "${S}/texmf/tex4ht/base/unix/tex4ht.env" tex4ht.env
+
+ insinto /etc/texmf/texmf.d
+ doins "${FILESDIR}/50tex4ht.cnf"
+
+ insinto ${TEXMF}/tex/generic/${PN}
+ insopts -m755
+ doins "${S}"/bin/ht/unix/*
+}
+
+pkg_postinst() {
+ use java || elog 'ODF converters (oolatex & friends) require the java use flag'
+ latex-package_pkg_postinst
+ elog "In order to avoid collisions with multiple packages"
+ elog "We are not installing the scripts in /usr/bin anymore"
+ elog "If you want to use, say, htlatex, you can use 'mk4ht htlatex file'"
+}