summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/dependor/Manifest1
-rw-r--r--dev-ruby/dependor/dependor-1.0.1.ebuild25
-rw-r--r--dev-ruby/dependor/metadata.xml11
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/dependor/Manifest b/dev-ruby/dependor/Manifest
new file mode 100644
index 000000000000..3cf298ab5e82
--- /dev/null
+++ b/dev-ruby/dependor/Manifest
@@ -0,0 +1 @@
+DIST dependor-1.0.1.gem 12288 SHA256 ff443b661d0ec7c4746bd63bad434aef90b49353155e2ae6a6a75d2ab3b03d94 SHA512 4233a270d8fc956a530008121fcb0110c2c66f77f51aa98a5db75b857c83f80f90b8e8ae67d098aa2363c21deaf1dbbba146c09b83fe6fa8004832249acea9e7 WHIRLPOOL af92e012aaaf56d6177fc7b993b5318a6f0e7ec91a1f1b858d1494ad663cfe7012ad5bb549b7dc94218b4f2122f5b9cb2b3c34cd9126ec0a85eaa126581f11a5
diff --git a/dev-ruby/dependor/dependor-1.0.1.ebuild b/dev-ruby/dependor/dependor-1.0.1.ebuild
new file mode 100644
index 000000000000..6c1132b1d898
--- /dev/null
+++ b/dev-ruby/dependor/dependor-1.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Reduces duplication when doing manual dependency injection"
+HOMEPAGE="https://github.com/psyho/dependor"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/dependor/metadata.xml b/dev-ruby/dependor/metadata.xml
new file mode 100644
index 000000000000..f425efb1dfc8
--- /dev/null
+++ b/dev-ruby/dependor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">psyho/dependor</remote-id>
+ </upstream>
+</pkgmetadata>