summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/unetbootin/Manifest3
-rw-r--r--sys-boot/unetbootin/files/unetbootin-647-frebootbutton.patch10
-rw-r--r--sys-boot/unetbootin/unetbootin-625.ebuild90
-rw-r--r--sys-boot/unetbootin/unetbootin-647.ebuild89
-rw-r--r--sys-boot/unetbootin/unetbootin-655.ebuild88
5 files changed, 0 insertions, 280 deletions
diff --git a/sys-boot/unetbootin/Manifest b/sys-boot/unetbootin/Manifest
index 7dff3cc86094..b88b338d6af7 100644
--- a/sys-boot/unetbootin/Manifest
+++ b/sys-boot/unetbootin/Manifest
@@ -1,4 +1 @@
-DIST unetbootin-625.tar.gz 22671470 BLAKE2B 7420d804f1a490edd701646a3c228687316f0ec17005bf0832104858f9e46fbbf184b13c6aa5f8b6f30bf411e033cddfefece9b9ee6f6fcc7872440af9f88b48 SHA512 0dc672097eb857f8516208f8cbe5a0ec3229aa5dbe56108f64c415d2d9d4679a41e3f8a4b7279c511197303a2e020c95293a305de4df2dc63dc4522b3d13259b
-DIST unetbootin-647.tar.gz 16253287 BLAKE2B 4095e2cc990de6a01d46e3861d20cbbd1dbb04ad90c929ea72034d935b82669e482032ca3289e717fa9d7cdd9a147bb19ce2e5c610f046f5ab9470a494a35d83 SHA512 487be195286dd1e7712afa86cb75f8a79a3acce77f5cbd2571ddad74533d84a90e17b96afecfd2c9831825975b6c562bfb218b583a042600c49a14179129e8bb
-DIST unetbootin-655.tar.gz 16258032 BLAKE2B 2cdf307702851d87302aac3246118c13c5c2a99f1a3a3b98156c5e0ca905d8fe79c87ce90817fee696adf2572bf26a4684f56245ff1e3573a1b7f97a489da970 SHA512 723b4c1499b5c9afd93e5ee3803c9ca18ee5ef5f7731797eedc194a2bbcc2c5be93cc6cb1059f8514f93a8c9e6d650aec40513f649b41382ae27c2f92389d709
DIST unetbootin-657.tar.gz 16258176 BLAKE2B 7124e3a4cace41b1ca61ca468e37adc90ae7d3099f54dc5da200cc7b7d94567afa5b4a597ba7d7e3a1327951fd7e61f320bc676b72ba68c7255e9145e5791adc SHA512 69ffdbc23f372c795e84267dfbed2221783a7efc9b1d5f589e7c308384cdfd0d9cf0950058f665e2c10bf6f17e0efd3eff81a1bedb98da316583f2462dfed2d9
diff --git a/sys-boot/unetbootin/files/unetbootin-647-frebootbutton.patch b/sys-boot/unetbootin/files/unetbootin-647-frebootbutton.patch
deleted file mode 100644
index d616d12c7406..000000000000
--- a/sys-boot/unetbootin/files/unetbootin-647-frebootbutton.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/unetbootin.ui
-+++ b/unetbootin.ui
-@@ -708,7 +708,6 @@
- <tabstop>driveselect</tabstop>
- <tabstop>okbutton</tabstop>
- <tabstop>cancelbutton</tabstop>
-- <tabstop>frebootbutton</tabstop>
- <tabstop>fexitbutton</tabstop>
- <tabstop>intromessage</tabstop>
- <tabstop>rebootmsgtext</tabstop>
diff --git a/sys-boot/unetbootin/unetbootin-625.ebuild b/sys-boot/unetbootin/unetbootin-625.ebuild
deleted file mode 100644
index 49f0d802f768..000000000000
--- a/sys-boot/unetbootin/unetbootin-625.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils qmake-utils
-
-DESCRIPTION="UNetbootin installs Linux/BSD distributions to a partition or USB drive"
-HOMEPAGE="https://github.com/unetbootin/unetbootin"
-SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 x86"
-
-UNBI_LINGUAS="
- am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
- ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
- zh_CN zh_TW
-"
-
-for lingua in ${UNBI_LINGUAS}; do
- IUSE="${IUSE} l10n_${lingua/_/-}"
-done
-
-S=${WORKDIR}/${P}/src/${PN}
-
-DEPEND="dev-qt/qtgui:4"
-RDEPEND="
- ${DEPEND}
- app-arch/p7zip
- sys-boot/syslinux
- sys-fs/mtools
-"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-581-desktop.patch"
-
- # QA check in case linguas are added or removed
- enum() {
- echo ${#}
- }
- [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
- || die "Numbers of recorded and actual linguas do not match"
- unset enum
-
- # Make room between the last line of TRANSLATIONS and the next definition
- sed -i \
- -e '/^DEFINES/s|.*|\n&|g' \
- ${PN}.pro || die
-
- # Remove localisations
- local lingua
- for lingua in ${UNBI_LINGUAS}; do
- if ! use l10n_${lingua/_/-}; then
- sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
- rm ${PN}_${lingua}.ts || die
- fi
- done
-}
-
-src_configure() {
- sed -i -e '/^RESOURCES/d' unetbootin.pro || die
-
- UNBN_QTPATH="$(qt4_get_bindir)/"
- "${UNBN_QTPATH}"lrelease ${PN}.pro || die
-
- eqmake4 ${PN}.pro || die
-}
-
-src_install() {
- dobin ${PN}
-
- domenu ${PN}.desktop
-
- for file in ${PN}*.png; do
- size="${file/${PN}_}"
- size="${size/.png}x${size/.png}"
- insinto /usr/share/icons/hicolor/${size}/apps
- newins ${file} ${PN}.png
- done
-
- local lingua
- for lingua in ${UNBI_LINGUAS}; do
- if use l10n_${lingua/_/-}; then
- insinto /usr/share/${PN}
- doins ${PN}_${lingua}.qm
- fi
- done
-}
diff --git a/sys-boot/unetbootin/unetbootin-647.ebuild b/sys-boot/unetbootin/unetbootin-647.ebuild
deleted file mode 100644
index a8e28b868c27..000000000000
--- a/sys-boot/unetbootin/unetbootin-647.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils qmake-utils
-
-DESCRIPTION="UNetbootin installs Linux/BSD distributions to a partition or USB drive"
-HOMEPAGE="https://github.com/unetbootin/unetbootin"
-SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-
-UNBI_LINGUAS="
- am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
- ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
- zh_CN zh_TW
-"
-
-for lingua in ${UNBI_LINGUAS}; do
- IUSE="${IUSE} l10n_${lingua/_/-}"
-done
-
-S=${WORKDIR}/${P}/src/${PN}
-
-DEPEND="dev-qt/qtgui:4"
-RDEPEND="
- ${DEPEND}
- app-arch/p7zip
- sys-boot/syslinux
- sys-fs/mtools
-"
-PATCHES=(
- "${FILESDIR}/${PN}-581-desktop.patch"
- "${FILESDIR}/${PN}-647-frebootbutton.patch"
-)
-
-src_prepare() {
- default
-
- # QA check in case linguas are added or removed
- enum() {
- echo ${#}
- }
- [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
- || die "Numbers of recorded and actual linguas do not match"
- unset enum
-
- # Remove localisations
- local lingua
- for lingua in ${UNBI_LINGUAS}; do
- if ! use l10n_${lingua/_/-}; then
- sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
- rm ${PN}_${lingua}.ts || die
- fi
- done
-}
-
-src_configure() {
- sed -i -e '/^RESOURCES/d' unetbootin.pro || die
-
- UNBN_QTPATH="$(qt4_get_bindir)/"
- "${UNBN_QTPATH}"lrelease ${PN}.pro || die
-
- eqmake4 ${PN}.pro || die
-}
-
-src_install() {
- dobin ${PN}
-
- domenu ${PN}.desktop
-
- for file in ${PN}*.png; do
- size="${file/${PN}_}"
- size="${size/.png}x${size/.png}"
- insinto /usr/share/icons/hicolor/${size}/apps
- newins ${file} ${PN}.png
- done
-
- local lingua
- for lingua in ${UNBI_LINGUAS}; do
- if use l10n_${lingua/_/-}; then
- insinto /usr/share/${PN}
- doins ${PN}_${lingua}.qm
- fi
- done
-}
diff --git a/sys-boot/unetbootin/unetbootin-655.ebuild b/sys-boot/unetbootin/unetbootin-655.ebuild
deleted file mode 100644
index f615c0100f45..000000000000
--- a/sys-boot/unetbootin/unetbootin-655.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils qmake-utils
-
-DESCRIPTION="UNetbootin installs Linux/BSD distributions to a partition or USB drive"
-HOMEPAGE="https://github.com/unetbootin/unetbootin"
-SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-
-UNBI_LINGUAS="
- am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
- ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
- zh_CN zh_TW
-"
-
-for lingua in ${UNBI_LINGUAS}; do
- IUSE="${IUSE} l10n_${lingua/_/-}"
-done
-
-S=${WORKDIR}/${P}/src/${PN}
-
-DEPEND="dev-qt/qtgui:4"
-RDEPEND="
- ${DEPEND}
- app-arch/p7zip
- sys-boot/syslinux
- sys-fs/mtools
-"
-PATCHES=(
- "${FILESDIR}/${PN}-581-desktop.patch"
-)
-
-src_prepare() {
- default
-
- # QA check in case linguas are added or removed
- enum() {
- echo ${#}
- }
- [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
- || die "Numbers of recorded and actual linguas do not match"
- unset enum
-
- # Remove localisations
- local lingua
- for lingua in ${UNBI_LINGUAS}; do
- if ! use l10n_${lingua/_/-}; then
- sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
- rm ${PN}_${lingua}.ts || die
- fi
- done
-}
-
-src_configure() {
- sed -i -e '/^RESOURCES/d' unetbootin.pro || die
-
- UNBN_QTPATH="$(qt4_get_bindir)/"
- "${UNBN_QTPATH}"lrelease ${PN}.pro || die
-
- eqmake4 ${PN}.pro || die
-}
-
-src_install() {
- dobin ${PN}
-
- domenu ${PN}.desktop
-
- for file in ${PN}*.png; do
- size="${file/${PN}_}"
- size="${size/.png}x${size/.png}"
- insinto /usr/share/icons/hicolor/${size}/apps
- newins ${file} ${PN}.png
- done
-
- local lingua
- for lingua in ${UNBI_LINGUAS}; do
- if use l10n_${lingua/_/-}; then
- insinto /usr/share/${PN}
- doins ${PN}_${lingua}.qm
- fi
- done
-}