summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/init-system-helpers/Manifest1
-rw-r--r--sys-apps/init-system-helpers/init-system-helpers-1.66.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/init-system-helpers/Manifest b/sys-apps/init-system-helpers/Manifest
index bd84e5746eb4..c9cf8c57e867 100644
--- a/sys-apps/init-system-helpers/Manifest
+++ b/sys-apps/init-system-helpers/Manifest
@@ -1 +1,2 @@
DIST init-system-helpers_1.60.tar.xz 40584 BLAKE2B ad21a65ef3c4bcec16b14fc4db890fb7f83df625d1038fe217c20e9391404914df189ae31506b9bbef0442cdd333f46bd9c4d9009b7d671d9ae2deb6b05eee8e SHA512 3739613fa8afa1fa6032f47f8cec67c526171987a7d1eae31d479db9cc1e49ae3cd397a858130c17680d62becb9c6499bd1da1268e9ed25b044337ab69f0dd88
+DIST init-system-helpers_1.66.tar.xz 44976 BLAKE2B e97d4483c73e7d5c310598eb75d77972f5334ef09708166f3bacb46e4e4495c7f7b2a905e70221180fbcd0524312c6b0962bf55a165092dccc839218f2fc46c5 SHA512 22c8c7f6483de6e95750a48d55b540478de9cd8ed23e806359b30e19528313cdc03f119b076182575ec3e06f76d628a95b0b9568be2d03fcbba278617661c93e
diff --git a/sys-apps/init-system-helpers/init-system-helpers-1.66.ebuild b/sys-apps/init-system-helpers/init-system-helpers-1.66.ebuild
new file mode 100644
index 000000000000..16d0b3cc65fe
--- /dev/null
+++ b/sys-apps/init-system-helpers/init-system-helpers-1.66.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Helper scripts useful for both OpenRC and systemd"
+HOMEPAGE="https://packages.debian.org/sid/init-system-helpers"
+# git repo: https://anonscm.debian.org/git/collab-maint/init-system-helpers.git
+SRC_URI="http://http.debian.net/debian/pool/main/i/${PN}/${PN}_${PV}.tar.xz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+BDEPEND=">=dev-python/docutils-0.21.2"
+RDEPEND="!<sys-apps/openrc-0.33"
+
+PATCHES=(
+ "${FILESDIR}/revert-openrc-management.patch"
+)
+
+src_install() {
+ # We only care about 'service' script/manpage:
+ exeinto /sbin/
+ doexe script/service
+
+ rst2man man8/service.rst > man8/service.8 || die "Failed to generate man page"
+
+ # FIXME: need to patch to remove *rc.d references, which we don't ship
+ # And should probably add a list of supported options (e.g., start/stop/etc.)
+ doman man8/service.8
+}