summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/libva-intel-driver/libva-intel-driver-9999.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/x11-libs/libva-intel-driver/libva-intel-driver-9999.ebuild b/x11-libs/libva-intel-driver/libva-intel-driver-9999.ebuild
index 1d8bbf4cd84b..4e4df0e31706 100644
--- a/x11-libs/libva-intel-driver/libva-intel-driver-9999.ebuild
+++ b/x11-libs/libva-intel-driver/libva-intel-driver-9999.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
MY_PN="intel-vaapi-driver"
if [[ ${PV} = *9999* ]] ; then # Live ebuild
inherit git-r3
- EGIT_BRANCH=master
EGIT_REPO_URI="https://github.com/intel/intel-vaapi-driver"
fi
-AUTOTOOLS_AUTORECONF="yes"
-inherit autotools-multilib
+
+inherit autotools multilib-minimal
DESCRIPTION="HW video decode support for Intel integrated graphics"
HOMEPAGE="https://github.com/intel/intel-vaapi-driver"
@@ -23,6 +22,7 @@ fi
LICENSE="MIT"
SLOT="0"
IUSE="wayland X"
+RESTRICT="test" # No tests
RDEPEND="
>=x11-libs/libdrm-2.4.52[video_cards_intel,${MULTILIB_USEDEP}]
@@ -32,22 +32,23 @@ RDEPEND="
>=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}]
)
"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-DOCS=( AUTHORS NEWS README )
-AUTOTOOLS_PRUNE_LIBTOOL_FILES="all"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
+ eapply_user
sed -e 's/intel-gen4asm/\0diSaBlEd/g' -i configure.ac || die
- autotools-multilib_src_prepare
+ eautoreconf
}
multilib_src_configure() {
- local myeconfargs=(
+ local myconf=(
$(use_enable wayland)
$(use_enable X x11)
)
- autotools-utils_src_configure
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ find "${D}" -name "*.la" -delete || die
}