summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/xscrabble/files/xscrabble-2.10-build.patch4
-rw-r--r--games-board/xscrabble/files/xscrabble-2.10-implicit-declaration.patch12
-rw-r--r--games-board/xscrabble/files/xscrabble-2.10-path-fixes.patch8
-rw-r--r--games-board/xscrabble/xscrabble-2.10-r3.ebuild (renamed from games-board/xscrabble/xscrabble-2.10-r2.ebuild)63
4 files changed, 67 insertions, 20 deletions
diff --git a/games-board/xscrabble/files/xscrabble-2.10-build.patch b/games-board/xscrabble/files/xscrabble-2.10-build.patch
index 7d5214c7db34..c290475e482b 100644
--- a/games-board/xscrabble/files/xscrabble-2.10-build.patch
+++ b/games-board/xscrabble/files/xscrabble-2.10-build.patch
@@ -1,7 +1,7 @@
respect compiler, ldflags and cflags
---- build
-+++ build
+--- a/build
++++ b/build
@@ -36,7 +36,7 @@
#define RULES_FILE \"$LIBDIR/en/scrabble_rules\"
" > src/config.h
diff --git a/games-board/xscrabble/files/xscrabble-2.10-implicit-declaration.patch b/games-board/xscrabble/files/xscrabble-2.10-implicit-declaration.patch
new file mode 100644
index 000000000000..88c9cd680e99
--- /dev/null
+++ b/games-board/xscrabble/files/xscrabble-2.10-implicit-declaration.patch
@@ -0,0 +1,12 @@
+diff --git a/src/xutils.c b/src/xutils.c
+index 25478df..26e3277 100644
+--- a/src/xutils.c
++++ b/src/xutils.c
+@@ -22,6 +22,7 @@
+ #include <X11/Xaw/Simple.h>
+ #include <X11/xpm.h>
+ #include <stdio.h>
++#include <stdlib.h>
+
+ #include "xutils.h"
+
diff --git a/games-board/xscrabble/files/xscrabble-2.10-path-fixes.patch b/games-board/xscrabble/files/xscrabble-2.10-path-fixes.patch
index 27a18689b1ed..5a0fe1a7e7d5 100644
--- a/games-board/xscrabble/files/xscrabble-2.10-path-fixes.patch
+++ b/games-board/xscrabble/files/xscrabble-2.10-path-fixes.patch
@@ -1,5 +1,5 @@
---- build
-+++ build
+--- a/build
++++ b/build
@@ -1,9 +1,10 @@
#!/bin/sh
@@ -9,8 +9,8 @@
-LIBDIR=/usr/games/lib/scrabble
+APPDEFAULTS=$DESTDIR/usr/$LIBDIR/X11/app-defaults
+REAL_APPDEFAULTS=/usr/$LIBDIR/X11/app-defaults
-+BINDIR=$DESTDIR/usr/games/bin
-+LIBDIR=$DESTDIR/usr/share/games/xscrabble
++BINDIR=$DESTDIR/usr/bin
++LIBDIR=$DESTDIR/usr/share/xscrabble
# Version (don't modify without knowing!!)
MAJOR=2
diff --git a/games-board/xscrabble/xscrabble-2.10-r2.ebuild b/games-board/xscrabble/xscrabble-2.10-r3.ebuild
index 2ea0730cfc70..26dd3487df37 100644
--- a/games-board/xscrabble/xscrabble-2.10-r2.ebuild
+++ b/games-board/xscrabble/xscrabble-2.10-r3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils multilib games
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="An X11 clone of the well-known Scrabble"
HOMEPAGE="http://freshmeat.net/projects/xscrabble/?topic_id=80"
@@ -15,42 +16,76 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="l10n_fr"
-RDEPEND="x11-libs/libXaw"
-DEPEND="${RDEPEND}
+DEPEND="x11-libs/libXaw"
+RDEPEND="
+ ${DEPEND}
+ acct-group/gamestat
+"
+BDEPEND="
x11-misc/gccmakedep
- x11-misc/imake"
+ x11-misc/imake
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-path-fixes.patch
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-implicit-declaration.patch
+)
src_unpack() {
unpack ${P}.tgz
- cp "${DISTDIR}"/xscrabble_en.tgz .
- use l10n_fr && cp "${DISTDIR}"/xscrabble_fr.tgz .
+ cp "${DISTDIR}"/xscrabble_en.tgz . || die
+
+ if use l10n_fr ; then
+ cp "${DISTDIR}"/xscrabble_fr.tgz . || die
+ fi
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-path-fixes.patch \
- "${FILESDIR}"/${P}-build.patch
+ default
sed -i '/install/s/-s //' build || die "sed failed"
}
+src_configure() {
+ tc-export CC
+}
+
src_compile() {
./build bin || die "build failed"
}
src_install() {
- local f
export DESTDIR="${D}" LIBDIR="$(get_libdir)"
+
./build install || die "install failed"
+
if use l10n_fr ; then
./build lang fr || die "fr failed"
fi
+
./build lang en || die "en failed"
- for f in "${D}"/usr/"${LIBDIR}"/X11/app-defaults/* ; do
+
+ local f
+ for f in "${ED}/usr/${LIBDIR}"/X11/app-defaults/* ; do
[[ -L ${f} ]] && continue
sed -i \
- -e "s:/usr/games/lib/scrabble/:${GAMES_DATADIR}/${PN}/:" \
+ -e "s:/usr/games/lib/scrabble/:/usr/share/${PN}/:" \
-e "s:fr/eng:fr/en:" \
${f} || die "sed ${f} failed"
done
+
dodoc CHANGES README
- prepgamesdirs
+
+ local paths=( /usr/share/${PN}/en/scrabble_scores )
+ if use l10n_fr ; then
+ paths+=( /usr/share/${PN}/fr/scrabble_scores )
+ fi
+
+ local path
+ for path in ${paths[@]} ; do
+ fowners root:gamestat ${path}
+ fperms 660 ${path}
+ done
+
+ fperms g+s /usr/bin/${PN}
}