summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-emulation/nestopia/Manifest2
-rw-r--r--games-emulation/nestopia/files/nestopia10
-rw-r--r--games-emulation/nestopia/files/nestopia-1.40-makefile.patch69
-rw-r--r--games-emulation/nestopia/nestopia-1.40.ebuild54
4 files changed, 0 insertions, 135 deletions
diff --git a/games-emulation/nestopia/Manifest b/games-emulation/nestopia/Manifest
index 641112b15364..809f35aeae45 100644
--- a/games-emulation/nestopia/Manifest
+++ b/games-emulation/nestopia/Manifest
@@ -1,3 +1 @@
-DIST Nestopia140src.zip 2346187 SHA256 ec503320679062af260135bf38e1fa2376803c75efb74039224fb2ef3b888762 SHA512 54a7c569239c15aa9bd7a5bbe13f67b5a62baccf95f81fb55ad9578872edc11a3e456af7ea67107e96c0c88726e976203058cf971fbb527cd30b644d8d51795a WHIRLPOOL c62959e52e1366ec2966087269a6ac07998d6ae0c24cae00ec2621ea506128eb887eb10ce25ac8c8e82a6c89aea8aa7fad9351f55146ce4b16ae6f81b5c992b3
DIST nestopia-1.46.2.tgz 1223407 SHA256 4a5065726ad9e7a120a2c6aa39b9c0904090119998a4d690d4deb5e374118fc0 SHA512 3aa87e98aa24b71e5feac5ffe8229e97d407fc0b14567b0ddbe7cc1eaca08a08f435a6fe294fbbd7066054befdfd27602db7c3c0577246b0e8addfe296404a23 WHIRLPOOL 25c43194797e5edca3abc5cb75dba126d9d246e9ab12270521e7fe6c13427b371ba9f92a71ed557271f159711411286b5ac5ab3fe06144760320531c33bf0c02
-DIST nst140_lnx_release_h.zip 250216 SHA256 0b6b11d98fabbb0319c1d0800428f8cba6631ac2808fb4618ced3d7c8d782859 SHA512 eea9b212a26f0d8c294371eeb15a22c1aba595334dd46629767af19671692bd29eda078caa96d4a91f505b4e2764861090578c63dd3715cfa0fce4af7fc39339 WHIRLPOOL 715f33a33a2dd630d35e3a7ca1acdbcdb8843139aa976686324d121fab6cd89a5e666cc952e6097563cda145e17717a823931bdb40067e9d295e747a4902d83d
diff --git a/games-emulation/nestopia/files/nestopia b/games-emulation/nestopia/files/nestopia
deleted file mode 100644
index e2a6b03e5948..000000000000
--- a/games-emulation/nestopia/files/nestopia
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-
-# create dir and copy files, if needed
-[ ! -d ~/.nestopia ] && mkdir ~/.nestopia
-[ ! -f ~/.nestopia/nstcontrols ] && cp "%GAMES_DATADIR%/nestopia/nstcontrols" ~/.nestopia/
-[ ! -f ~/.nestopia/NstDatabase.xml ] && cp "%GAMES_DATADIR%/nestopia/NstDatabase".xml ~/.nestopia/
-
-# wrap around the emu
-exec nestopia.bin "$@"
-
diff --git a/games-emulation/nestopia/files/nestopia-1.40-makefile.patch b/games-emulation/nestopia/files/nestopia-1.40-makefile.patch
deleted file mode 100644
index 467e49445ec4..000000000000
--- a/games-emulation/nestopia/files/nestopia-1.40-makefile.patch
+++ /dev/null
@@ -1,69 +0,0 @@
---- Makefile.orig 2010-01-24 02:21:57.196476493 -0500
-+++ Makefile 2010-01-24 02:27:52.134475800 -0500
-@@ -3,19 +3,20 @@
- # By R. Belmont
- #
-
--CC = gcc
--CPP = g++
--CFLAGS = -c -O3 -g3
--CFLAGS += -DNST_PRAGMA_ONCE_SUPPORT -D_SZ_ONE_DIRECTORY
--CFLAGS += -Isource -Isource/core -Isource/zlib -Isource/core/api -Isource/core/board -Isource/core/input -Isource/linux/unzip
--CFLAGS += -Isource/core/vssystem -Isource/linux -Isource/nes_ntsc -I.. -I../nes_ntsc -Isource/linux/7zip
--CFLAGS += `sdl-config --cflags` `pkg-config --cflags gtk+-2.0`
--CFLAGS += -finline-limit=2000 --param inline-unit-growth=1000 --param large-function-growth=1000 -finline-functions-called-once
-+FLAGS = -c \
-+ -DNST_PRAGMA_ONCE_SUPPORT -D_SZ_ONE_DIRECTORY \
-+ -Isource -Isource/core -Isource/zlib -Isource/core/api -Isource/core/board -Isource/core/input -Isource/linux/unzip \
-+ -Isource/core/vssystem -Isource/linux -Isource/nes_ntsc -I.. -I../nes_ntsc -Isource/linux/7zip \
-+ `sdl-config --cflags` `pkg-config --cflags gtk+-2.0` \
-+ -finline-limit=2000 --param inline-unit-growth=1000 --param large-function-growth=1000 -finline-functions-called-once
-+
-+CFLAGS += $(FLAGS)
-+CXXFLAGS += $(FLAGS)
-
- # enable this for input debugging
- #CFLAGS += -DDEBUG_INPUT
-
--CPPFLAGS = -Wno-deprecated -fno-rtti
-+CXXFLAGS += -Wno-deprecated -fno-rtti
-
- EXE = nst
- LIBS = -lm -lz -lasound `sdl-config --libs` `pkg-config --libs gtk+-2.0`
-@@ -144,6 +145,8 @@
- OBJDIRS = objs objs/core objs/core/api objs/core/board objs/core/input objs/core/vssystem objs/nes_ntsc
- OBJDIRS += objs/linux objs/linux/7zip objs/linux/unzip
-
-+$(shell mkdir $(sort $(OBJDIRS)))
-+
- # build rules
- objs/%.o: source/%.c
- @echo Compiling $<...
-@@ -151,24 +154,19 @@
-
- objs/%.o: source/%.cpp
- @echo Compiling $<...
-- @$(CC) $(CFLAGS) $(CPPFLAGS) $< -o $@
-+ $(CC) $(CXXFLAGS) $< -o $@
-
- objs/%.o: source/%.o
- @echo Compiling $<...
- @$.o) $(CFLAGS) $.oFLAGS) $< -o $@
-
--all: maketree $(EXE) $(GENNSTCONTROLS)
--
--maketree: $(sort $(OBJDIRS))
-+all: $(EXE) $(GENNSTCONTROLS)
-
--$(sort $(OBJDIRS)):
-- @echo Creating output directory $@
-- @mkdir $@
-
- # link the commandline exe
- $(EXE): $(OBJS)
- @echo Linking $@...
-- @$(CPP) -g -o $(EXE) $^ $(LIBS)
-+ $(CXX) $(LDFLAGS) -g -o $(EXE) $^ $(LIBS)
-
- clean:
- -@rm -f $(OBJS) $(EXE) $(GENNSTCONTROLS)
diff --git a/games-emulation/nestopia/nestopia-1.40.ebuild b/games-emulation/nestopia/nestopia-1.40.ebuild
deleted file mode 100644
index f6d6c03e7b79..000000000000
--- a/games-emulation/nestopia/nestopia-1.40.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit eutils flag-o-matic games
-
-MY_PV="${PV//./}"
-LNX_P="nst${MY_PV}_lnx_release_h"
-DESCRIPTION="NEStopia is a portable Nintendo Entertainment System emulator written in C++"
-HOMEPAGE="http://rbelmont.mameworld.info/?page_id=200"
-SRC_URI="mirror://sourceforge/${PN}/Nestopia${MY_PV}src.zip
- http://rbelmont.mameworld.info/${LNX_P}.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE=""
-
-RDEPEND=">=x11-libs/gtk+-2.4:2
- media-libs/alsa-lib
- >=media-libs/libsdl-1.2.12[sound,joystick,video]
- sys-libs/zlib
- virtual/opengl
- virtual/glu"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.patch
- sed \
- -e "s:%GAMES_DATADIR%:${GAMES_DATADIR}:g" \
- "${FILESDIR}"/${PN} \
- > ${PN} \
- || die "sed failed"
- strip-flags
-}
-
-src_install() {
- newgamesbin nst ${PN}.bin
- dogamesbin ${PN}
-
- insinto "${GAMES_DATADIR}/${PN}"
- doins NstDatabase.xml nstcontrols
-
- make_desktop_entry "${PN}" "Nestopia"
-
- dodoc README.Linux changelog.txt
- dohtml -r readme.html doc/*.html doc/details
-
- prepgamesdirs
-}