summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-mta/msmtp/Manifest1
-rw-r--r--mail-mta/msmtp/msmtp-1.8.11.ebuild145
2 files changed, 146 insertions, 0 deletions
diff --git a/mail-mta/msmtp/Manifest b/mail-mta/msmtp/Manifest
index c040e5e52ad6..18d9a50db5d4 100644
--- a/mail-mta/msmtp/Manifest
+++ b/mail-mta/msmtp/Manifest
@@ -1,3 +1,4 @@
DIST msmtp-1.8.10.tar.xz 355364 BLAKE2B b70143e28da8b64035448cbb61e133a5a1d35bc472316a3e164f2f168d67ef71455c583610afdfe522d33b77dea1a7ff55f9d6c200c6b1d9b3e2fcadb4fa10c1 SHA512 0d2280772ded3ed33036f7a9047c054f413e34f8264a82df26b85dc48000fa318d5400201ce0b888f3d821c629e25e17e5cf6b69b3e452b14e6883904b4ad83b
+DIST msmtp-1.8.11.tar.xz 356492 BLAKE2B 0ee4b9ee859b21c35776c037fa93a3b104a86103a5543b0a0c035d3c3a285d7e6cf7eb38e56b172c4dcd6cc536274b6d6661297b2e160b1e9eed659fadfb5e17 SHA512 77595ca3d06781aa908677edae08bef92840e69dde5db8eedb555327b671d87cde441181fa17342f5b9492e76f0520a49bfa86dafce9d93844137ae7f96eac16
DIST msmtp-1.8.7.tar.xz 340908 BLAKE2B 5241acf54d5a6af6ccf2c3bfd33954a5235af2d2cb467e4134401538e60e1847489a7a599359e2d13202ea9637c32a67ec5180372b139e06f6d47f060cba6c8f SHA512 5a079cb90b48853ad812125e8b341f5bcd5f5ba4725d62c37210050896527b63f993aa6393f1d4107636153bf0ed84b0288e88a7e78a119c66b2d58f1e69a67d
DIST msmtp-1.8.8.tar.xz 349740 BLAKE2B 005056e2bfeb97ccf2c86670a172157b6ba43e44bf1738fa9d75e6ca8bb7d952f118155b17a80db61ee4f10bdd009a72c2a7adf26b01296409b8998ac698f1ef SHA512 e519e04b0065e410007f6e47df435b7c5bde99ca7a1a2e9ff7528848c68f9809691cdf2c5b793d4e3e17a650a25ee31be66b0be47410f83972f281cf76926771
diff --git a/mail-mta/msmtp/msmtp-1.8.11.ebuild b/mail-mta/msmtp/msmtp-1.8.11.ebuild
new file mode 100644
index 000000000000..9c112ec7abde
--- /dev/null
+++ b/mail-mta/msmtp/msmtp-1.8.11.ebuild
@@ -0,0 +1,145 @@
+# Copyright 2004-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fcaps multilib
+
+DESCRIPTION="An SMTP client and SMTP plugin for mail user agents such as Mutt"
+HOMEPAGE="https://marlam.de/msmtp/"
+SRC_URI="https://marlam.de/msmtp/releases/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="daemon doc gnome-keyring idn +mta nls sasl ssl vim-syntax"
+
+# fcaps.eclass unconditionally defines "filecaps" USE flag which we need for
+# USE="daemon" in order to set the caps we need.
+REQUIRED_USE="daemon? ( filecaps )"
+
+# Upstream discourages usage of openssl. See also
+# https://marlam.de/msmtp/news/openssl-discouraged/
+DEPEND="
+ gnome-keyring? ( app-crypt/libsecret )
+ nls? ( virtual/libintl )
+ sasl? ( virtual/gsasl )
+ ssl? ( net-libs/gnutls[idn?] )
+ !ssl? ( idn? ( net-dns/libidn2:= ) )
+"
+
+RDEPEND="${DEPEND}
+ net-mail/mailbase
+ daemon? (
+ acct-group/msmtpd
+ acct-user/msmtpd
+ )
+ mta? (
+ !mail-mta/courier
+ !mail-mta/esmtp
+ !mail-mta/exim
+ !mail-mta/mini-qmail
+ !mail-mta/netqmail
+ !mail-mta/nullmailer
+ !mail-mta/postfix
+ !mail-mta/qmail-ldap
+ !mail-mta/sendmail
+ !mail-mta/opensmtpd
+ !<mail-mta/ssmtp-2.64-r2
+ !>=mail-mta/ssmtp-2.64-r2[mta]
+ )
+"
+
+BDEPEND="
+ doc? ( virtual/texi2dvi )
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS doc/msmtprc*"
+
+src_prepare() {
+ # Use default Gentoo location for mail aliases
+ sed 's:/etc/aliases:/etc/mail/aliases:' \
+ -i scripts/find_alias/find_alias_for_msmtp.sh || die
+
+ default
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-gai-idn
+ $(use_enable nls)
+ $(use_with daemon msmtpd)
+ $(use_with gnome-keyring libsecret)
+ $(use_with idn libidn)
+ $(use_with sasl libgsasl)
+ $(use_with ssl tls gnutls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ if use doc ; then
+ cd doc || die
+ emake html pdf
+ fi
+}
+
+src_install() {
+ default
+
+ if use daemon ; then
+ fcaps CAP_NET_BIND_SERVICE usr/bin/msmtpd
+ newinitd "${FILESDIR}"/msmtpd.init msmtpd
+ newconfd "${FILESDIR}"/msmtpd.confd msmtpd
+ fi
+
+ if use doc ; then
+ dodoc doc/msmtp.{html,pdf}
+ fi
+
+ if use mta ; then
+ dosym ../bin/msmtp /usr/sbin/sendmail
+ dosym ../bin/msmtp /usr/$(get_libdir)/sendmail
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins scripts/vim/msmtp.vim
+ fi
+
+ insinto /etc
+ newins doc/msmtprc-system.example msmtprc
+
+ src_install_contrib find_alias find_alias_for_msmtp.sh
+ src_install_contrib msmtpqueue "*.sh" "README ChangeLog"
+ src_install_contrib msmtpq "msmtpq msmtp-queue" README.msmtpq
+ src_install_contrib set_sendmail set_sendmail.sh set_sendmail.conf
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ einfo "Please edit ${EROOT}/etc/msmtprc before first use."
+ einfo "In addition, per user configuration files can be placed"
+ einfo "as '~/.msmtprc'. See the msmtprc-user.example file under"
+ einfo "/usr/share/doc/${PF}/ for an example."
+ fi
+}
+
+src_install_contrib() {
+ subdir="$1"
+ bins="$2"
+ docs="$3"
+ local dir=/usr/share/${PN}/${subdir}
+ insinto ${dir}
+ exeinto ${dir}
+ for i in ${bins} ; do
+ doexe scripts/${subdir}/${i}
+ done
+ for i in ${docs} ; do
+ newdoc scripts/${subdir}/${i} ${subdir}.${i}
+ done
+}