summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/apache-tools/Manifest1
-rw-r--r--app-admin/apache-tools/apache-tools-2.4.18.ebuild96
2 files changed, 0 insertions, 97 deletions
diff --git a/app-admin/apache-tools/Manifest b/app-admin/apache-tools/Manifest
index b29fe52e855b..9d9eb3a5a8c8 100644
--- a/app-admin/apache-tools/Manifest
+++ b/app-admin/apache-tools/Manifest
@@ -1,4 +1,3 @@
DIST httpd-2.2.31.tar.bz2 5610489 SHA256 f32f9d19f535dac63b06cb55dfc023b40dcd28196b785f79f9346779e22f26ac SHA512 5aa47d4b76f692bbd8b309135ff99152df98cf69b505b9daf3f13f7f2a31443eaf4995161adfbc47a133b4d0e091fda2d95fc6b87a956f0ada18d7466ee28e74 WHIRLPOOL a2e3e53c51719cb6f7e641b41788cd89ce7b4d2ea105b403bfa3b3d4479b69c5604228269062f66722594e105e91121d05b1c9f27ca7dc4ecfcf339da8b8375c
-DIST httpd-2.4.18.tar.bz2 5181291 SHA256 0644b050de41f5c9f67c825285049b144690421acb709b06fe53eddfa8a9fd4c SHA512 8e342cc447313c07275869381c2d6f2314a96547f0c86ee1c617975d0f7ad8efb47113ab5995c733108ae4dec31ad79847e397ecea859b60414ffe1680617a31 WHIRLPOOL e0ae6b8581e2993e0f873d8928e3b54f1df750f29e82d2f1308376af440308c56e89dfb3ec051cdf164a271580ccac71ebc5b038e23ca65a9221fdfc08b47b41
DIST httpd-2.4.20.tar.bz2 6331344 SHA256 0e76a375ed3dbac636f50ac39de966ece443751fe4d62392f9a360a19d94d0da SHA512 8591e0ca8f1c4755d670f1a8780bb656c62b30635cff1f7d4434f7c5017b99f1b14bbb296da5cdb63cd3bcfa4908b8b5f99a0c036e9e0f0c9514acd2a3cb7e53 WHIRLPOOL cc61fa5a2344268cdba69ba1662d555d492b40468a81b1d67fce55f85e178f63ef218a303e51e494c91a26dcec259e3912ca640192dbbe42d2b02ee4fac19a1d
DIST httpd-2.4.23.tar.bz2 6351875 SHA256 0c1694b2aad7765896faf92843452ee2555b9591ae10d4f19b245f2adfe85e58 SHA512 c520de5be748c0a785ef0dc77102749eb4f47e224968b8d4bed2ae644faa0964623a0e960b64486a0888446790d050b52a6ae34fe61717fab95b37384b4825b1 WHIRLPOOL f3defbd06a878c66236adfcac2b59b6f47115ac815708bb45f2152bd1754b14a01458c9331eb7a65cba52e0bc53e2e66b32a384d44a029b07ffdd068c7c08a19
diff --git a/app-admin/apache-tools/apache-tools-2.4.18.ebuild b/app-admin/apache-tools/apache-tools-2.4.18.ebuild
deleted file mode 100644
index 993b58d11364..000000000000
--- a/app-admin/apache-tools/apache-tools-2.4.18.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit flag-o-matic eutils multilib toolchain-funcs
-
-DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
-HOMEPAGE="https://httpd.apache.org/"
-SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc64-solaris ~x64-solaris"
-IUSE="libressl ssl"
-RESTRICT="test"
-
-RDEPEND=">=dev-libs/apr-1.5.0:1
- dev-libs/apr-util:1
- dev-libs/expat
- dev-libs/libpcre
- kernel_linux? ( sys-apps/util-linux )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-S="${WORKDIR}/httpd-${PV}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.4.7-Makefile.patch #459446
-
- # This package really should upgrade to using pcre's .pc file.
- cat <<-\EOF >"${T}"/pcre-config
- #!/bin/sh
- [ "${flag}" = "--version" ] && set -- --modversion
- exec ${PKG_CONFIG} libpcre "$@"
- EOF
- chmod a+x "${T}"/pcre-config
-}
-
-src_configure() {
- # Brain dead check.
- tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
-
- tc-export PKG_CONFIG
-
- # Instead of filtering --as-needed (bug #128505), append --no-as-needed
- append-ldflags $(no-as-needed)
-
- # econf overwrites the stuff from config.layout.
- ac_cv_path_PKGCONFIG=${PKG_CONFIG} \
- econf \
- --libexecdir="${EPREFIX}"/usr/$(get_libdir)/apache2/modules \
- --sbindir="${EPREFIX}"/usr/sbin \
- --with-perl="${EPREFIX}"/usr/bin/perl \
- --with-expat="${EPREFIX}"/usr \
- --with-z="${EPREFIX}"/usr \
- --with-apr="${SYSROOT}${EPREFIX}"/usr \
- --with-apr-util="${SYSROOT}${EPREFIX}"/usr \
- --with-pcre="${T}"/pcre-config \
- $(use_enable ssl) \
- $(usex ssl '--with-ssl="${EPREFIX}"/usr' '')
- sed -i \
- -e '/^LTFLAGS/s:--silent::' \
- build/rules.mk build/config_vars.mk || die
-}
-
-src_compile() {
- emake -C support
-}
-
-src_install() {
- emake -C support DESTDIR="${D}" install
- dodoc CHANGES
- doman docs/man/{dbmmanage,htdigest,htpasswd,htdbm,ab,logresolve}.1 \
- docs/man/{htcacheclean,rotatelogs}.8
-
- # Providing compatiblity symlinks for #177697 (which we'll stop to install
- # at some point).
- pushd "${ED}"/usr/sbin >/dev/null || die
- local i
- for i in *; do
- dosym ${i} /usr/sbin/${i}2
- done
- popd >/dev/null || die
-
- # Provide a symlink for ab-ssl
- if use ssl; then
- dosym ab /usr/bin/ab-ssl
- dosym ab /usr/bin/ab2-ssl
- fi
-}