summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/mlt/files/mlt-6.20.0-nullpointer-crash.patch22
-rw-r--r--media-libs/mlt/mlt-6.20.0-r2.ebuild1
2 files changed, 23 insertions, 0 deletions
diff --git a/media-libs/mlt/files/mlt-6.20.0-nullpointer-crash.patch b/media-libs/mlt/files/mlt-6.20.0-nullpointer-crash.patch
new file mode 100644
index 000000000000..6bff797c0a92
--- /dev/null
+++ b/media-libs/mlt/files/mlt-6.20.0-nullpointer-crash.patch
@@ -0,0 +1,22 @@
+From b32be6e56e328bb2e580aa13cd757aa211310bae Mon Sep 17 00:00:00 2001
+From: Dan Dennedy <dan@dennedy.org>
+Date: Thu, 27 Feb 2020 23:49:07 -0800
+Subject: [PATCH] fix null pointer crash in mix transition
+
+---
+ src/modules/core/transition_mix.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/modules/core/transition_mix.c b/src/modules/core/transition_mix.c
+index ab7a166d0..89c07a285 100644
+--- a/src/modules/core/transition_mix.c
++++ b/src/modules/core/transition_mix.c
+@@ -139,7 +139,7 @@ static int transition_get_audio( mlt_frame frame_a, void **buffer, mlt_audio_for
+ mlt_frame_get_audio( frame_a, (void**) &buffer_a, format, &frequency_a, &channels_a, &samples_a );
+
+ // Prevent dividing by zero.
+- if ( !channels_a || !channels_b )
++ if ( !channels_a || !channels_b || !buffer_a || !buffer_b )
+ return 1;
+
+ if ( buffer_b == buffer_a )
diff --git a/media-libs/mlt/mlt-6.20.0-r2.ebuild b/media-libs/mlt/mlt-6.20.0-r2.ebuild
index 6edc6c8f9cb1..4f93b42419b8 100644
--- a/media-libs/mlt/mlt-6.20.0-r2.ebuild
+++ b/media-libs/mlt/mlt-6.20.0-r2.ebuild
@@ -87,6 +87,7 @@ PATCHES=(
"${FILESDIR}"/${P}-qt-5.15.patch
"${FILESDIR}"/${P}-no-gtk2.patch
"${FILESDIR}"/${P}-opencv4.patch
+ "${FILESDIR}"/${P}-nullpointer-crash.patch
)
pkg_setup() {