summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libksba/libksba-1.3.5-r2.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/dev-libs/libksba/libksba-1.3.5-r2.ebuild b/dev-libs/libksba/libksba-1.3.5-r2.ebuild
index 78876e7ec539..fa41b9b66193 100644
--- a/dev-libs/libksba/libksba-1.3.5-r2.ebuild
+++ b/dev-libs/libksba/libksba-1.3.5-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,15 +16,17 @@ RDEPEND=">=dev-libs/libgpg-error-1.8"
DEPEND="${RDEPEND}"
src_configure() {
- econf \
- $(use_enable static-libs static) \
- GPG_ERROR_CONFIG="${EROOT}/usr/bin/${CHOST}-gpg-error-config" \
- LIBGCRYPT_CONFIG="${EROOT}/usr/bin/${CHOST}-libgcrypt-config" \
- $("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g')
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ GPG_ERROR_CONFIG="${EROOT}/usr/bin/${CHOST}-gpg-error-config"
+ LIBGCRYPT_CONFIG="${EROOT}/usr/bin/${CHOST}-libgcrypt-config"
+ $("${S}/configure" --help | grep -o -- '--without-.*-prefix')
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {
default
# ppl need to use lib*-config for --cflags and --libs
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -type f -name '*.la' -delete || die
}