summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/wmmp/Manifest1
-rw-r--r--x11-plugins/wmmp/wmmp-0.12.6.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-plugins/wmmp/Manifest b/x11-plugins/wmmp/Manifest
index f891308fcffc..b3670918d86c 100644
--- a/x11-plugins/wmmp/Manifest
+++ b/x11-plugins/wmmp/Manifest
@@ -1 +1,2 @@
DIST WMmp-0.10.0.tar.gz 228560 BLAKE2B ec405452112131cad8738b28d13bdbe7f6a60a3204374aa76632bb0cb16c3eea087e58f5294354bd4c201bd9b989d009d417c38fa09d334a4ab72c08e0c527c3 SHA512 5a2777afcb879dd42556f169d4e472660f3cb2bd2b3a1e3833328d3be793e859f7b36dce6e59ca39a4a074b89d305a7704d60382dfc6bed0578c046fe3a8598c
+DIST wmmp-0.12.6.tar.gz 33440 BLAKE2B 130d56906f52681147e4a384f578f14b6eb4a958026ad47d8e6726bb35e3ac4324d73bae225e37b512794ca1eaaace4cca413ef518e7456abe4592d14b863e2a SHA512 e2f293743e1d96283179c64a3af30b4f0405e3b9754aac74f92f7c4ce66efc1aeaca1e8ad586c1b3dd596a6145efad3366687bb5fa601e69fcbf33b302154816
diff --git a/x11-plugins/wmmp/wmmp-0.12.6.ebuild b/x11-plugins/wmmp/wmmp-0.12.6.ebuild
new file mode 100644
index 000000000000..8cb845e58314
--- /dev/null
+++ b/x11-plugins/wmmp/wmmp-0.12.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Window Maker dock app client for mpd (Music Player Daemon)"
+HOMEPAGE="https://github.com/yogsothoth/wmmp"
+SRC_URI="https://github.com/yogsothoth/wmmp/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ doman "${CMAKE_USE_DIR}/doc/WMmp.1"
+ dobin "${BUILD_DIR}/bin/WMmp"
+}