summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-cluster/pmix/Manifest1
-rw-r--r--sys-cluster/pmix/metadata.xml16
-rw-r--r--sys-cluster/pmix/pmix-2.1.1.ebuild29
3 files changed, 46 insertions, 0 deletions
diff --git a/sys-cluster/pmix/Manifest b/sys-cluster/pmix/Manifest
new file mode 100644
index 000000000000..3d268978deb3
--- /dev/null
+++ b/sys-cluster/pmix/Manifest
@@ -0,0 +1 @@
+DIST pmix-2.1.1.tar.bz2 1063090 BLAKE2B 35a3bf7d297d399e897f9b9f748e176262cc0fde5afbfc9ea1e21e5c1550cf0081d9924692d7592fe1224eb727a9c3bb7b3fd216ae1b9e09dd29aefe83ac9eba SHA512 2e5d4b3c907ea9f54bb2b682c63fedb6e6c5cfad578c51bb64c805368ccd35adb317fc472867c717e0cd1d90bf13b18655a62041840c33b4a178c25bb3297d3d
diff --git a/sys-cluster/pmix/metadata.xml b/sys-cluster/pmix/metadata.xml
new file mode 100644
index 000000000000..f0314db0b37c
--- /dev/null
+++ b/sys-cluster/pmix/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cluster@gentoo.org</email>
+ <name>Gentoo Cluster Project</name>
+ </maintainer>
+ <use>
+ <flag name="munge">Enable authentication via munge</flag>
+ <flag name="pmi">Build PMI1 and PMI2 interface</flag>
+ </use>
+</pkgmetadata>
diff --git a/sys-cluster/pmix/pmix-2.1.1.ebuild b/sys-cluster/pmix/pmix-2.1.1.ebuild
new file mode 100644
index 000000000000..6bce06897de1
--- /dev/null
+++ b/sys-cluster/pmix/pmix-2.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="The Process Management Interface (PMI) Exascale"
+HOMEPAGE="https://pmix.github.io/pmix/"
+SRC_URI="https://github.com/pmix/pmix/releases/download/v${PV}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +munge pmi"
+
+RDEPEND="
+ dev-libs/libevent:0=
+ sys-cluster/ucx
+ sys-libs/zlib:0=
+ munge? ( sys-auth/munge )
+ pmi? ( !sys-cluster/slurm )
+ "
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable pmi pmi-backward-compatibility) \
+ $(use_with munge)
+}