summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/seahorse/Manifest1
-rw-r--r--app-crypt/seahorse/seahorse-3.34.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-crypt/seahorse/Manifest b/app-crypt/seahorse/Manifest
index c46fe1890f8c..2570ad776f70 100644
--- a/app-crypt/seahorse/Manifest
+++ b/app-crypt/seahorse/Manifest
@@ -1 +1,2 @@
DIST seahorse-3.32.2.tar.xz 1278668 BLAKE2B cd3fe6794ca02b1b0fd4b833a7128b8180137441a788f1f3ec5bb4186517ebb9e7422fabab2d19f60420b36e6b1ecab8b8326c99122aad185b8e45927232708f SHA512 e372f79907fbc5d60a41ea0db3a91575b0b304c1727c6091f94eec28445cd836faa32754582c59fd1eb8ce784986e63b4c8cabbd46d5e4cacec1150d9ca08481
+DIST seahorse-3.34.1.tar.xz 1271616 BLAKE2B 64956d0ee4f15bc048f42cefd827aad91927b34eecf4a2e53d988c379b3eae1ce0ae29ef469c2ff80ec9cceeaf77a271c57e28cb98dd24ae55c048faff487c1d SHA512 d2dff7d73a0968c1a5a8d39460f08b67f6794f22812200f564ef719354ab5cc2dac2213cba0d4bc10a455aecb9f55de8ff39943db4482beaac9cfdc2ca1012b8
diff --git a/app-crypt/seahorse/seahorse-3.34.1.ebuild b/app-crypt/seahorse/seahorse-3.34.1.ebuild
new file mode 100644
index 000000000000..2f9feb4c7928
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-3.34.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org gnome2-utils meson xdg vala
+
+DESCRIPTION="Manage your passwords and encryption keys"
+HOMEPAGE="https://wiki.gnome.org/Apps/Seahorse"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+IUSE="ldap zeroconf"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=app-crypt/gcr-3.11.91:=
+ >=app-crypt/gpgme-1.7.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=app-crypt/gnupg-2.0.12
+ >=app-crypt/libsecret-0.16
+ dev-libs/libpwquality
+ net-misc/openssh
+ ldap? ( net-nds/openldap:= )
+ >=net-libs/libsoup-2.33.92:2.4
+ zeroconf? ( >=net-dns/avahi-0.6:=[dbus] )
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ app-crypt/gcr[vala]
+ app-crypt/libsecret[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dhelp=true
+ -Dpgp-support=true
+ -Dcheck-compatible-gpg=false # keep lowest version listed as compatible as min dep for gnupg RDEPEND
+ -Dpkcs11-support=true
+ -Dkeyservers-support=true
+ -Dhkp-support=true
+ $(meson_use ldap ldap-support)
+ $(meson_use zeroconf key-sharing)
+ -Dmanpage=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}