summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/zarith/zarith-1.12.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-ml/zarith/zarith-1.12.ebuild b/dev-ml/zarith/zarith-1.12.ebuild
index 365b3503fd38..1b285165f7c6 100644
--- a/dev-ml/zarith/zarith-1.12.ebuild
+++ b/dev-ml/zarith/zarith-1.12.ebuild
@@ -29,8 +29,10 @@ src_configure() {
tc-export CC AR
./configure \
-ocamllibdir /usr/$(get_libdir)/ocaml \
- -installdir "${ED}"/usr/$(get_libdir)/ocaml \
$(usex mpir "-mpir" "-gmp") || die
+ sed -i \
+ -e 's|$(INSTALLDIR)|$(DESTDIR)$(INSTALLDIR)|g' \
+ project.mak || die
}
src_compile() {
@@ -48,6 +50,7 @@ src_install() {
emake \
HASOCAMLOPT=$(usex ocamlopt yes no) \
HASDYNLINK=$(usex ocamlopt yes no) \
+ DESTDIR="${ED}" \
install
dosym zarith/libzarith.a /usr/$(get_libdir)/ocaml/libzarith.a