summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/gemato/gemato-9999.ebuild12
-rw-r--r--app-portage/gemato/metadata.xml2
2 files changed, 13 insertions, 1 deletions
diff --git a/app-portage/gemato/gemato-9999.ebuild b/app-portage/gemato/gemato-9999.ebuild
index 244ff5bbf7f5..375377b795d5 100644
--- a/app-portage/gemato/gemato-9999.ebuild
+++ b/app-portage/gemato/gemato-9999.ebuild
@@ -16,16 +16,26 @@ EGIT_REPO_URI="https://github.com/mgorny/gemato.git"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS=""
-IUSE="+blake2 bzip2 +gpg lzma sha3"
+IUSE="+blake2 bzip2 +gpg lzma +portage-postsync sha3"
RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
gpg? ( app-crypt/gnupg )
lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
+ portage-postsync? ( app-crypt/gentoo-keys )
sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
DEPEND="${RDEPEND}"
python_test() {
esetup.py test
}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use portage-postsync; then
+ exeinto /etc/portage/repo.postsync.d
+ doexe utils/repo.postsync.d/00gemato
+ fi
+}
diff --git a/app-portage/gemato/metadata.xml b/app-portage/gemato/metadata.xml
index 23ea67a25989..ae9f30181418 100644
--- a/app-portage/gemato/metadata.xml
+++ b/app-portage/gemato/metadata.xml
@@ -10,6 +10,8 @@
functions</flag>
<flag name='gpg'>Install dependencies needed for OpenPGP
signature verification support</flag>
+ <flag name='portage-postsync'>Install a Portage hook to verify
+ the repository after fetching via rsync</flag>
<flag name='sha3'>Install dependencies needed for SHA3 hash
functions</flag>
</use>