summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/pecl-rrd/pecl-rrd-1.1.3-r1.ebuild16
-rw-r--r--dev-php/pecl-rrd/pecl-rrd-1.1.3-r2.ebuild42
-rw-r--r--dev-php/pecl-rrd/pecl-rrd-2.0.1-r1.ebuild20
-rw-r--r--dev-php/pecl-rrd/pecl-rrd-2.0.1-r2.ebuild42
4 files changed, 84 insertions, 36 deletions
diff --git a/dev-php/pecl-rrd/pecl-rrd-1.1.3-r1.ebuild b/dev-php/pecl-rrd/pecl-rrd-1.1.3-r1.ebuild
deleted file mode 100644
index 910275dbd2ee..000000000000
--- a/dev-php/pecl-rrd/pecl-rrd-1.1.3-r1.ebuild
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_PHP="php5-6"
-
-inherit php-ext-pecl-r3
-
-DESCRIPTION="RRDtool bindings for PHP"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="net-analyzer/rrdtool[graph]"
-RDEPEND="${DEPEND}"
diff --git a/dev-php/pecl-rrd/pecl-rrd-1.1.3-r2.ebuild b/dev-php/pecl-rrd/pecl-rrd-1.1.3-r2.ebuild
new file mode 100644
index 000000000000..ac2a4557ce6d
--- /dev/null
+++ b/dev-php/pecl-rrd/pecl-rrd-1.1.3-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php5-6"
+
+DESCRIPTION="RRDtool bindings for PHP"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="php_targets_php5-6? ( net-analyzer/rrdtool[graph] )"
+RDEPEND="${DEPEND}"
+
+PDEPEND="
+ php_targets_php7-0? ( dev-php/pecl-rrd:7[php_targets_php7-0(-)] )
+ php_targets_php7-1? ( dev-php/pecl-rrd:7[php_targets_php7-1(-)] )
+"
+
+src_prepare() {
+ if use php_targets_php5-6 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=()
+ php-ext-source-r3_src_configure
+}
+
+src_install() {
+ if use php_targets_php5-6 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}
diff --git a/dev-php/pecl-rrd/pecl-rrd-2.0.1-r1.ebuild b/dev-php/pecl-rrd/pecl-rrd-2.0.1-r1.ebuild
deleted file mode 100644
index 4501a33effcd..000000000000
--- a/dev-php/pecl-rrd/pecl-rrd-2.0.1-r1.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# Define 5.6 here to have the {,REQUIRED_}USE generated
-USE_PHP="php5-6 php7-0"
-
-inherit php-ext-pecl-r3
-
-# But we really only build 7.0
-USE_PHP="php7-0"
-
-DESCRIPTION="RRDtool bindings for PHP"
-LICENSE="BSD"
-SLOT="7"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="net-analyzer/rrdtool[graph]"
-RDEPEND="${DEPEND} php_targets_php5-6? ( ${CATEGORY}/${PN}:0 )"
diff --git a/dev-php/pecl-rrd/pecl-rrd-2.0.1-r2.ebuild b/dev-php/pecl-rrd/pecl-rrd-2.0.1-r2.ebuild
new file mode 100644
index 000000000000..08528ee02abb
--- /dev/null
+++ b/dev-php/pecl-rrd/pecl-rrd-2.0.1-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define 5.6 here to have the {,REQUIRED_}USE generated
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+# But we really only build 7.0
+USE_PHP="php7-0 php7-1"
+
+DESCRIPTION="RRDtool bindings for PHP"
+LICENSE="BSD"
+SLOT="7"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ php_targets_php7-0? ( net-analyzer/rrdtool[graph] )
+ php_targets_php7-1? ( net-analyzer/rrdtool[graph] )
+"
+RDEPEND="${DEPEND} php_targets_php5-6? ( ${CATEGORY}/${PN}:0 )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=()
+ php-ext-source-r3_src_configure
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}