summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-firmware/sgabios/sgabios-0.1_pre10.ebuild14
1 files changed, 2 insertions, 12 deletions
diff --git a/sys-firmware/sgabios/sgabios-0.1_pre10.ebuild b/sys-firmware/sgabios/sgabios-0.1_pre10.ebuild
index 1f4e844ac430..150fd1ef8bec 100644
--- a/sys-firmware/sgabios/sgabios-0.1_pre10.ebuild
+++ b/sys-firmware/sgabios/sgabios-0.1_pre10.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit toolchain-funcs
@@ -12,24 +12,14 @@ HOMEPAGE="https://code.google.com/p/sgabios/"
SRC_URI="mirror://gentoo/${P}.tar.gz
!binary? ( https://dev.gentoo.org/~tamiko/distfiles/${P}.tar.gz )
binary? ( https://dev.gentoo.org/~tamiko/distfiles/${P}-bin.tar.xz )"
+S="${WORKDIR}/sgabios-a85446a"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="+binary"
-
REQUIRED_USE="!amd64? ( !x86? ( binary ) )"
-S="${WORKDIR}/sgabios-a85446a"
-
-src_prepare() {
- if use binary; then
- eapply_user
- return
- fi
- default
-}
-
src_compile() {
use binary && return