summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/global/files/global-6.6.4-fno-common.patch44
-rw-r--r--dev-util/global/global-6.6.4.ebuild7
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-util/global/files/global-6.6.4-fno-common.patch b/dev-util/global/files/global-6.6.4-fno-common.patch
new file mode 100644
index 000000000000..5a85cc125683
--- /dev/null
+++ b/dev-util/global/files/global-6.6.4-fno-common.patch
@@ -0,0 +1,44 @@
+--- a/libutil/args.c
++++ b/libutil/args.c
+@@ -39,7 +39,7 @@
+ #define ARGS_GFIND 3
+ #define ARGS_BOTH 4
+
+-int type;
++static int type;
+ const char **argslist;
+ FILE *ip;
+ GFIND *gp;
+--- a/libutil/convert.c
++++ b/libutil/convert.c
+@@ -46,7 +46,7 @@
+
+ #include "convert.h"
+ static int debug = 0;
+-int flags;
++static int flags;
+
+ /**
+ * This module converts records before output.
+--- a/libutil/gpathop.c
++++ b/libutil/gpathop.c
+@@ -49,7 +49,7 @@
+ static int opened;
+ static int created;
+
+-int openflags;
++static int openflags;
+ void
+ set_gpath_flags(int flags) {
+ openflags = flags;
+--- a/libutil/version.c
++++ b/libutil/version.c
+@@ -30,7 +30,7 @@
+ #endif
+ #include "version.h"
+
+-const char *copy = "\
++static const char *copy = "\
+ Copyright (c) %s Tama Communications Corporation\n\
+ License GPLv3+: GNU GPL version 3 or later <http://www.gnu.org/licenses/gpl.html>\n\
+ This is free software; you are free to change and redistribute it.\n\
diff --git a/dev-util/global/global-6.6.4.ebuild b/dev-util/global/global-6.6.4.ebuild
index ebb9cd1c3afb..48f5dfdc0a92 100644
--- a/dev-util/global/global-6.6.4.ebuild
+++ b/dev-util/global/global-6.6.4.ebuild
@@ -27,7 +27,7 @@ RDEPEND="
sys-devel/libtool:2
)"
-DEPEND="${DEPEND}
+DEPEND="${RDEPEND}
doc? (
app-text/texi2html
sys-apps/texinfo
@@ -35,7 +35,10 @@ DEPEND="${DEPEND}
SITEFILE="50gtags-gentoo.el"
-PATCHES=( "${FILESDIR}/${PN}-6.2.9-tinfo.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-6.2.9-tinfo.patch"
+ "${FILESDIR}/${PN}-6.6.4-fno-common.patch"
+)
DOCS=( AUTHORS FAQ NEWS README THANKS )