summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.3.22.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 84716cf15ae3..7d848a4e04d5 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.2.10.tar.gz 2202147 SHA256 8541895aa2abe2183fa15efe33794db7428fec3302e0c9bf1db13fa1668e2b66 SHA512 5395776f50c5302d2fa75af702ced17da66a4c0435d62aed907f1ceaa93d38acc2d91a250d2153d852239a08d9f7f0bf361523cc89168a6cb81ef6f8a6ec5124 WHIRLPOOL aa4ff7a2aa1a900642782783b85479943bcce85c7df0c056d989d329c0693424110859a1d9d358e0cc5af94be174c96786c2f339e78934c114011606dfce11ec
DIST botocore-1.3.14.tar.gz 2289202 SHA256 44904496f26370f47469327e5df10e439aa07aaf1c0516c7c67352337eeeb729 SHA512 7cf1a342271b02842c5d989fa4ac2bb02074f8ff18dda70c751857f44b83e2ce02c904f0484a05f274bcb9459bf580e0456b72554e87509b2f2529170a239362 WHIRLPOOL efa0d700bdd7e9803be63fc3a54fffb4234356769b1dea69bf93c974deb9a3a3438d88de004dce6a0c83390042fb8f2b822d9204f6727eceb5aee657c22c6a98
DIST botocore-1.3.20.tar.gz 2326244 SHA256 9760d883611110a05f5f8346c7b2198aef87be9117d4cbe1e4ee6608a560c4a2 SHA512 bd8d80598631610da4f05c8cc735affef31c726dc30512e358950e967efefbe63455bc63dccbb180f059a3f9da6c0004edfafc9bf99198732708c1ef141f0b06 WHIRLPOOL 18ba18fa6d62b10d7547f58bf6e8d26cab8564f4e8a229dd6f939db6b4f4d05edda4a239811067443d14edcfe2b293acdb449fc809f551f99b4ff37e4fb70fbd
+DIST botocore-1.3.22.tar.gz 2349601 SHA256 02a6d320b09179bc5dcbafd4be732d9431bfebf5bed6d6b6508eca96b599a399 SHA512 7b349a78c83051a29993ce00a11ecfa4734425c3ed27ce3e405140e19017b5c670d857ea489ea1f6f3ec767b3e4704547565b2ec67f5d7001a0cc30ff2a39de7 WHIRLPOOL 98c5e7488c6d1fe5c3e3484c770f8b346508359c5d174e5660f10ea62b054f442e3d15cc716ddd5acc42f1af0a10463c1923de138338175f1dcba9ced283c8ee
diff --git a/dev-python/botocore/botocore-1.3.22.ebuild b/dev-python/botocore/botocore-1.3.22.ebuild
new file mode 100644
index 000000000000..44e0a6ae37a9
--- /dev/null
+++ b/dev-python/botocore/botocore-1.3.22.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-3.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+ <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}