summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mate-base/mate-desktop/Manifest1
-rw-r--r--mate-base/mate-desktop/mate-desktop-1.18.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/mate-base/mate-desktop/Manifest b/mate-base/mate-desktop/Manifest
index d27dc1fb967e..79b6bf2bd5c3 100644
--- a/mate-base/mate-desktop/Manifest
+++ b/mate-base/mate-desktop/Manifest
@@ -1,3 +1,4 @@
DIST mate-desktop-1.12.1.tar.xz 773332 SHA256 d9b96ac455340916a11b221d45a940c347e4428e5096035496d9f703eacf5a03 SHA512 bcd3731bded736cdb4e0531d9c35253c025fa654d51f3ffb72ad7768ef62a1407b6ef62c2ff6beb45b0a30c2fe85e8d72c3e13068c92716e85f99f103b562c9e WHIRLPOOL 149b970d99d684230f9ec0d31b08062d2dcc8a547973dcde105f5bc903714b0f5cbbf60f2a06c3fbb1bdf87892362bd0785784b81c7f61ceeac319feefd2a445
DIST mate-desktop-1.14.1.tar.xz 829244 SHA256 97b5067c3b9a0b96494cf189dc94e64ac852cd21cddc27961e7b744f550d5786 SHA512 b8d9688bfbea83d1264bce32be72fcb629b007e073553af24a9a79895baa29db3137cf6eed6a1bdf1a0b16ba3e02de892e85cbcfa62b84773d02fce71311496d WHIRLPOOL ade1e0367d033386393d95eabafbcc0f8a8d21c025875997aa0e4ff52cdf5c53c7b61eccdf8cddcc81c023b4268dd35098807c111545b40dc81576d698dddff4
DIST mate-desktop-1.16.1.tar.xz 810184 SHA256 587a8da6e65386015101992e1082bb4d4d38420873c70348ba55dc9f9f63f6df SHA512 4daec6ef5e9fd523962d34d59ecda91acb3831825100b2a96836d402dc187e1a4123642149bfa600a22a9ff1ed2a83632176a5864e2df027b29c5d42ef9d598d WHIRLPOOL be024eaea8b0f149dcc2316e481b2e8b9005580d742ee8f3088863580cbe665a8bd480cdd5b6b228934e51fbd1af9bd549721e2c0b4c1b7a569ffad113284985
+DIST mate-desktop-1.18.0.tar.xz 827332 SHA256 6f2dd9fc60bacd0ff27b8328c7addceb9e73a75c7dce7db4132659d588173b8a SHA512 0490e9810009923fa315e7f191103bc797c37f4417cf41bf317c55d26f7b52a848a65c28dde6903a861694c131ca52f3ed0be05cbbf6b2dd1cb216539f513220 WHIRLPOOL bfa312c8b8abb476c8e322874c5f9ddd586b8341c0324b01cc4193d9d7b7dd135bb00eda5a89ca881276dae940f2d920cda8ace36290211b55134e45cd6241fb
diff --git a/mate-base/mate-desktop/mate-desktop-1.18.0.ebuild b/mate-base/mate-desktop/mate-desktop-1.18.0.ebuild
new file mode 100644
index 000000000000..ff8a88e3707d
--- /dev/null
+++ b/mate-base/mate-desktop/mate-desktop-1.18.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Libraries for the MATE desktop that are not part of the UI"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="X debug +introspection startup-notification"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.36:2
+ >=gnome-base/dconf-0.13.4:0
+ x11-libs/cairo:0
+ x11-libs/libX11:0
+ >=x11-libs/libXrandr-1.3:0
+ virtual/libintl:0
+ >=x11-libs/gtk+-3.0:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+ startup-notification? ( >=x11-libs/startup-notification-0.5:0 )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40:*
+ sys-devel/gettext:*
+ >=x11-proto/randrproto-1.3:0
+ x11-proto/xproto:0
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ --enable-mate-about \
+ $(use_with X x) \
+ $(use_enable debug) \
+ $(use_enable introspection) \
+ $(use_enable startup-notification)
+}