summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/luminance-hdr/Manifest1
-rw-r--r--media-gfx/luminance-hdr/files/luminance-hdr-2.3.1-docs.patch17
-rw-r--r--media-gfx/luminance-hdr/files/luminance-hdr-2.3.1-no-git.patch54
-rw-r--r--media-gfx/luminance-hdr/files/luminance-hdr-2.3.1-openmp-automagic.patch40
-rw-r--r--media-gfx/luminance-hdr/files/luminance-hdr-2.4.0-fits-automagic.patch36
-rw-r--r--media-gfx/luminance-hdr/files/luminance-hdr-2.4.0-qtprinter.patch99
-rw-r--r--media-gfx/luminance-hdr/files/luminance-hdr-2.4.0-qtquick.patch13
-rw-r--r--media-gfx/luminance-hdr/luminance-hdr-2.4.0.ebuild86
8 files changed, 0 insertions, 346 deletions
diff --git a/media-gfx/luminance-hdr/Manifest b/media-gfx/luminance-hdr/Manifest
index 2e474e03980..5a667dceda6 100644
--- a/media-gfx/luminance-hdr/Manifest
+++ b/media-gfx/luminance-hdr/Manifest
@@ -1,2 +1 @@
-DIST luminance-hdr-2.4.0.tar.bz2 10507522 BLAKE2B b8dc777211b63e4e03466612e1c4b7c685f921db292712c749fc14d9638a69fd735990fd5412c7376a7452911cb15212448afc03aa8407f0d6f9c65fac5d5769 SHA512 aa14a13d12ba382f5f8dcb79a57aa68864678db62f036ac2d8b8959da76f20b938481932a6fff3861eb6dbc5a1d4f06bc1f3e3ca9a6ce4f7a27a9db736aa8702
DIST luminance-hdr-2.5.1.tar.bz2 10238826 BLAKE2B 02cc275e2433281e9305e07efb6f77a611ca8e8167ca478a0c4a4c16feab260203aeef501b24b52b54ff9ad92923fd52b2c6925d81e60b492f0ac2465e65b604 SHA512 5d2165ca69080b67426cbc7e30c3ad5545f1a9dacf09e76684c619633cd40b03ed2d0e32181a5dce9463addf20dce1afb58cbf4c0710688e143112687448be2c
diff --git a/media-gfx/luminance-hdr/files/luminance-hdr-2.3.1-docs.patch b/media-gfx/luminance-hdr/files/luminance-hdr-2.3.1-docs.patch
deleted file mode 100644
index 514ded78220..00000000000
--- a/media-gfx/luminance-hdr/files/luminance-hdr-2.3.1-docs.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Don't install extra docs and fix install dir.
-
---- luminance-hdr-2.3.1/CMakeLists.txt
-+++ luminance-hdr-2.3.1/CMakeLists.txt
-@@ -250,12 +250,6 @@
-
- INSTALL(FILES ${CMAKE_SOURCE_DIR}/images/luminance-hdr.png DESTINATION share/icons/hicolor/48x48/apps) # icon
- INSTALL(FILES ${CMAKE_SOURCE_DIR}/luminance-hdr.desktop DESTINATION share/applications) #desktop entry
-- INSTALL(FILES
-- ${CMAKE_SOURCE_DIR}/AUTHORS
-- ${CMAKE_SOURCE_DIR}/README
-- ${CMAKE_SOURCE_DIR}/LICENSE
-- ${CMAKE_SOURCE_DIR}/Changelog
-- DESTINATION share/luminance-hdr) #info files
- INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/help DESTINATION share/luminance-hdr) # help directory
- # Microsoft Windows
- ELSEIF(WIN32)
diff --git a/media-gfx/luminance-hdr/files/luminance-hdr-2.3.1-no-git.patch b/media-gfx/luminance-hdr/files/luminance-hdr-2.3.1-no-git.patch
deleted file mode 100644
index fe95265a684..00000000000
--- a/media-gfx/luminance-hdr/files/luminance-hdr-2.3.1-no-git.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-Don't try to define the git version of the release.
-
---- luminance-hdr-2.3.1/CMakeLists.txt
-+++ luminance-hdr-2.3.1/CMakeLists.txt
-@@ -32,12 +32,6 @@
- ${QT_QTCORE_LIBRARIES} ${QT_QTGUI_LIBRARIES} ${QT_QTNETWORK_LIBRARIES}
- ${QT_QTWEBKIT_LIBRARIES} ${QT_QTXML_LIBRARIES} ${QT_QTSQL_LIBRARIES})
-
--FIND_PACKAGE(Git)
--IF(GIT_FOUND)
-- include(GetGitRevisionDescription)
-- get_git_head_revision(GIT_REFSPEC GIT_SHA1)
--ENDIF()
--
- IF(WIN32)
- # Windows Section
-
---- luminance-hdr-2.3.1.orig/src/Common/CMakeLists.txt
-+++ luminance-hdr-2.3.1/src/Common/CMakeLists.txt
-@@ -1,5 +1,3 @@
--CONFIGURE_FILE( ${CMAKE_CURRENT_SOURCE_DIR}/GitSHA1.cpp.in
-- ${CMAKE_CURRENT_BINARY_DIR}/GitSHA1.cpp @ONLY)
- CONFIGURE_FILE( ${CMAKE_CURRENT_SOURCE_DIR}/global.hxx.in
- ${CMAKE_CURRENT_BINARY_DIR}/global.hxx @ONLY)
- CONFIGURE_FILE( ${CMAKE_CURRENT_SOURCE_DIR}/config.h.in
-@@ -32,8 +30,7 @@
-
- ADD_LIBRARY(common ${FILES_H} ${FILES_CPP} ${FILES_MOC} ${FILES_HXX} ${FILES_UI_H}
- ${CMAKE_CURRENT_BINARY_DIR}/global.hxx
-- ${CMAKE_CURRENT_BINARY_DIR}/config.h
-- ${CMAKE_CURRENT_BINARY_DIR}/GitSHA1.cpp)
-+ ${CMAKE_CURRENT_BINARY_DIR}/config.h)
-
- SET(FILES_TO_TRANSLATE ${FILES_TO_TRANSLATE} ${FILES_CPP} ${FILES_H} ${FILES_UI} ${FILES_HXX} PARENT_SCOPE)
- SET(LUMINANCE_MODULES_GUI ${LUMINANCE_MODULES_GUI} common PARENT_SCOPE)
---- luminance-hdr-2.3.1.orig/src/UI/UMessageBox.cpp
-+++ luminance-hdr-2.3.1/src/UI/UMessageBox.cpp
-@@ -28,7 +28,6 @@
-
- #include "UI/UMessageBox.h"
-
--#include "Common/GitSHA1.h"
- #include "Common/config.h"
- #include "Common/archs.h"
- #include "ui_about.h"
-@@ -92,7 +91,7 @@
- ui.authorsBox->setOpenExternalLinks(true);
- ui.thanksToBox->setOpenExternalLinks(true);
- ui.GPLbox->setTextInteractionFlags(Qt::TextSelectableByMouse);
-- ui.label_version->setText(ui.label_version->text().append(QString(LUMINANCEVERSION)).append(" [Build ").append(QString(g_GIT_SHA1).left(6)).append("]"));
-+ ui.label_version->setText(ui.label_version->text().append(QString(LUMINANCEVERSION)));
-
- bool license_file_not_found=true;
- QString docDir = QCoreApplication::applicationDirPath();
diff --git a/media-gfx/luminance-hdr/files/luminance-hdr-2.3.1-openmp-automagic.patch b/media-gfx/luminance-hdr/files/luminance-hdr-2.3.1-openmp-automagic.patch
deleted file mode 100644
index 69fa0324c6a..00000000000
--- a/media-gfx/luminance-hdr/files/luminance-hdr-2.3.1-openmp-automagic.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Only use openmp support if explicitly enabled.
-
---- luminance-hdr-2.3.1/cmake/CompilerSettings.cmake
-+++ luminance-hdr-2.3.1/cmake/CompilerSettings.cmake
-@@ -8,6 +8,8 @@
- ENDIF()
- ENDIF()
-
-+OPTION(USE_OPENMP "Use openmp threading support." ON)
-+
- #Activate C++11 support, when available
- if("${CMAKE_CXX_COMPILER_ID}" MATCHES "GNU")
- execute_process(COMMAND ${CMAKE_CXX_COMPILER} -dumpversion OUTPUT_VARIABLE GCC_VERSION)
-@@ -39,16 +41,18 @@
- endif()
-
- #OpenMP Support under Linux, Windows with MSVC & MacOS X with GCC >= 4.3
--IF(MSVC)
-- FIND_PACKAGE(OpenMP REQUIRED)
-- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${OpenMP_CXX_FLAGS}")
-- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${OpenMP_C_FLAGS}")
--ELSEIF(CMAKE_COMPILER_IS_GNUCC AND UNIX)
-- EXECUTE_PROCESS(COMMAND ${CMAKE_CXX_COMPILER} -dumpversion OUTPUT_VARIABLE GCC_VERSION)
-- IF(GCC_VERSION VERSION_GREATER 4.3 OR GCC_VERSION VERSION_EQUAL 4.3)
-- MESSAGE(STATUS "GCC >= 4.3")
-+IF(USE_OPENMP)
-+ IF(MSVC)
- FIND_PACKAGE(OpenMP REQUIRED)
- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${OpenMP_CXX_FLAGS}")
- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${OpenMP_C_FLAGS}")
-+ ELSEIF(CMAKE_COMPILER_IS_GNUCC AND UNIX)
-+ EXECUTE_PROCESS(COMMAND ${CMAKE_CXX_COMPILER} -dumpversion OUTPUT_VARIABLE GCC_VERSION)
-+ IF(GCC_VERSION VERSION_GREATER 4.3 OR GCC_VERSION VERSION_EQUAL 4.3)
-+ MESSAGE(STATUS "GCC >= 4.3")
-+ FIND_PACKAGE(OpenMP REQUIRED)
-+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${OpenMP_CXX_FLAGS}")
-+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${OpenMP_C_FLAGS}")
-+ ENDIF()
- ENDIF()
- ENDIF()
diff --git a/media-gfx/luminance-hdr/files/luminance-hdr-2.4.0-fits-automagic.patch b/media-gfx/luminance-hdr/files/luminance-hdr-2.4.0-fits-automagic.patch
deleted file mode 100644
index e586c400e42..00000000000
--- a/media-gfx/luminance-hdr/files/luminance-hdr-2.4.0-fits-automagic.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Only use FITS support if explicitly enabled.
-
---- luminance-hdr-2.4.0/CMakeLists.txt
-+++ luminance-hdr-2.4.0/CMakeLists.txt
-@@ -10,6 +10,8 @@
- include(cmake/CompilerSettings.cmake)
- include(cmake/Internationalization.cmake)
-
-+OPTION(USE_FITS "Enable FITS support." ON)
-+
- # find and setup Qt5 for this project
-
- # Tell CMake to run moc when necessary:
-@@ -122,13 +124,15 @@
- INCLUDE_DIRECTORIES(${JPEGLIB_INCLUDE_DIR})
- INCLUDE_DIRECTORIES(${LCMS2_INCLUDE_DIR})
-
--FIND_PACKAGE(CCfits)
--IF(CCFITS_FOUND)
-- INCLUDE_DIRECTORIES(${CCFITS_INCLUDE_DIRS})
-- SET(LIBS ${LIBS} ${CCFITS_LIBRARIES})
-- ADD_DEFINITIONS(-DHAVE_CCFITS)
--ELSE()
-- message(WARNING "CCfits not found! Building without FITS support!")
-+IF(USE_FITS)
-+ FIND_PACKAGE(CCfits REQUIRED)
-+ IF(CCFITS_FOUND)
-+ INCLUDE_DIRECTORIES(${CCFITS_INCLUDE_DIRS})
-+ SET(LIBS ${LIBS} ${CCFITS_LIBRARIES})
-+ ADD_DEFINITIONS(-DHAVE_CCFITS)
-+ ELSE()
-+ MESSAGE(FATAL_ERROR "CCfits not found!")
-+ ENDIF()
- ENDIF()
-
- SET(LIBS ${LIBS} ${OPENEXR_LIBRARIES})
diff --git a/media-gfx/luminance-hdr/files/luminance-hdr-2.4.0-qtprinter.patch b/media-gfx/luminance-hdr/files/luminance-hdr-2.4.0-qtprinter.patch
deleted file mode 100644
index c619308f813..00000000000
--- a/media-gfx/luminance-hdr/files/luminance-hdr-2.4.0-qtprinter.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-From 07e36ef892343b01bf13545866823e6a55044382 Mon Sep 17 00:00:00 2001
-From: Davide Anastasia <davide.anastasia@gmail.com>
-Date: Mon, 29 Sep 2014 08:06:15 +0100
-Subject: [PATCH] Fix QPrinter support
-
----
- CMakeLists.txt | 25 +++++++++++++------------
- src/HelpBrowser/CMakeLists.txt | 3 +--
- src/HelpBrowser/helpbrowser.cpp | 8 +++++---
- 3 files changed, 19 insertions(+), 17 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 1b07692..8a60ad4 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -18,19 +18,20 @@ include(cmake/Internationalization.cmake)
- # to always look for includes there:
- #set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
--find_package(Qt5Core)
--find_package(Qt5Concurrent)
--find_package(Qt5Widgets)
--find_package(Qt5Gui)
--find_package(Qt5Declarative)
--find_package(Qt5WebKit)
--find_package(Qt5WebKitWidgets)
--find_package(Qt5Xml)
--find_package(Qt5Sql)
--find_package(Qt5Network)
--find_package(Qt5LinguistTools)
-+find_package(Qt5Core REQUIRED)
-+find_package(Qt5Concurrent REQUIRED)
-+find_package(Qt5Widgets REQUIRED)
-+find_package(Qt5Gui REQUIRED)
-+find_package(Qt5Declarative REQUIRED)
-+find_package(Qt5WebKit REQUIRED)
-+find_package(Qt5WebKitWidgets REQUIRED)
-+find_package(Qt5Xml REQUIRED)
-+find_package(Qt5Sql REQUIRED)
-+find_package(Qt5Network REQUIRED)
-+find_package(Qt5LinguistTools REQUIRED)
-+find_package(Qt5PrintSupport REQUIRED)
- IF(WIN32)
-- find_package(Qt5WinExtras)
-+ find_package(Qt5WinExtras)
- ENDIF()
-
- # Include the qtmain lib if we are on the windows platform
-diff --git a/src/HelpBrowser/CMakeLists.txt b/src/HelpBrowser/CMakeLists.txt
-index 04319a8..2f4916a 100644
---- a/src/HelpBrowser/CMakeLists.txt
-+++ b/src/HelpBrowser/CMakeLists.txt
-@@ -27,9 +27,8 @@ INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR})
- QT5_WRAP_CPP(FILES_MOC ${FILES_H})
- QT5_WRAP_UI(FILES_UI_H ${FILES_UI})
-
--
- ADD_LIBRARY(helpbrowser ${FILES_H} ${FILES_CPP} ${FILES_MOC} ${FILES_UI_H} ${FILES_HXX})
--qt5_use_modules(helpbrowser Core Concurrent Gui Widgets Xml WebKit WebKitWidgets)
-+qt5_use_modules(helpbrowser Core Concurrent Gui Widgets Xml WebKit WebKitWidgets PrintSupport)
-
- SET(FILES_TO_TRANSLATE ${FILES_TO_TRANSLATE} ${FILES_CPP} ${FILES_H} ${FILES_UI} ${FILES_HXX} PARENT_SCOPE)
- SET(LUMINANCE_MODULES_GUI ${LUMINANCE_MODULES_GUI} helpbrowser PARENT_SCOPE)
-diff --git a/src/HelpBrowser/helpbrowser.cpp b/src/HelpBrowser/helpbrowser.cpp
-index bfd2820..ce7f984 100644
---- a/src/HelpBrowser/helpbrowser.cpp
-+++ b/src/HelpBrowser/helpbrowser.cpp
-@@ -30,6 +30,7 @@ for which a new license (GPL+exception) is in place.
- #include "ui_HelpBrowser.h"
- #include "ui_HelpSideBar.h"
-
-+#include <QDebug>
- #include <QAction>
- #include <QBuffer>
- #include <QDir>
-@@ -45,8 +46,6 @@ for which a new license (GPL+exception) is in place.
- #include <QModelIndex>
- #include <QModelIndexList>
- #include <QPainter>
--#include <QPrinter>
--#include <QPrintDialog>
- #include <QProcess>
- #include <QPushButton>
- #include <QString>
-@@ -56,7 +55,10 @@ for which a new license (GPL+exception) is in place.
- #include <QXmlDefaultHandler>
- #include <QDesktopServices>
-
--#include <QDebug>
-+#include <QtPrintSupport/QPrinter>
-+#include <QtPrintSupport/QPrintDialog>
-+
-+
-
- #include "Common/global.h"
- #include "HelpBrowser/schelptreemodel.h"
---
-2.2.2
-
diff --git a/media-gfx/luminance-hdr/files/luminance-hdr-2.4.0-qtquick.patch b/media-gfx/luminance-hdr/files/luminance-hdr-2.4.0-qtquick.patch
deleted file mode 100644
index 6e1fc2f16ea..00000000000
--- a/media-gfx/luminance-hdr/files/luminance-hdr-2.4.0-qtquick.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Gentoo has a Qt5Quick cmake module instead of a Qt5Declarative one.
-
---- luminance-hdr-2.4.0/CMakeLists.txt
-+++ luminance-hdr-2.4.0/CMakeLists.txt
-@@ -22,7 +22,7 @@
- find_package(Qt5Concurrent REQUIRED)
- find_package(Qt5Widgets REQUIRED)
- find_package(Qt5Gui REQUIRED)
--find_package(Qt5Declarative REQUIRED)
-+find_package(Qt5Quick REQUIRED)
- find_package(Qt5WebKit REQUIRED)
- find_package(Qt5WebKitWidgets REQUIRED)
- find_package(Qt5Xml REQUIRED)
diff --git a/media-gfx/luminance-hdr/luminance-hdr-2.4.0.ebuild b/media-gfx/luminance-hdr/luminance-hdr-2.4.0.ebuild
deleted file mode 100644
index c3c5aab7eee..00000000000
--- a/media-gfx/luminance-hdr/luminance-hdr-2.4.0.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils toolchain-funcs eutils flag-o-matic
-
-MY_P=${P/_/.}
-DESCRIPTION="Graphical user interface that provides a workflow for HDR imaging"
-HOMEPAGE="http://qtpfsgui.sourceforge.net https://github.com/LuminanceHDR/LuminanceHDR"
-SRC_URI="mirror://sourceforge/qtpfsgui/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-LANGS=" cs de es fi fr hi hu id it pl ro ru sk tr zh"
-IUSE="cpu_flags_x86_sse2 fits openmp test ${LANGS// / l10n_}"
-
-RDEPEND="
- dev-libs/boost:0=
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtdeclarative:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtprintsupport:5
- dev-qt/qtsql:5
- dev-qt/qtwebkit:5
- >=media-gfx/exiv2-0.14:0=
- media-libs/lcms:2
- media-libs/libpng:0=
- >=media-libs/libraw-0.13.4:=
- media-libs/ilmbase:=
- >=media-libs/openexr-1.2.2-r2:=
- >=media-libs/tiff-3.8.2-r2:0
- sci-libs/fftw:3.0[threads]
- fits? ( sci-libs/ccfits )
- sci-libs/gsl
- virtual/jpeg:0
-"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
- test? ( dev-cpp/gtest )
-"
-
-DOCS=( AUTHORS BUGS Changelog README TODO )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.3.1-no-git.patch
- "${FILESDIR}"/${PN}-2.3.1-docs.patch
- "${FILESDIR}"/${PN}-2.3.1-openmp-automagic.patch
- "${FILESDIR}"/${P}-fits-automagic.patch
- "${FILESDIR}"/${P}-qtprinter.patch
- "${FILESDIR}"/${P}-qtquick.patch
-)
-
-pkg_pretend() {
- if use cpu_flags_x86_sse2 ; then
- append-flags -msse2
- else
- eerror "This package requires a CPU supporting the SSE2 instruction set."
- die "SSE2 support missing"
- fi
-
- if use openmp ; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
- fi
-}
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_use openmp OPENMP)
- $(cmake-utils_use_use fits FITS)
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- for lang in ${LANGS} ; do
- if ! use l10n_${lang} ; then
- rm -f "${D}"/usr/share/${PN}/i18n/{lang,qt}_${lang}.qm || die
- fi
- done
-}