summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/videorbits/Manifest1
-rw-r--r--media-gfx/videorbits/files/videorbits-2.201-libpng15.patch8
-rw-r--r--media-gfx/videorbits/files/videorbits-2.205-fix-buildsystem.patch19
-rw-r--r--media-gfx/videorbits/files/videorbits-2.205-qa-implicit-declarations.patch23
-rw-r--r--media-gfx/videorbits/videorbits-2.205.ebuild37
5 files changed, 84 insertions, 4 deletions
diff --git a/media-gfx/videorbits/Manifest b/media-gfx/videorbits/Manifest
index f8a756d93c16..8a291d24769b 100644
--- a/media-gfx/videorbits/Manifest
+++ b/media-gfx/videorbits/Manifest
@@ -1 +1,2 @@
DIST videorbits-2.201.tgz 648187 SHA256 2d3b7dd906e2e20e2082b5106b92d279d662a8877ec780cac0913c877642d1bb SHA512 eeb233487ac33702ff58f9434ff1850aac5ede9ecfebe4b1d313f07451c1cbb911ba6adca013136639bc0d01480acd71e5cffddcbf48af5aef58d40f48d6655a WHIRLPOOL f15367d62b123162231c6de69847f286f40d6806809083ea8040cc5f7ce0499afcd0c7174e79915b9eb87e297f0ca9904e392fa840ff5ebad4685d4f754b258b
+DIST videorbits-2.205.tgz 672377 SHA256 cdd5e54cbc888f93f7f75729f301fa7552f6023a0dc641b2845ad09f5307c48d SHA512 faad5a7ab98167d67b7748b4b9aca1ced0e802ed85cba55ba9966d08c48045daa8fef8d387c576dcfa50ace8c4962bb0043bb83e3ba741844ede67d331e4fbf8 WHIRLPOOL b13e95b2e7cc2e56017ea8eafdc45359476f0753b551ec73ad50ee0ead38450b3eb3f987630f1d1193afaad6a157ed99e67bc029619aed8e72985b6d6eab3035
diff --git a/media-gfx/videorbits/files/videorbits-2.201-libpng15.patch b/media-gfx/videorbits/files/videorbits-2.201-libpng15.patch
index e384738b9357..f87132b0be44 100644
--- a/media-gfx/videorbits/files/videorbits-2.201-libpng15.patch
+++ b/media-gfx/videorbits/files/videorbits-2.201-libpng15.patch
@@ -1,5 +1,5 @@
---- src/simple_png_read.c
-+++ src/simple_png_read.c
+--- videorbits-2.205/src/simple_png_read.c
++++ videorbits-2.205/src/simple_png_read.c
@@ -92,7 +92,7 @@
return -1;
}
@@ -18,8 +18,8 @@
fprintf(stderr, "simple_png_read_header: error\n");
png_destroy_read_struct(&png_ptr, &info_ptr, &end_info);
fclose(fp);
---- src/simple_png_write.c
-+++ src/simple_png_write.c
+--- videorbits-2.205/src/simple_png_write.c
++++ videorbits-2.205/src/simple_png_write.c
@@ -18,6 +18,7 @@
#include <stdio.h>
#include <stdlib.h>
diff --git a/media-gfx/videorbits/files/videorbits-2.205-fix-buildsystem.patch b/media-gfx/videorbits/files/videorbits-2.205-fix-buildsystem.patch
new file mode 100644
index 000000000000..8d2359232bc2
--- /dev/null
+++ b/media-gfx/videorbits/files/videorbits-2.205-fix-buildsystem.patch
@@ -0,0 +1,19 @@
+Fix installation paths.
+
+--- videorbits-2.205/images/Makefile.am
++++ videorbits-2.205/images/Makefile.am
+@@ -1,4 +1,4 @@
+-imagesdir = $(prefix)/images
+-images_DATA= v04.pgm v06.pgm
++images_dir = $(datadir)/videorbits/images
++images__DATA= v04.pgm v06.pgm
+
+
+--- videorbits-2.205/lookuptables/Makefile.am
++++ videorbits-2.205/lookuptables/Makefile.am
+@@ -1,3 +1,3 @@
+-lookuptablesdir = $(prefix)/lookuptables
+-lookuptables_DATA=powLookup22.txt powLookup47.txt Kodak_DCS260_response_function
++lookuptables_dir = $(datadir)/videorbits/lookuptables
++lookuptables__DATA=powLookup22.txt powLookup47.txt Kodak_DCS260_response_function
+
diff --git a/media-gfx/videorbits/files/videorbits-2.205-qa-implicit-declarations.patch b/media-gfx/videorbits/files/videorbits-2.205-qa-implicit-declarations.patch
new file mode 100644
index 000000000000..1e46ccf5651e
--- /dev/null
+++ b/media-gfx/videorbits/files/videorbits-2.205-qa-implicit-declarations.patch
@@ -0,0 +1,23 @@
+Fix implicit declarations caused by missing headers and
+failures caused by -Werror=format-security checks
+
+--- videorbits-2.205/src/pchirp2nocrop.c
++++ videorbits-2.205/src/pchirp2nocrop.c
+@@ -1,5 +1,6 @@
+ #include <stdlib.h>
+ #include <math.h>
++#include <string.h>
+ #include "PNMImageOffsetable.h"
+ #include "mat_util.h"
+ #include "boundingbox.h"
+--- videorbits-2.205/src/par.c
++++ videorbits-2.205/src/par.c
+@@ -111,7 +111,7 @@
+
+ /* - - Write file-type number - - */
+ sprintf(magic_number, "P%d\n", data_type);
+- fprintf(file_ptr, magic_number);
++ fprintf(file_ptr, "%s", magic_number);
+
+ /* - - put comments - - */ /* !!!!!! break up long comments */
+ fprintf(file_ptr, "# %s\n", comments);
diff --git a/media-gfx/videorbits/videorbits-2.205.ebuild b/media-gfx/videorbits/videorbits-2.205.ebuild
new file mode 100644
index 000000000000..3be55d712584
--- /dev/null
+++ b/media-gfx/videorbits/videorbits-2.205.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="a collection of programs for creating high dynamic range images"
+HOMEPAGE="http://comparametric.sourceforge.net/"
+SRC_URI="mirror://sourceforge/comparametric/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ sys-libs/zlib
+ media-libs/libpng:0=
+ virtual/jpeg:0
+ sci-libs/fftw:2.1
+ media-libs/netpbm"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.201-libpng15.patch"
+ "${FILESDIR}/${P}-qa-implicit-declarations.patch"
+ "${FILESDIR}/${P}-fix-buildsystem.patch"
+)
+DOCS=( AUTHORS README README.MORE )
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}