summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-cdr/mkcdtoc/mkcdtoc-1.0-r1.ebuild (renamed from app-cdr/mkcdtoc/mkcdtoc-1.0.ebuild)19
1 files changed, 16 insertions, 3 deletions
diff --git a/app-cdr/mkcdtoc/mkcdtoc-1.0.ebuild b/app-cdr/mkcdtoc/mkcdtoc-1.0-r1.ebuild
index c49089a56cab..0f8a1b52bd52 100644
--- a/app-cdr/mkcdtoc/mkcdtoc-1.0.ebuild
+++ b/app-cdr/mkcdtoc/mkcdtoc-1.0-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="command-line utility to create toc-files for cdrdao"
HOMEPAGE="https://sourceforge.net/projects/mkcdtoc/"
@@ -10,7 +10,20 @@ SRC_URI="mirror://sourceforge/mkcdtoc/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND=">=dev-lang/perl-5.8.0"
RDEPEND="${DEPEND}"
+
+src_compile() {
+ # bug #799164
+ emake PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ # bug #799164
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ DESTDIR="${D}" \
+ MANDIR="/usr/share/man" \
+ install
+}