summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/rake-compiler/Manifest1
-rw-r--r--dev-ruby/rake-compiler/rake-compiler-1.0.8.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/rake-compiler/Manifest b/dev-ruby/rake-compiler/Manifest
index 14721e8f1ca..d52a48bf00f 100644
--- a/dev-ruby/rake-compiler/Manifest
+++ b/dev-ruby/rake-compiler/Manifest
@@ -1 +1,2 @@
DIST rake-compiler-1.0.7.tar.gz 33444 BLAKE2B c3a92206d4d7defdf21295aaf094f704596962a3ee79c3517ea1058732e1f9f378b5f14bbe3b9652572564d11c566e26014e187dcdb488409bf95ea9a52e0a7c SHA512 fa901f5cc48891f07bd8d9a27cf4e745e87d5a667dbee0c9f4b43f9564fdfe3067b9c658f10ea8bcacd32ea7320a542ef0fca9373147057472f5572a4a4c5268
+DIST rake-compiler-1.0.8.tar.gz 33547 BLAKE2B 542544543cd6d02a9ff964571244c65a0d748e09ea88027a514f25d13086463094aec29b0961881aa175f9553afcf14fc9f7c12dba0e96a07bf88e21f51e87bf SHA512 30b753d45a1180e034b520ad6385f2799098f0916d55e8b4729f5e3a29dabc1acfa292475edfb384c7809543e1c3e428e28db1bacb5383deb9f4bb31b18d6fe5
diff --git a/dev-ruby/rake-compiler/rake-compiler-1.0.8.ebuild b/dev-ruby/rake-compiler/rake-compiler-1.0.8.ebuild
new file mode 100644
index 00000000000..1c37feb616f
--- /dev/null
+++ b/dev-ruby/rake-compiler/rake-compiler-1.0.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Provide a standard and simplified way to build and package Ruby extensions"
+HOMEPAGE="https://github.com/luislavena/rake-compiler"
+LICENSE="MIT"
+
+SRC_URI="https://github.com/luislavena/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rake"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:3 )"
+
+USE_RUBY="ruby24 ruby25 ruby26" ruby_add_bdepend "test? ( dev-util/cucumber dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ # Make sure the right rspec version is used in cucumber.
+ sed -i -e "1igem 'rspec', '~>2.0'" features/support/env.rb || die
+
+ # Avoid failing features for native gems, this also fails with rubygems
+ sed -i -e '/generate native gem/,$ s:^:#:' features/package.feature || die
+}
+
+each_ruby_test() {
+ # Skip cucumber for new ruby versions (not ready yet)
+ case ${RUBY} in
+ **ruby24|*ruby25|*ruby26)
+ RSPEC_VERSION=3 ruby-ng_rspec
+ ruby-ng_cucumber
+ ;;
+ *)
+ RSPEC_VERSION=3 ruby-ng_rspec
+ ;;
+ esac
+}