summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/ansi2html/ansi2html-1.5.2-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/ansi2html/ansi2html-1.5.2-r2.ebuild b/dev-python/ansi2html/ansi2html-1.5.2-r2.ebuild
new file mode 100644
index 000000000000..6bcbcf7230e1
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.5.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="https://pypi.org/project/ansi2html/ https://github.com/ralphbean/ansi2html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND=">=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ doman man/${PN}.1
+ distutils-r1_python_install_all
+}