summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-3.18.3.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index ea9cd92f9fa2..d61654335936 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,2 +1,3 @@
DIST epiphany-3.16.3.tar.xz 3082680 SHA256 d527f1770779ec22d955aeb13b148a846a26144e433ff0480c981af80e2390b1 SHA512 68f4dc0e299b929f244818d93a9af14f48ef2c3a93813fe5457c11d37ddb5a5e2b5ae3f93f0d41e8095590f87d8679d2cee5b6298c128475a9ad9eb6aa3c8bae WHIRLPOOL c82ff5051ac3c1ac2480b846f77893f39f52517f0aa0f7a6084e8b24e98f490264a6adecd89671d89719da835ca84f0613019e281280380bb20d980c2294afe9
DIST epiphany-3.18.2.tar.xz 3091980 SHA256 8436170731966bb40b7d8e29dbedfa5d5ddbf78572cf5fd51fce1ac6da5da6c2 SHA512 a230f489b2d30cba0682333b1c26a53d223b5d00ac3a0255d0bdc505ee2d3ccb3fa114c290241e601e4af64b39224ee90eea1063e6ba0818f83fb914831382d8 WHIRLPOOL b9d1ec410fff4815ef0e5526bcfbb9670962fd89ea5212a9956996996d64d07ec882212276eaa1734dcc79e466e3d888130b51cd4ade61409419539d38d46fc4
+DIST epiphany-3.18.3.tar.xz 3095720 SHA256 cd4e9ce588c4c66109547d93999d9740d338c3f9dbfbc2143cf2cbb74260def9 SHA512 f519ab4f5742b3ff6b28c079e0086a37b7b7cd55d1cd3a9de0260cab28c25e0179bacf2764aa877e6e389b6a84ef3fd7d59e475c3711d0f1e1593866c177fc6a WHIRLPOOL 483f2735cd72249ef9401dda951934568de2d04ebf98e5397cd6c04945952db6aed402611f35a5e7c3e32d1ff060d363106721c2a380037b1650d37664a7db4d
diff --git a/www-client/epiphany/epiphany-3.18.3.ebuild b/www-client/epiphany/epiphany-3.18.3.ebuild
new file mode 100644
index 000000000000..26e946cd9d89
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.18.3.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+# TODO: coverage
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nss test"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.5.5
+ >=app-crypt/libsecret-0.14
+ >=app-text/iso-codes-0.35
+ >=dev-libs/glib-2.38:2[dbus]
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+ >=net-dns/avahi-0.6.22[dbus]
+ >=net-libs/webkit-gtk-2.9.5:4
+ >=net-libs/libsoup-2.48:2.4
+ >=x11-libs/gtk+-3.13:3
+ >=x11-libs/libnotify-0.5.1:=
+ gnome-base/gnome-desktop:3=
+
+ dev-db/sqlite:3
+ x11-libs/libwnck:3
+ x11-libs/libX11
+
+ nss? ( dev-libs/nss )
+"
+# epiphany-extensions support was removed in 3.7; let's not pretend it still works
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/adwaita-icon-theme
+ !www-client/epiphany-extensions
+"
+# paxctl needed for bug #407085
+# eautoreconf requires gnome-common-3.5.5
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=gnome-base/gnome-common-3.6
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ sys-apps/paxctl
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix unittests
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751591
+ epatch "${FILESDIR}"/${PN}-3.16.0-unittest-1.patch
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751593
+ epatch "${FILESDIR}"/${PN}-3.14.0-unittest-2.patch
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-shared \
+ --disable-static \
+ --with-distributor-name=Gentoo \
+ $(use_enable nss) \
+ $(use_enable test tests)
+}
+
+src_compile() {
+ # needed to avoid "Command line `dbus-launch ...' exited with non-zero exit status 1"
+ unset DISPLAY
+ gnome2_src_compile
+}
+
+src_test() {
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DISPLAY
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog* NEWS README TODO"
+ gnome2_src_install
+}