summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/packagekit-base/files/0001-entropy-PackageKitEntropyClient.output-API-update.patch26
-rw-r--r--app-admin/packagekit-base/files/packagekit-base-0.8.15-qtdbus-annotate.patch12
-rw-r--r--app-admin/packagekit-base/files/packagekit-base-0.8.x-npapi-sdk.patch13
-rw-r--r--app-text/rarian/files/rarian-0.8.1-fix-old-doc.patch13
-rw-r--r--gnome-base/gnome-settings-daemon/files/3.24.2-optional.patch145
-rw-r--r--media-libs/cogl/files/cogl-1.22.0-initial-output.patch46
-rw-r--r--media-libs/cogl/files/cogl-1.22.0-wait-flip.patch42
-rw-r--r--media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch47
-rw-r--r--media-video/subtitleeditor/files/subtitleeditor-0.52.1-build-fix.patch55
-rw-r--r--net-misc/ssh-askpass-fullscreen/files/ssh-askpass-fullscreen.179
-rw-r--r--x11-libs/gtk+/files/gtk+-2.24.27-update-icon-cache.patch64
11 files changed, 542 insertions, 0 deletions
diff --git a/app-admin/packagekit-base/files/0001-entropy-PackageKitEntropyClient.output-API-update.patch b/app-admin/packagekit-base/files/0001-entropy-PackageKitEntropyClient.output-API-update.patch
new file mode 100644
index 000000000000..e24faeec9a50
--- /dev/null
+++ b/app-admin/packagekit-base/files/0001-entropy-PackageKitEntropyClient.output-API-update.patch
@@ -0,0 +1,26 @@
+From ee2dfacb275e8145c7ae1ba8da86779054adf902 Mon Sep 17 00:00:00 2001
+From: Fabio Erculiani <lxnay@sabayon.org>
+Date: Fri, 6 Dec 2013 07:40:15 +0100
+Subject: [PATCH] entropy: PackageKitEntropyClient.output API update
+
+---
+ backends/entropy/entropyBackend.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/backends/entropy/entropyBackend.py b/backends/entropy/entropyBackend.py
+index 57b6c59..bec8ef6 100755
+--- a/backends/entropy/entropyBackend.py
++++ b/backends/entropy/entropyBackend.py
+@@ -776,7 +776,8 @@ class PackageKitEntropyClient(Client):
+ def init_singleton(self):
+ Client.init_singleton(self, url_fetcher = PkUrlFetcher)
+
+- def output(self, text, header = "", footer = "", back = False,
++ @classmethod
++ def output(cls, text, header = "", footer = "", back = False,
+ importance = 0, level = "info", count = None, percent = False):
+ """
+ Reimplemented from entropy.output.TextInterface.
+--
+1.8.4.4
+
diff --git a/app-admin/packagekit-base/files/packagekit-base-0.8.15-qtdbus-annotate.patch b/app-admin/packagekit-base/files/packagekit-base-0.8.15-qtdbus-annotate.patch
new file mode 100644
index 000000000000..69a0fd7e5f49
--- /dev/null
+++ b/app-admin/packagekit-base/files/packagekit-base-0.8.15-qtdbus-annotate.patch
@@ -0,0 +1,12 @@
+Index: PackageKit-0.8.12/src/org.freedesktop.PackageKit.xml
+===================================================================
+--- PackageKit-0.8.12.orig/src/org.freedesktop.PackageKit.xml
++++ PackageKit-0.8.12/src/org.freedesktop.PackageKit.xml
+@@ -317,6 +317,7 @@
+
+ <!--*****************************************************************************************-->
+ <method name="GetPackageHistory">
++ <annotation name="org.qtproject.QtDBus.QtTypeName.Out0" value="QVariant"/>
+ <doc:doc>
+ <doc:description>
+ <doc:para>
diff --git a/app-admin/packagekit-base/files/packagekit-base-0.8.x-npapi-sdk.patch b/app-admin/packagekit-base/files/packagekit-base-0.8.x-npapi-sdk.patch
new file mode 100644
index 000000000000..59b3ab109648
--- /dev/null
+++ b/app-admin/packagekit-base/files/packagekit-base-0.8.x-npapi-sdk.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 3e8d301..7ba7f4b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -361,7 +361,7 @@ AC_ARG_ENABLE(browser_plugin, AS_HELP_STRING([--enable-browser-plugin],[Build br
+ enable_browser_plugin=$enableval,enable_browser_plugin=yes)
+ if test x$enable_browser_plugin = xyes; then
+ PKG_CHECK_MODULES(PK_BROWSER_PLUGIN, \
+- mozilla-plugin >= 8.0 \
++ npapi-sdk \
+ gio-unix-2.0 \
+ nspr >= 4.8 \
+ cairo \
diff --git a/app-text/rarian/files/rarian-0.8.1-fix-old-doc.patch b/app-text/rarian/files/rarian-0.8.1-fix-old-doc.patch
new file mode 100644
index 000000000000..f84f987d8f10
--- /dev/null
+++ b/app-text/rarian/files/rarian-0.8.1-fix-old-doc.patch
@@ -0,0 +1,13 @@
+--- util/rarian-sk-preinstall.cpp.old 2008-09-01 20:40:21.000000000 +0200
++++ util/rarian-sk-preinstall.cpp 2010-01-30 11:29:39.000000000 +0100
+@@ -96,8 +96,8 @@
+ }
+ if (i == 1) {
+ /* Normal path. Add file:/ to the start */
+- new_url = (char *) malloc (sizeof(char) * (strlen (input) + 7));
+- sprintf (new_url, "file:/%s", input);
++ new_url = (char *) malloc (sizeof(char) * (strlen (input) + 8));
++ sprintf (new_url, "file://%s", input);
+ } else {
+ /* Don't know what to do. Just copy and append file: to it */
+ new_url = (char *) malloc (sizeof(char) * (strlen(input) + 6));
diff --git a/gnome-base/gnome-settings-daemon/files/3.24.2-optional.patch b/gnome-base/gnome-settings-daemon/files/3.24.2-optional.patch
new file mode 100644
index 000000000000..64c47a92e3f0
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/3.24.2-optional.patch
@@ -0,0 +1,145 @@
+From 22f6a45b665e604f874e82a817d45bb976d8c5ae Mon Sep 17 00:00:00 2001
+From: Timo Tambet <ttambet@gmail.com>
+Date: Sat, 25 Feb 2017 14:48:19 +0200
+Subject: [PATCH 1/1] [PATCH] Make colord and wacom support optional
+
+---
+ configure.ac | 56 +++++++++++++++++++++++++++++++----------------
+ plugins/Makefile.am | 9 ++++++--
+ plugins/dummy/Makefile.am | 5 ++++-
+ 3 files changed, 48 insertions(+), 22 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 0d169c8f..792195aa 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -158,13 +158,23 @@ PKG_CHECK_MODULES(CLIPBOARD,
+ gtk+-x11-3.0
+ x11)
+
+-PKG_CHECK_MODULES(COLOR,
+- colord >= 1.0.2
+- gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION
+- libcanberra-gtk3
+- libgeoclue-2.0 >= $GEOCLUE_REQUIRED_VERSION
+- lcms2 >= $LCMS_REQUIRED_VERSION
+- libnotify)
++AC_ARG_ENABLE([color],
++ AS_HELP_STRING([--disable-color],
++ [turn off color plugin]),
++ [],
++ [enable_color=yes])
++
++AS_IF([test "$enable_color" = "yes"],
++ [PKG_CHECK_MODULES(COLOR,
++ colord >= 1.0.2
++ gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION
++ libcanberra-gtk3
++ libgeoclue-2.0 >= $GEOCLUE_REQUIRED_VERSION
++ lcms2 >= $LCMS_REQUIRED_VERSION
++ libnotify)
++ AC_DEFINE(HAVE_COLOR, 1, [Define if color plugin is enabled])
++ ])
++AM_CONDITIONAL(BUILD_COLOR, test "x$enable_color" = "xyes")
+
+ PKG_CHECK_MODULES(DATETIME,
+ libnotify >= $LIBNOTIFY_REQUIRED_VERSION
+@@ -268,23 +278,31 @@ case $host_os in
+ if test "$host_cpu" = s390 -o "$host_cpu" = s390x; then
+ have_wacom=no
+ else
+- if test x$enable_gudev != xno; then
+- LIBWACOM_PKG="libwacom >= $LIBWACOM_REQUIRED_VERSION"
+- PKG_CHECK_MODULES(LIBWACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION])
+- PKG_CHECK_MODULES(WACOM, [gtk+-3.0 pango >= $PANGO_REQUIRED_VERSION])
+- PKG_CHECK_MODULES(WACOM_OLED, [gudev-1.0])
+- else
++ have_wacom=no
++ AS_IF([test "$enable_gudev" != "no"],
++ [AC_ARG_ENABLE([wacom],
++ AS_HELP_STRING([--disable-wacom],
++ [turn off wacom plugin]),
++ [],
++ [enable_wacom=no]) dnl Default value
++ AS_IF([test "$enable_wacom" = "xyes"],
++ [
++ PKG_CHECK_MODULES(LIBWACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION])
++ PKG_CHECK_MODULES(WACOM, [gtk+-3.0, pango >= $PANGO_REQUIRED_VERSION])
++ PKG_CHECK_MODULES(WACOM_OLED, [gudev-1.0])
++ have_wacom=yes
++ AC_DEFINE_UNQUOTED(HAVE_WACOM, 1, [Define to 1 if wacom support is available])
++ ])
++ ], [
+ AC_MSG_ERROR([GUdev is necessary to compile Wacom support])
+- fi
+- AC_DEFINE_UNQUOTED(HAVE_WACOM, 1, [Define to 1 if wacom support is available])
+- have_wacom=yes
++ ])
+ fi
+ ;;
+ *)
+- have_wacom=no
+- ;;
++ have_wacom=no
++ ;;
+ esac
+-AM_CONDITIONAL(HAVE_WACOM, test x$have_wacom = xyes)
++AM_CONDITIONAL(BUILD_WACOM, test x$have_wacom = xyes)
+
+ dnl ---------------------------------------------------------------------------
+ dnl - common
+diff --git a/plugins/Makefile.am b/plugins/Makefile.am
+index 9324b406..ee78d6d0 100644
+--- a/plugins/Makefile.am
++++ b/plugins/Makefile.am
+@@ -4,7 +4,6 @@ enabled_plugins = \
+ a11y-keyboard \
+ a11y-settings \
+ clipboard \
+- color \
+ datetime \
+ dummy \
+ power \
+@@ -22,13 +21,19 @@ enabled_plugins = \
+
+ disabled_plugins = $(NULL)
+
++if BUILD_COLOR
++enabled_plugins += color
++else
++disabled_plugins += color
++endif
++
+ if SMARTCARD_SUPPORT
+ enabled_plugins += smartcard
+ else
+ disabled_plugins += smartcard
+ endif
+
+-if HAVE_WACOM
++if BUILD_WACOM
+ enabled_plugins += wacom
+ else
+ disabled_plugins += wacom
+diff --git a/plugins/dummy/Makefile.am b/plugins/dummy/Makefile.am
+index cb5856cf..06ac595a 100644
+--- a/plugins/dummy/Makefile.am
++++ b/plugins/dummy/Makefile.am
+@@ -22,10 +22,13 @@ gsd_dummy_LDADD = $(DUMMY_LIBS) $(top_builddir)/gnome-settings-daemon/libgsd.la
+ desktopdir = $(sysconfdir)/xdg/autostart
+
+ desktop_DATA =
++if !BUILD_COLOR
++desktop_DATA += org.gnome.SettingsDaemon.Color.desktop
++endif
+ if !SMARTCARD_SUPPORT
+ desktop_DATA += org.gnome.SettingsDaemon.Smartcard.desktop
+ endif
+-if !HAVE_WACOM
++if !BUILD_WACOM
+ desktop_DATA += org.gnome.SettingsDaemon.Wacom.desktop
+ endif
+ if !BUILD_PRINT_NOTIFICATIONS
+--
+2.11.1
+
diff --git a/media-libs/cogl/files/cogl-1.22.0-initial-output.patch b/media-libs/cogl/files/cogl-1.22.0-initial-output.patch
new file mode 100644
index 000000000000..d7f9d0ff99f4
--- /dev/null
+++ b/media-libs/cogl/files/cogl-1.22.0-initial-output.patch
@@ -0,0 +1,46 @@
+From 188752158701e3a406e7fd5850b3eaf9c4798cd7 Mon Sep 17 00:00:00 2001
+From: Ray Strode <rstrode@redhat.com>
+Date: Fri, 13 Nov 2015 13:35:05 -0500
+Subject: winsys-egl-kms: bypass initial output setup if kms fd passed in
+
+if mutter is handling the output setup, then we shouldn't do it,
+too.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=758073
+---
+ cogl/winsys/cogl-winsys-egl-kms.c | 12 ++++++++----
+ 1 file changed, 8 insertions(+), 4 deletions(-)
+
+diff --git a/cogl/winsys/cogl-winsys-egl-kms.c b/cogl/winsys/cogl-winsys-egl-kms.c
+index b460907..6d7049d 100644
+--- a/cogl/winsys/cogl-winsys-egl-kms.c
++++ b/cogl/winsys/cogl-winsys-egl-kms.c
+@@ -663,6 +663,14 @@ _cogl_winsys_egl_display_setup (CoglDisplay *display,
+ return FALSE;
+ }
+
++ /* Force a full modeset / drmModeSetCrtc on
++ * the first swap buffers call.
++ */
++ kms_display->pending_set_crtc = TRUE;
++
++ if (kms_renderer->opened_fd < 0)
++ return TRUE;
++
+ output0 = find_output (0,
+ kms_renderer->fd,
+ resources,
+@@ -736,10 +744,6 @@ _cogl_winsys_egl_display_setup (CoglDisplay *display,
+ kms_display->width = output0->mode.hdisplay;
+ kms_display->height = output0->mode.vdisplay;
+
+- /* We defer setting the crtc modes until the first swap_buffers request of a
+- * CoglOnscreen framebuffer. */
+- kms_display->pending_set_crtc = TRUE;
+-
+ return TRUE;
+ }
+
+--
+cgit v0.11.2
+
diff --git a/media-libs/cogl/files/cogl-1.22.0-wait-flip.patch b/media-libs/cogl/files/cogl-1.22.0-wait-flip.patch
new file mode 100644
index 000000000000..b7c4d99a2812
--- /dev/null
+++ b/media-libs/cogl/files/cogl-1.22.0-wait-flip.patch
@@ -0,0 +1,42 @@
+From a583492ea2aa3ea8e78c269bd5db3f52f82aa79c Mon Sep 17 00:00:00 2001
+From: Ray Strode <rstrode@redhat.com>
+Date: Wed, 21 Oct 2015 15:47:01 -0400
+Subject: kms-winsys: don't wait for a flip when page flipping fails
+
+If we get EACCES from drmPageFlip we're not going to get
+a flip event and shouldn't wait for one.
+
+This commit changes the EACCES path to silently ignore the
+failed flip request and just clean up the fb.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=756926
+---
+ cogl/winsys/cogl-winsys-egl-kms.c | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/cogl/winsys/cogl-winsys-egl-kms.c b/cogl/winsys/cogl-winsys-egl-kms.c
+index 20c325c..b460907 100644
+--- a/cogl/winsys/cogl-winsys-egl-kms.c
++++ b/cogl/winsys/cogl-winsys-egl-kms.c
+@@ -590,7 +590,7 @@ flip_all_crtcs (CoglDisplay *display, CoglFlipKMS *flip, int fb_id)
+ for (l = kms_display->crtcs; l; l = l->next)
+ {
+ CoglKmsCrtc *crtc = l->data;
+- int ret;
++ int ret = 0;
+
+ if (crtc->count == 0 || crtc->ignore)
+ continue;
+@@ -610,7 +610,8 @@ flip_all_crtcs (CoglDisplay *display, CoglFlipKMS *flip, int fb_id)
+ }
+ }
+
+- flip->pending++;
++ if (ret == 0)
++ flip->pending++;
+ }
+
+ if (kms_renderer->page_flips_not_supported && needs_flip)
+--
+cgit v0.11.2
+
diff --git a/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch b/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch
new file mode 100644
index 000000000000..ecf9de908cfd
--- /dev/null
+++ b/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch
@@ -0,0 +1,47 @@
+Solves automagic selection of Qt version.
+
+https://bugs.gentoo.org/show_bug.cgi?id=523122
+https://bugzilla.gnome.org/show_bug.cgi?id=737174
+
+diff --git a/configure.ac b/configure.ac
+index e9ead09..3ee710a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -206,6 +206,10 @@ AC_ARG_ENABLE(qt,
+ AS_HELP_STRING([--enable-qt],
+ [enable Qt support, (MP3 album art) [[default=auto]]]),,
+ [enable_qt=auto])
++AC_ARG_WITH(qt-version,
++ AS_HELP_STRING([--with-qt-version=major],
++ [Force specific Qt version [[default=auto]]]),,
++ [with_qt_version=auto])
+
+ selected_for_media_art="no (disabled)"
+
+@@ -218,14 +222,18 @@ if test "x$enable_qt" == "xyes" && test "x$enable_gdkpixbuf" == "xyes"; then
+ fi
+
+ if test "x$enable_qt" != "xno" && test "x$enable_gdkpixbuf" != "xyes"; then
+- PKG_CHECK_MODULES(QT5,
+- [Qt5Gui >= $QT5_REQUIRED],
+- [have_qt5=yes],
+- [have_qt5=no])
+- PKG_CHECK_MODULES(QT4,
+- [QtGui >= $QT4_REQUIRED],
+- [have_qt4=yes],
+- [have_qt4=no])
++ if test "x$with_qt_version" == "xauto" || test "x$with_qt_version" == "x5"; then
++ PKG_CHECK_MODULES(QT5,
++ [Qt5Gui >= $QT5_REQUIRED],
++ [have_qt5=yes],
++ [have_qt5=no])
++ fi
++ if test "x$with_qt_version" == "xauto" || test "x$with_qt_version" == "x4"; then
++ PKG_CHECK_MODULES(QT4,
++ [QtGui >= $QT4_REQUIRED],
++ [have_qt4=yes],
++ [have_qt4=no])
++ fi
+
+ if test "x$have_qt5" = "xyes"; then
+ BACKEND_CFLAGS="$QT5_CFLAGS -fPIC"
diff --git a/media-video/subtitleeditor/files/subtitleeditor-0.52.1-build-fix.patch b/media-video/subtitleeditor/files/subtitleeditor-0.52.1-build-fix.patch
new file mode 100644
index 000000000000..9cce5d2d98f2
--- /dev/null
+++ b/media-video/subtitleeditor/files/subtitleeditor-0.52.1-build-fix.patch
@@ -0,0 +1,55 @@
+Fix build errors with gcc-4.9.3 -std=c++11 (after disabling -ansi)
+
+https://gna.org/bugs/?23714
+
+https://bugs.gentoo.org/show_bug.cgi?id=550764
+https://bugs.gentoo.org/show_bug.cgi?id=566328
+
+--- a/src/subtitleview.cc 2015-12-24 01:52:29.322622155 +0100
++++ b/src/subtitleview.cc 2015-12-24 01:52:44.210491213 +0100
+@@ -1363,7 +1363,7 @@
+ {
+ int num;
+ std::istringstream ss(event->string);
+- bool is_num = ss >> num != 0;
++ bool is_num = static_cast<bool>(ss >> num) != 0;
+ // Update only if it's different
+ if(is_num != get_enable_search())
+ set_enable_search(is_num);
+--- a/src/utility.h 2015-12-24 01:49:42.205104858 +0100
++++ b/src/utility.h 2015-12-24 01:50:23.387737071 +0100
+@@ -91,7 +91,7 @@
+ std::istringstream s(src);
+ // return s >> dest != 0;
+
+- bool state = s >> dest != 0;
++ bool state = static_cast<bool>(s >> dest) != 0;
+
+ if(!state)
+ se_debug_message(SE_DEBUG_UTILITY, "string:'%s'failed.", src.c_str());
+--- a/plugins/actions/dialoguize/dialoguize.cc 2015-12-24 01:06:24.125428454 +0100
++++ b/plugins/actions/dialoguize/dialoguize.cc 2015-12-24 01:06:42.630277006 +0100
+@@ -23,7 +23,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+-#include <auto_ptr.h>
++#include <memory>
+ #include "extension/action.h"
+ #include "i18n.h"
+ #include "debug.h"
+--- a/plugins/actions/documentmanagement/documentmanagement.old 2015-12-24 01:17:13.914730337 +0100
++++ b/plugins/actions/documentmanagement/documentmanagement.cc 2015-12-24 01:17:23.339640430 +0100
+@@ -178,9 +178,9 @@
+
+ ui_id = ui->new_merge_id();
+
+- #define ADD_UI(name) ui->add_ui(ui_id, "/menubar/menu-file/"name, name, name);
+- #define ADD_OPEN_UI(name) ui->add_ui(ui_id, "/menubar/menu-file/menu-open/"name, name, name);
+- #define ADD_SAVE_UI(name) ui->add_ui(ui_id, "/menubar/menu-file/menu-save/"name, name, name);
++ #define ADD_UI(name) ui->add_ui(ui_id, "/menubar/menu-file/" name, name, name);
++ #define ADD_OPEN_UI(name) ui->add_ui(ui_id, "/menubar/menu-file/menu-open/" name, name, name);
++ #define ADD_SAVE_UI(name) ui->add_ui(ui_id, "/menubar/menu-file/menu-save/" name, name, name);
+
+ ADD_UI("new-document");
+ ADD_OPEN_UI("open-document");
diff --git a/net-misc/ssh-askpass-fullscreen/files/ssh-askpass-fullscreen.1 b/net-misc/ssh-askpass-fullscreen/files/ssh-askpass-fullscreen.1
new file mode 100644
index 000000000000..86f97cde03cd
--- /dev/null
+++ b/net-misc/ssh-askpass-fullscreen/files/ssh-askpass-fullscreen.1
@@ -0,0 +1,79 @@
+.\" Hey, EMACS: -*- nroff -*-
+.\" First parameter, NAME, should be all caps
+.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+.\" other parameters are allowed: see man(7), man(1)
+.TH SSH-ASKPASS-FULLSCREEN 1 "May 8 , 2004"
+.\" Please adjust this date whenever revising the manpage.
+.\"
+.\" Some roff macros, for reference:
+.\" .nh disable hyphenation
+.\" .hy enable hyphenation
+.\" .ad l left justify
+.\" .ad b justify to both left and right margins
+.\" .nf disable filling
+.\" .fi enable filling
+.\" .br insert line break
+.\" .sp <n> insert n+1 empty lines
+.\" for manpage-specific macros, see man(7)
+.SH NAME
+ssh-askpass-fullscreen \- A simple replacement for ssh-askpass written with gtk2
+.SH SYNOPSIS
+.B ssh-askpass-fullscreen
+
+.SH DESCRIPTION
+This manual page was written for the Debian distribution
+because the original program does not have a manual page.
+.PP
+
+.B gnome-ssh-askpass
+is a GNOME-based passphrase dialog for use with OpenSSH. It is
+intended to be called by the
+.B ssh-add(1)
+program and not invoked directly. It allows
+.B ssh-add(1)
+to obtain a passphrase from a user, even if not connected to a terminal
+(assuming that an X display is available). This happens auto-matically
+in the case where
+.B ssh-add
+is invoked from one's
+.B ~/.xsession or as one of the GNOME startup programs, for example.
+
+In order to be called automatically by
+.B ssh-add,
+.B ssh-askpass-fullscreen
+should be installed as /usr/bin/ssh-askpass
+
+
+.\" TeX users may be more comfortable with the \fB<whatever>\fP and
+.\" \fI<whatever>\fP escape sequences to invode bold face and italics,
+.\" respectively.
+\fBssh-askpass-fullscreen\fP is a program that...
+.SH ENVIRONMENT VARIABLES
+The following environment variables are recognized:
+
+.TP
+.IR "GNOME_SSH_ASKPASS_GRAB_SERVER"
+ Causes gnome-ssh-askpass to grab the X server before
+asking for a passphrase.
+
+.TP
+.IR "GNOME_SSH_ASKPASS_GRAB_POINTER"
+ Causes gnome-ssh-askpass to grab the mouse pointer will be
+grabbed too.
+
+.PP
+These may have some benefit to security if you don't trust your X
+server. Keyboard is always grabbed.
+
+.TP
+
+.SH SEE ALSO
+.BR ssh-add (1),
+.BR ssh-askpass (1).
+.br
+
+.SH AUTHOR
+This manual page was written by Marco Presi (Zufus) <zufus@debian.org>,
+for the Debian GNU/Linux system (but may be used by others) and it is
+based on that for x11-ssh-askpass by Philip Hands and the one for
+gnome-ssh-askpass by Colin Watson <cjwatson@debian.org>
diff --git a/x11-libs/gtk+/files/gtk+-2.24.27-update-icon-cache.patch b/x11-libs/gtk+/files/gtk+-2.24.27-update-icon-cache.patch
new file mode 100644
index 000000000000..f88e02e53500
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-2.24.27-update-icon-cache.patch
@@ -0,0 +1,64 @@
+From 2537d97e4685767ce22834c0dd24d37ba715fb52 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sat, 9 May 2015 23:30:58 +0200
+Subject: [PATCH] Always use external gtk-update-icon-cache
+
+---
+ configure.ac | 8 +++-----
+ gtk/Makefile.am | 13 ++-----------
+ 2 files changed, 5 insertions(+), 16 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 2671a3d..fa46004 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -913,11 +913,9 @@ dnl Look for a host system's gdk-pixbuf-csource if we are cross-compiling
+
+ AM_CONDITIONAL(CROSS_COMPILING, test $cross_compiling = yes)
+
+-if test $cross_compiling = yes; then
+- AC_PATH_PROG(GTK_UPDATE_ICON_CACHE, gtk-update-icon-cache, no)
+- if test x$GTK_UPDATE_ICON_CACHE = xno; then
+- REBUILD_PNGS=#
+- fi
++AC_PATH_PROG(GTK_UPDATE_ICON_CACHE, gtk-update-icon-cache, no)
++if test x$GTK_UPDATE_ICON_CACHE = xno; then
++ REBUILD_PNGS=#
+ fi
+
+ AC_PATH_PROG(GDK_PIXBUF_CSOURCE, gdk-pixbuf-csource, no)
+diff --git a/gtk/Makefile.am b/gtk/Makefile.am
+index 248220d..42e4c23 100644
+--- a/gtk/Makefile.am
++++ b/gtk/Makefile.am
+@@ -1039,8 +1039,7 @@ endif
+ # Installed tools
+ #
+ bin_PROGRAMS = \
+- gtk-query-immodules-2.0 \
+- gtk-update-icon-cache
++ gtk-query-immodules-2.0
+
+ bin_SCRIPTS = gtk-builder-convert
+
+@@ -1390,16 +1389,8 @@ stamp-icons: $(STOCK_ICONS)
+ ) done \
+ && touch stamp-icons
+
+-if CROSS_COMPILING
+-gtk_update_icon_cache_program = $(GTK_UPDATE_ICON_CACHE)
+-else
+-gtk_update_icon_cache_program = \
+- ./gtk-update-icon-cache
+-endif
+-
+ gtkbuiltincache.h: @REBUILD@ stamp-icons
+- $(MAKE) $(AM_MAKEFLAGS) gtk-update-icon-cache$(EXEEXT)
+- $(gtk_update_icon_cache_program) --force --ignore-theme-index \
++ $(GTK_UPDATE_ICON_CACHE) --force --ignore-theme-index \
+ --include-image-data \
+ --source builtin_icons stock-icons > gtkbuiltincache.h.tmp && \
+ mv gtkbuiltincache.h.tmp gtkbuiltincache.h
+--
+2.3.6
+