summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
index a8ecd68283ff..0f4ded070376 100644
--- a/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
+++ b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
inherit ruby-fakegem
@@ -18,6 +18,9 @@ IUSE=""
RUBY_PATCHES=( ${PN}-accept-encoding.patch )
ruby_add_bdepend "
- dev-ruby/hoe
test? ( dev-ruby/minitest )
"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}