summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/gambit/Manifest1
-rw-r--r--games-board/gambit/gambit-1.0.3-r1.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/games-board/gambit/Manifest b/games-board/gambit/Manifest
index 02def04e0b46..8ad68518361a 100644
--- a/games-board/gambit/Manifest
+++ b/games-board/gambit/Manifest
@@ -1,2 +1 @@
-DIST Gambit-1.0.3-src.tar.bz2 1902202 BLAKE2B 8b4d830466f5894819c82a3b4657d193a1caa82f5cd6902dff8047e4c6731d8e0996806c88ab5f2990303e372eddff60dd085f6f839f4ba2d09ceca9b4ce5603 SHA512 c4d26849d9318b5c404f26c8ac2c09e64417e44e8a8786b9640fe76dd16d70d1ebbba2866e1d9e79efecab948f39cda9664c8eecad0f024782a8345be3acd6c9
DIST Gambit-1.0.4-src.tar.xz 1675576 BLAKE2B 4545bee38509d44f80af874473ff562b441e570be3681b166b064574e12bfad8b8a2fb5043b9d0b9089160de2d97407160336cb58864168232cf0921244cf92d SHA512 9ba12e0e9598e2b08228aa009690e6a05677916dcea1413a42be20d620accbe7cef4f4300e3ccc5d4d99e37c7fb85d923df8f5fa9146ee8049bbde2ce66ab7a9
diff --git a/games-board/gambit/gambit-1.0.3-r1.ebuild b/games-board/gambit/gambit-1.0.3-r1.ebuild
deleted file mode 100644
index 3bf43a1a5631..000000000000
--- a/games-board/gambit/gambit-1.0.3-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-CMAKE_IN_SOURCE_BUILD=true
-inherit cmake-utils
-
-MY_P="${P^}"
-
-DESCRIPTION="Qt-based chess application + engine \"gupta\""
-HOMEPAGE="https://sourceforge.net/projects/gambitchess/"
-SRC_URI="mirror://sourceforge/project/${PN}chess/${MY_P}/${MY_P}-src.tar.bz2"
-
-LICENSE="CC0-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-qt/qtcore:4
- dev-qt/qtgui:4
- dev-qt/qtopengl:4
- media-libs/mesa
- x11-libs/libX11"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}-src"
-
-src_configure() {
- local mycmakeargs=(
- -DCONFIG_ENABLE_UPDATE_CHECKER=OFF
- -DCONFIG_GUPTA_ENGINE_DIRECTORY=/usr/bin
- -DCONFIG_RESOURCE_PATH_PREFIX=/usr/share/${PN}/
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- emake -C engine/gupta VERBOSE=1 STRIP=/bin/true CFLAGS_RELEASE= release
-}
-
-src_install() {
- insinto /usr/share/${PN}
- doins -r data/*
-
- doicon artwork/icons/${PN}/${PN}.svg
- make_desktop_entry ${PN}chess ${PN^} ${PN} Game
- dodoc doc/contributors.txt
-
- dobin engine/gupta/gupta
- dobin ${PN}chess
-}