summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild (renamed from dev-python/uncertainties/uncertainties-3.1.7.ebuild)20
1 files changed, 16 insertions, 4 deletions
diff --git a/dev-python/uncertainties/uncertainties-3.1.7.ebuild b/dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild
index c7f85704f3f1..93177ac576f4 100644
--- a/dev-python/uncertainties/uncertainties-3.1.7.ebuild
+++ b/dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild
@@ -5,24 +5,36 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )
+
inherit distutils-r1 optfeature
DESCRIPTION="Python module for calculations with uncertainties"
-HOMEPAGE="https://pythonhosted.org/uncertainties/"
+HOMEPAGE="
+ https://pythonhosted.org/uncertainties/
+ https://github.com/lebigot/uncertainties/
+ https://pypi.org/project/uncertainties/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-RDEPEND="dev-python/future[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
- test? ( dev-python/numpy[${PYTHON_USEDEP}] )
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
"
distutils_enable_tests pytest
distutils_enable_sphinx doc --no-autodoc
+src_prepare() {
+ # not used in py3, see https://github.com/lebigot/uncertainties/pull/168
+ sed -i -e '/future/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
pkg_postinst() {
optfeature "numpy support" dev-python/numpy
}