summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/cgoban/cgoban-1.9.14-r1.ebuild25
-rw-r--r--games-board/cgoban/cgoban-1.9.14-r2.ebuild (renamed from games-board/cgoban/cgoban-1.9.14.ebuild)25
2 files changed, 22 insertions, 28 deletions
diff --git a/games-board/cgoban/cgoban-1.9.14-r1.ebuild b/games-board/cgoban/cgoban-1.9.14-r1.ebuild
index 948c254910fc..d612a96e31ae 100644
--- a/games-board/cgoban/cgoban-1.9.14-r1.ebuild
+++ b/games-board/cgoban/cgoban-1.9.14-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=6
-inherit eutils autotools
+EAPI=5
+inherit eutils autotools games
DESCRIPTION="A Go-frontend"
HOMEPAGE="http://cgoban1.sourceforge.net/"
@@ -11,30 +11,20 @@ SRC_URI="mirror://sourceforge/cgoban1/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ppc x86"
IUSE=""
RDEPEND="
- || (
- media-gfx/imagemagick
- media-gfx/graphicsmagick[imagemagick]
- )
+ virtual/imagemagick-tools
x11-libs/libX11
x11-libs/libXt"
DEPEND="${RDEPEND}
x11-proto/xproto"
-PATCHES=(
- "${FILESDIR}"/${P}-cflags.patch
-)
-
src_prepare() {
- # ${P}-cflags.patch patches configure.ac, not .in:
- mv configure.{in,ac} || die
-
- default
-
cp cgoban_icon.png ${PN}.png || die
+ mv configure.{in,ac} || die
+ epatch "${FILESDIR}"/${P}-cflags.patch
eautoreconf
}
@@ -42,4 +32,5 @@ src_install() {
default
doicon ${PN}.png
make_desktop_entry cgoban Cgoban
+ prepgamesdirs
}
diff --git a/games-board/cgoban/cgoban-1.9.14.ebuild b/games-board/cgoban/cgoban-1.9.14-r2.ebuild
index 4f1fdd4a2efb..92cf71adde65 100644
--- a/games-board/cgoban/cgoban-1.9.14.ebuild
+++ b/games-board/cgoban/cgoban-1.9.14-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit eutils autotools games
+EAPI=6
+inherit eutils autotools
DESCRIPTION="A Go-frontend"
HOMEPAGE="http://cgoban1.sourceforge.net/"
@@ -11,23 +11,27 @@ SRC_URI="mirror://sourceforge/cgoban1/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
RDEPEND="
- || (
- media-gfx/imagemagick
- media-gfx/graphicsmagick[imagemagick]
- )
+ virtual/imagemagick-tools
x11-libs/libX11
x11-libs/libXt"
DEPEND="${RDEPEND}
x11-proto/xproto"
+PATCHES=(
+ "${FILESDIR}"/${P}-cflags.patch
+)
+
src_prepare() {
- cp cgoban_icon.png ${PN}.png || die
+ # ${P}-cflags.patch patches configure.ac, not .in:
mv configure.{in,ac} || die
- epatch "${FILESDIR}"/${P}-cflags.patch
+
+ default
+
+ cp cgoban_icon.png ${PN}.png || die
eautoreconf
}
@@ -35,5 +39,4 @@ src_install() {
default
doicon ${PN}.png
make_desktop_entry cgoban Cgoban
- prepgamesdirs
}