summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/python/python-2.7.17-r1.ebuild4
-rw-r--r--dev-lang/python/python-3.6.10.ebuild6
-rw-r--r--dev-lang/python/python-3.7.7.ebuild5
-rw-r--r--dev-lang/python/python-3.8.2.ebuild5
-rw-r--r--dev-lang/python/python-3.9.0_alpha4.ebuild5
5 files changed, 25 insertions, 0 deletions
diff --git a/dev-lang/python/python-2.7.17-r1.ebuild b/dev-lang/python/python-2.7.17-r1.ebuild
index 7f6c843e9f5e..544e46b4ffcc 100644
--- a/dev-lang/python/python-2.7.17-r1.ebuild
+++ b/dev-lang/python/python-2.7.17-r1.ebuild
@@ -175,6 +175,10 @@ src_configure() {
# https://bugs.gentoo.org/596798
# (upstream dropped this flag in 3.2a4 anyway)
ac_cv_opt_olimit_ok=no
+ # glibc-2.30 removes it; since we can't cleanly force-rebuild
+ # Python on glibc upgrade, remove it proactively to give
+ # a chance for users rebuilding python before glibc
+ ac_cv_header_stropts_h=no
--with-fpectl
--enable-shared
diff --git a/dev-lang/python/python-3.6.10.ebuild b/dev-lang/python/python-3.6.10.ebuild
index 04d1b2520cde..72e2472af8f7 100644
--- a/dev-lang/python/python-3.6.10.ebuild
+++ b/dev-lang/python/python-3.6.10.ebuild
@@ -133,6 +133,11 @@ src_configure() {
fi
local myeconfargs=(
+ # glibc-2.30 removes it; since we can't cleanly force-rebuild
+ # Python on glibc upgrade, remove it proactively to give
+ # a chance for users rebuilding python before glibc
+ ac_cv_header_stropts_h=no
+
--with-fpectl
--enable-shared
$(use_enable ipv6)
@@ -150,6 +155,7 @@ src_configure() {
OPT="" econf "${myeconfargs[@]}"
+
if use threads && grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
eerror "configure has detected that the sem_open function is broken."
eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
diff --git a/dev-lang/python/python-3.7.7.ebuild b/dev-lang/python/python-3.7.7.ebuild
index 98a67f6b1429..6ad2817ec1e4 100644
--- a/dev-lang/python/python-3.7.7.ebuild
+++ b/dev-lang/python/python-3.7.7.ebuild
@@ -128,6 +128,11 @@ src_configure() {
fi
local myeconfargs=(
+ # glibc-2.30 removes it; since we can't cleanly force-rebuild
+ # Python on glibc upgrade, remove it proactively to give
+ # a chance for users rebuilding python before glibc
+ ac_cv_header_stropts_h=no
+
--enable-shared
$(use_enable ipv6)
--infodir='${prefix}/share/info'
diff --git a/dev-lang/python/python-3.8.2.ebuild b/dev-lang/python/python-3.8.2.ebuild
index 0960b3a64978..831650e0d934 100644
--- a/dev-lang/python/python-3.8.2.ebuild
+++ b/dev-lang/python/python-3.8.2.ebuild
@@ -133,6 +133,11 @@ src_configure() {
fi
local myeconfargs=(
+ # glibc-2.30 removes it; since we can't cleanly force-rebuild
+ # Python on glibc upgrade, remove it proactively to give
+ # a chance for users rebuilding python before glibc
+ ac_cv_header_stropts_h=no
+
--enable-shared
$(use_enable ipv6)
--infodir='${prefix}/share/info'
diff --git a/dev-lang/python/python-3.9.0_alpha4.ebuild b/dev-lang/python/python-3.9.0_alpha4.ebuild
index 77a4321ff044..cf3bb88ec5b5 100644
--- a/dev-lang/python/python-3.9.0_alpha4.ebuild
+++ b/dev-lang/python/python-3.9.0_alpha4.ebuild
@@ -149,6 +149,11 @@ src_configure() {
fi
local myeconfargs=(
+ # glibc-2.30 removes it; since we can't cleanly force-rebuild
+ # Python on glibc upgrade, remove it proactively to give
+ # a chance for users rebuilding python before glibc
+ ac_cv_header_stropts_h=no
+
--enable-shared
$(use_enable ipv6)
--infodir='${prefix}/share/info'