summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-dns/dnsmasq/Manifest2
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.76-r1.ebuild190
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.76.ebuild186
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.77-r1.ebuild195
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.77.ebuild193
5 files changed, 0 insertions, 766 deletions
diff --git a/net-dns/dnsmasq/Manifest b/net-dns/dnsmasq/Manifest
index f8bdcc32285e..0c1296ae6cf8 100644
--- a/net-dns/dnsmasq/Manifest
+++ b/net-dns/dnsmasq/Manifest
@@ -1,3 +1 @@
-DIST dnsmasq-2.76.tar.xz 480796 BLAKE2B 09dd0e97bcd70fa2beecd80ed157692a217a8a5b71f5d9491c419bedc909b1dcee043c5aeaab333a44d1775785182658ac999c5d3c4f4bd48f1683122697e326 SHA512 8a930f3e7cdc0c291ce89bea8128a4b8438b9aa9e660a2ac037e0baa4c5c74f4482a8f83b0410066a759444b3c4e1cf62a9beb625e38509690227996de10e06a
-DIST dnsmasq-2.77.tar.xz 487244 BLAKE2B 4671dd47f87c4554b7d18413cff22cd5ed8338d2d97a8c2ecb57a92d0c7efa6a7fd9ff208b529f124cd8678e0d7f9328366a18039162647bed6076a05a882b1a SHA512 6ca98a71a8fdfd606e29c58b34dadfa63148c39f931570cca67a287e044d52c6ec2f8acbf5620ada3312e9db3a2fd63877188d829c070beaa730607e3309e768
DIST dnsmasq-2.78.tar.xz 489172 BLAKE2B 996b59181c4b582b74c91be073e62f0756d2e4c67ee36ff825b6973699f60e44959bb0451bbb8623f277e5a8378cda987a300eee6ec9398ae99284b302da2747 SHA512 9b79b84e5a768d52f90f6335ccef2c404ecd7a13e78e49f4cd0755fffc6cf34d0dc96ad4c72cad1dab3c5743a8d0d789b3e9b6e625b03c5675bb898ca61a698b
diff --git a/net-dns/dnsmasq/dnsmasq-2.76-r1.ebuild b/net-dns/dnsmasq/dnsmasq-2.76-r1.ebuild
deleted file mode 100644
index 70cc1f59fb18..000000000000
--- a/net-dns/dnsmasq/dnsmasq-2.76-r1.ebuild
+++ /dev/null
@@ -1,190 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils toolchain-funcs flag-o-matic user systemd
-
-DESCRIPTION="Small forwarding DNS server"
-HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/doc.html"
-SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${P}.tar.xz"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd"
-IUSE="auth-dns conntrack dbus +dhcp dhcp-tools dnssec idn +inotify ipv6 lua nls script selinux static tftp"
-DM_LINGUAS="de es fi fr id it no pl pt_BR ro"
-
-CDEPEND="dbus? ( sys-apps/dbus )
- idn? ( net-dns/libidn )
- lua? ( dev-lang/lua:* )
- conntrack? ( net-libs/libnetfilter_conntrack )
- nls? (
- sys-devel/gettext
- net-dns/libidn
- )
-"
-
-DEPEND="${CDEPEND}
- app-arch/xz-utils
- dnssec? (
- dev-libs/nettle[gmp]
- static? (
- dev-libs/nettle[static-libs(+)]
- )
- )
- virtual/pkgconfig"
-
-RDEPEND="${CDEPEND}
- dnssec? (
- !static? (
- dev-libs/nettle[gmp]
- )
- )
- selinux? ( sec-policy/selinux-dnsmasq )
-"
-
-REQUIRED_USE="dhcp-tools? ( dhcp )
- lua? ( script )"
-
-use_have() {
- local useflag no_only uword
- if [[ $1 == '-n' ]]; then
- no_only=1
- shift
- fi
- useflag="${1}"
- shift
-
- uword="${1:-${useflag}}"
- shift
-
- while [[ ${uword} ]]; do
- uword="${uword^^}"
-
- if ! use "${useflag}"; then
- echo -n " -DNO_${uword}"
- elif [[ -z "${no_only}" ]]; then
- echo -n " -DHAVE_${uword}"
- fi
- uword="${1}"
- shift
- done
-}
-
-pkg_pretend() {
- if use static; then
- einfo "Only sys-libs/gmp and dev-libs/nettle are statically linked."
- use dnssec || einfo "Thus, ${P}[!dnssec,static] makes no sense; the static USE flag is ignored."
- fi
-}
-
-pkg_setup() {
- enewgroup dnsmasq
- enewuser dnsmasq -1 -1 /dev/null dnsmasq
-}
-
-src_prepare() {
- default
-
- sed -i -r 's:lua5.[0-9]+:lua:' Makefile
- sed -i "s:%%PREFIX%%:${EPREFIX}/usr:" dnsmasq.conf.example
-}
-
-src_configure() {
- COPTS="$(use_have -n auth-dns auth)"
- COPTS+="$(use_have conntrack)"
- COPTS+="$(use_have dbus)"
- COPTS+="$(use_have idn)"
- COPTS+="$(use_have -n inotify)"
- COPTS+="$(use_have -n dhcp dhcp dhcp6)"
- COPTS+="$(use_have -n ipv6 ipv6 dhcp6)"
- COPTS+="$(use_have lua luascript)"
- COPTS+="$(use_have -n script)"
- COPTS+="$(use_have -n tftp)"
- COPTS+="$(use_have dnssec)"
- COPTS+="$(use_have static dnssec_static)"
-}
-
-src_compile() {
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- COPTS="${COPTS}" \
- CONFFILE="/etc/${PN}.conf" \
- all$(use nls && echo "-i18n")
-
- use dhcp-tools && emake -C contrib/lease-tools \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- all
-}
-
-src_install() {
- local lingua puid
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- COPTS="${COPTS}" \
- DESTDIR="${D}" \
- install$(use nls && echo "-i18n")
-
- for lingua in ${DM_LINGUAS}; do
- has ${lingua} ${LINGUAS-${lingua}} \
- || rm -rf "${D}"/usr/share/locale/${lingua}
- done
- [[ -d "${D}"/usr/share/locale/ ]] && rmdir --ignore-fail-on-non-empty "${D}"/usr/share/locale/
-
- dodoc CHANGELOG CHANGELOG.archive FAQ dnsmasq.conf.example
- dodoc -r logo
-
- docinto html/
- dodoc *.html
-
- newinitd "${FILESDIR}"/dnsmasq-init-r2 ${PN}
- newconfd "${FILESDIR}"/dnsmasq.confd-r1 ${PN}
-
- insinto /etc
- newins dnsmasq.conf.example dnsmasq.conf
-
- insinto /usr/share/dnsmasq
- doins trust-anchors.conf
-
- if use dhcp; then
- dodir /var/lib/misc
- newinitd "${FILESDIR}"/dnsmasq-init-dhcp-r1 ${PN}
- fi
- if use dbus; then
- insinto /etc/dbus-1/system.d
- doins dbus/dnsmasq.conf
- fi
-
- if use dhcp-tools; then
- dosbin contrib/lease-tools/{dhcp_release,dhcp_lease_time}
- doman contrib/lease-tools/{dhcp_release,dhcp_lease_time}.1
- if use ipv6; then
- dosbin contrib/lease-tools/dhcp_release6
- doman contrib/lease-tools/dhcp_release6.1
- fi
- fi
-
- systemd_newunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service
-}
-
-pkg_preinst() {
- # temporary workaround to (hopefully) prevent leases file from being removed
- [[ -f /var/lib/misc/dnsmasq.leases ]] && cp /var/lib/misc/dnsmasq.leases "${T}"
-}
-
-pkg_postinst() {
- # temporary workaround to (hopefully) prevent leases file from being removed
- [[ -f "${T}"/dnsmasq.leases ]] && cp "${T}"/dnsmasq.leases /var/lib/misc/dnsmasq.leases
-}
diff --git a/net-dns/dnsmasq/dnsmasq-2.76.ebuild b/net-dns/dnsmasq/dnsmasq-2.76.ebuild
deleted file mode 100644
index 580899b2c9cf..000000000000
--- a/net-dns/dnsmasq/dnsmasq-2.76.ebuild
+++ /dev/null
@@ -1,186 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils toolchain-funcs flag-o-matic user systemd
-
-DESCRIPTION="Small forwarding DNS server"
-HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/doc.html"
-SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${P}.tar.xz"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
-IUSE="auth-dns conntrack dbus +dhcp dhcp-tools dnssec idn +inotify ipv6 lua nls script selinux static tftp"
-DM_LINGUAS="de es fi fr id it no pl pt_BR ro"
-
-CDEPEND="dbus? ( sys-apps/dbus )
- idn? ( net-dns/libidn )
- lua? ( dev-lang/lua:* )
- conntrack? ( net-libs/libnetfilter_conntrack )
- nls? (
- sys-devel/gettext
- net-dns/libidn
- )
-"
-
-DEPEND="${CDEPEND}
- app-arch/xz-utils
- dnssec? (
- dev-libs/nettle[gmp]
- static? (
- dev-libs/nettle[static-libs(+)]
- )
- )
- virtual/pkgconfig"
-
-RDEPEND="${CDEPEND}
- dnssec? (
- !static? (
- dev-libs/nettle[gmp]
- )
- )
- selinux? ( sec-policy/selinux-dnsmasq )
-"
-
-REQUIRED_USE="dhcp-tools? ( dhcp )
- lua? ( script )"
-
-use_have() {
- local useflag no_only uword
- if [[ $1 == '-n' ]]; then
- no_only=1
- shift
- fi
- useflag="${1}"
- shift
-
- uword="${1:-${useflag}}"
- shift
-
- while [[ ${uword} ]]; do
- uword="${uword^^}"
-
- if ! use "${useflag}"; then
- echo -n " -DNO_${uword}"
- elif [[ -z "${no_only}" ]]; then
- echo -n " -DHAVE_${uword}"
- fi
- uword="${1}"
- shift
- done
-}
-
-pkg_pretend() {
- if use static; then
- einfo "Only sys-libs/gmp and dev-libs/nettle are statically linked."
- use dnssec || einfo "Thus, ${P}[!dnssec,static] makes no sense; the static USE flag is ignored."
- fi
-}
-
-pkg_setup() {
- enewgroup dnsmasq
- enewuser dnsmasq -1 -1 /dev/null dnsmasq
-}
-
-src_prepare() {
- default
-
- sed -i -r 's:lua5.[0-9]+:lua:' Makefile
- sed -i "s:%%PREFIX%%:${EPREFIX}/usr:" dnsmasq.conf.example
-}
-
-src_configure() {
- COPTS="$(use_have -n auth-dns auth)"
- COPTS+="$(use_have conntrack)"
- COPTS+="$(use_have dbus)"
- COPTS+="$(use_have idn)"
- COPTS+="$(use_have -n inotify)"
- COPTS+="$(use_have -n dhcp dhcp dhcp6)"
- COPTS+="$(use_have -n ipv6 ipv6 dhcp6)"
- COPTS+="$(use_have lua luascript)"
- COPTS+="$(use_have -n script)"
- COPTS+="$(use_have -n tftp)"
- COPTS+="$(use_have dnssec)"
- COPTS+="$(use_have static dnssec_static)"
-}
-
-src_compile() {
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- COPTS="${COPTS}" \
- CONFFILE="/etc/${PN}.conf" \
- all$(use nls && echo "-i18n")
-
- use dhcp-tools && emake -C contrib/lease-tools \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- all
-}
-
-src_install() {
- local lingua puid
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- COPTS="${COPTS}" \
- DESTDIR="${D}" \
- install$(use nls && echo "-i18n")
-
- for lingua in ${DM_LINGUAS}; do
- has ${lingua} ${LINGUAS-${lingua}} \
- || rm -rf "${D}"/usr/share/locale/${lingua}
- done
- [[ -d "${D}"/usr/share/locale/ ]] && rmdir --ignore-fail-on-non-empty "${D}"/usr/share/locale/
-
- dodoc CHANGELOG CHANGELOG.archive FAQ dnsmasq.conf.example
- dodoc -r logo
-
- docinto html/
- dodoc *.html
-
- newinitd "${FILESDIR}"/dnsmasq-init-r2 ${PN}
- newconfd "${FILESDIR}"/dnsmasq.confd-r1 ${PN}
-
- insinto /etc
- newins dnsmasq.conf.example dnsmasq.conf
-
- insinto /usr/share/dnsmasq
- doins trust-anchors.conf
-
- if use dhcp; then
- dodir /var/lib/misc
- newinitd "${FILESDIR}"/dnsmasq-init-dhcp-r1 ${PN}
- fi
- if use dbus; then
- insinto /etc/dbus-1/system.d
- doins dbus/dnsmasq.conf
- fi
-
- if use dhcp-tools; then
- dosbin contrib/lease-tools/{dhcp_release,dhcp_lease_time}
- doman contrib/lease-tools/{dhcp_release,dhcp_lease_time}.1
- fi
-
- systemd_newunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service
-}
-
-pkg_preinst() {
- # temporary workaround to (hopefully) prevent leases file from being removed
- [[ -f /var/lib/misc/dnsmasq.leases ]] && cp /var/lib/misc/dnsmasq.leases "${T}"
-}
-
-pkg_postinst() {
- # temporary workaround to (hopefully) prevent leases file from being removed
- [[ -f "${T}"/dnsmasq.leases ]] && cp "${T}"/dnsmasq.leases /var/lib/misc/dnsmasq.leases
-}
diff --git a/net-dns/dnsmasq/dnsmasq-2.77-r1.ebuild b/net-dns/dnsmasq/dnsmasq-2.77-r1.ebuild
deleted file mode 100644
index af735d94ac36..000000000000
--- a/net-dns/dnsmasq/dnsmasq-2.77-r1.ebuild
+++ /dev/null
@@ -1,195 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs flag-o-matic user systemd
-
-DESCRIPTION="Small forwarding DNS server"
-HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/doc.html"
-SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${P}.tar.xz"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-
-IUSE="auth-dns conntrack dbus +dhcp dhcp-tools dnssec +id idn libidn2 +inotify"
-IUSE+=" ipv6 lua nls script selinux static tftp"
-
-DM_LINGUAS=(de es fi fr id it no pl pt_BR ro)
-
-CDEPEND="dbus? ( sys-apps/dbus )
- idn? (
- !libidn2? ( net-dns/libidn )
- libidn2? ( >=net-dns/libidn2-2.0 )
- )
- lua? ( dev-lang/lua:* )
- conntrack? ( net-libs/libnetfilter_conntrack )
- nls? ( sys-devel/gettext )
-"
-
-DEPEND="${CDEPEND}
- app-arch/xz-utils
- dnssec? (
- dev-libs/nettle[gmp]
- static? ( dev-libs/nettle[static-libs(+)] )
- )
- virtual/pkgconfig
-"
-
-RDEPEND="${CDEPEND}
- dnssec? (
- !static? (
- dev-libs/nettle[gmp]
- )
- )
- selinux? ( sec-policy/selinux-dnsmasq )
-"
-
-REQUIRED_USE="dhcp-tools? ( dhcp )
- lua? ( script )
- libidn2? ( idn )"
-
-use_have() {
- local useflag no_only uword
- if [[ $1 == '-n' ]]; then
- no_only=1
- shift
- fi
- useflag="${1}"
- shift
-
- uword="${1:-${useflag}}"
- shift
-
- while [[ ${uword} ]]; do
- uword="${uword^^}"
-
- if ! use "${useflag}"; then
- echo -n " -DNO_${uword}"
- elif [[ -z "${no_only}" ]]; then
- echo -n " -DHAVE_${uword}"
- fi
- uword="${1}"
- shift
- done
-}
-
-pkg_pretend() {
- if use static; then
- einfo "Only sys-libs/gmp and dev-libs/nettle are statically linked."
- use dnssec || einfo "Thus, ${P}[!dnssec,static] makes no sense; the static USE flag is ignored."
- fi
-}
-
-pkg_setup() {
- enewgroup dnsmasq
- enewuser dnsmasq -1 -1 /dev/null dnsmasq
-}
-
-src_prepare() {
- default
-
- sed -i -r 's:lua5.[0-9]+:lua:' Makefile
- sed -i "s:%%PREFIX%%:${EPREFIX}/usr:" dnsmasq.conf.example
-}
-
-src_configure() {
- COPTS="$(use_have -n auth-dns auth)"
- COPTS+="$(use_have conntrack)"
- COPTS+="$(use_have dbus)"
- COPTS+="$(use libidn2 || use_have idn)"
- COPTS+="$(use_have libidn2)"
- COPTS+="$(use_have -n inotify)"
- COPTS+="$(use_have -n dhcp dhcp dhcp6)"
- COPTS+="$(use_have -n ipv6 ipv6 dhcp6)"
- COPTS+="$(use_have -n id id)"
- COPTS+="$(use_have lua luascript)"
- COPTS+="$(use_have -n script)"
- COPTS+="$(use_have -n tftp)"
- COPTS+="$(use_have dnssec)"
- COPTS+="$(use_have static dnssec_static)"
-}
-
-src_compile() {
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- COPTS="${COPTS}" \
- CONFFILE="/etc/${PN}.conf" \
- all$(use nls && echo "-i18n")
-
- use dhcp-tools && emake -C contrib/lease-tools \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- all
-}
-
-src_install() {
- local lingua puid
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- COPTS="${COPTS}" \
- DESTDIR="${D}" \
- install$(use nls && echo "-i18n")
-
- for lingua in "${DM_LINGUAS[@]}"; do
- has ${lingua} ${LINGUAS-${lingua}} \
- || rm -rf "${D}"/usr/share/locale/${lingua}
- done
- [[ -d "${D}"/usr/share/locale/ ]] && rmdir --ignore-fail-on-non-empty "${D}"/usr/share/locale/
-
- dodoc CHANGELOG CHANGELOG.archive FAQ dnsmasq.conf.example
- dodoc -r logo
-
- docinto html/
- dodoc *.html
-
- newinitd "${FILESDIR}"/dnsmasq-init-r2 ${PN}
- newconfd "${FILESDIR}"/dnsmasq.confd-r1 ${PN}
-
- insinto /etc
- newins dnsmasq.conf.example dnsmasq.conf
-
- insinto /usr/share/dnsmasq
- doins trust-anchors.conf
-
- if use dhcp; then
- dodir /var/lib/misc
- newinitd "${FILESDIR}"/dnsmasq-init-dhcp-r1 ${PN}
- fi
- if use dbus; then
- insinto /etc/dbus-1/system.d
- doins dbus/dnsmasq.conf
- fi
-
- if use dhcp-tools; then
- dosbin contrib/lease-tools/{dhcp_release,dhcp_lease_time}
- doman contrib/lease-tools/{dhcp_release,dhcp_lease_time}.1
- if use ipv6; then
- dosbin contrib/lease-tools/dhcp_release6
- doman contrib/lease-tools/dhcp_release6.1
- fi
- fi
-
- systemd_newunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service
-}
-
-pkg_preinst() {
- # temporary workaround to (hopefully) prevent leases file from being removed
- [[ -f /var/lib/misc/dnsmasq.leases ]] && cp /var/lib/misc/dnsmasq.leases "${T}"
-}
-
-pkg_postinst() {
- # temporary workaround to (hopefully) prevent leases file from being removed
- [[ -f "${T}"/dnsmasq.leases ]] && cp "${T}"/dnsmasq.leases /var/lib/misc/dnsmasq.leases
-}
diff --git a/net-dns/dnsmasq/dnsmasq-2.77.ebuild b/net-dns/dnsmasq/dnsmasq-2.77.ebuild
deleted file mode 100644
index cd8e91ad766c..000000000000
--- a/net-dns/dnsmasq/dnsmasq-2.77.ebuild
+++ /dev/null
@@ -1,193 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs flag-o-matic user systemd
-
-DESCRIPTION="Small forwarding DNS server"
-HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/doc.html"
-SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${P}.tar.xz"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-
-IUSE="auth-dns conntrack dbus +dhcp dhcp-tools dnssec +id idn libidn2 +inotify"
-IUSE+=" ipv6 lua nls script selinux static tftp"
-
-DM_LINGUAS=(de es fi fr id it no pl pt_BR ro)
-
-CDEPEND="dbus? ( sys-apps/dbus )
- idn? ( net-dns/libidn )
- libidn2? ( >=net-dns/libidn2-2.0 )
- lua? ( dev-lang/lua:* )
- conntrack? ( net-libs/libnetfilter_conntrack )
- nls? ( sys-devel/gettext )
-"
-
-DEPEND="${CDEPEND}
- app-arch/xz-utils
- dnssec? (
- dev-libs/nettle[gmp]
- static? ( dev-libs/nettle[static-libs(+)] )
- )
- virtual/pkgconfig
-"
-
-RDEPEND="${CDEPEND}
- dnssec? (
- !static? (
- dev-libs/nettle[gmp]
- )
- )
- selinux? ( sec-policy/selinux-dnsmasq )
-"
-
-REQUIRED_USE="dhcp-tools? ( dhcp )
- lua? ( script )
- libidn2? ( !idn )"
-
-use_have() {
- local useflag no_only uword
- if [[ $1 == '-n' ]]; then
- no_only=1
- shift
- fi
- useflag="${1}"
- shift
-
- uword="${1:-${useflag}}"
- shift
-
- while [[ ${uword} ]]; do
- uword="${uword^^}"
-
- if ! use "${useflag}"; then
- echo -n " -DNO_${uword}"
- elif [[ -z "${no_only}" ]]; then
- echo -n " -DHAVE_${uword}"
- fi
- uword="${1}"
- shift
- done
-}
-
-pkg_pretend() {
- if use static; then
- einfo "Only sys-libs/gmp and dev-libs/nettle are statically linked."
- use dnssec || einfo "Thus, ${P}[!dnssec,static] makes no sense; the static USE flag is ignored."
- fi
-}
-
-pkg_setup() {
- enewgroup dnsmasq
- enewuser dnsmasq -1 -1 /dev/null dnsmasq
-}
-
-src_prepare() {
- default
-
- sed -i -r 's:lua5.[0-9]+:lua:' Makefile
- sed -i "s:%%PREFIX%%:${EPREFIX}/usr:" dnsmasq.conf.example
-}
-
-src_configure() {
- COPTS="$(use_have -n auth-dns auth)"
- COPTS+="$(use_have conntrack)"
- COPTS+="$(use_have dbus)"
- COPTS+="$(use_have idn)"
- COPTS+="$(use_have libidn2)"
- COPTS+="$(use_have -n inotify)"
- COPTS+="$(use_have -n dhcp dhcp dhcp6)"
- COPTS+="$(use_have -n ipv6 ipv6 dhcp6)"
- COPTS+="$(use_have -n id id)"
- COPTS+="$(use_have lua luascript)"
- COPTS+="$(use_have -n script)"
- COPTS+="$(use_have -n tftp)"
- COPTS+="$(use_have dnssec)"
- COPTS+="$(use_have static dnssec_static)"
-}
-
-src_compile() {
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- COPTS="${COPTS}" \
- CONFFILE="/etc/${PN}.conf" \
- all$(use nls && echo "-i18n")
-
- use dhcp-tools && emake -C contrib/lease-tools \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- all
-}
-
-src_install() {
- local lingua puid
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- COPTS="${COPTS}" \
- DESTDIR="${D}" \
- install$(use nls && echo "-i18n")
-
- for lingua in "${DM_LINGUAS[@]}"; do
- has ${lingua} ${LINGUAS-${lingua}} \
- || rm -rf "${D}"/usr/share/locale/${lingua}
- done
- [[ -d "${D}"/usr/share/locale/ ]] && rmdir --ignore-fail-on-non-empty "${D}"/usr/share/locale/
-
- dodoc CHANGELOG CHANGELOG.archive FAQ dnsmasq.conf.example
- dodoc -r logo
-
- docinto html/
- dodoc *.html
-
- newinitd "${FILESDIR}"/dnsmasq-init-r2 ${PN}
- newconfd "${FILESDIR}"/dnsmasq.confd-r1 ${PN}
-
- insinto /etc
- newins dnsmasq.conf.example dnsmasq.conf
-
- insinto /usr/share/dnsmasq
- doins trust-anchors.conf
-
- if use dhcp; then
- dodir /var/lib/misc
- newinitd "${FILESDIR}"/dnsmasq-init-dhcp-r1 ${PN}
- fi
- if use dbus; then
- insinto /etc/dbus-1/system.d
- doins dbus/dnsmasq.conf
- fi
-
- if use dhcp-tools; then
- dosbin contrib/lease-tools/{dhcp_release,dhcp_lease_time}
- doman contrib/lease-tools/{dhcp_release,dhcp_lease_time}.1
- if use ipv6; then
- dosbin contrib/lease-tools/dhcp_release6
- doman contrib/lease-tools/dhcp_release6.1
- fi
- fi
-
- systemd_newunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service
-}
-
-pkg_preinst() {
- # temporary workaround to (hopefully) prevent leases file from being removed
- [[ -f /var/lib/misc/dnsmasq.leases ]] && cp /var/lib/misc/dnsmasq.leases "${T}"
-}
-
-pkg_postinst() {
- # temporary workaround to (hopefully) prevent leases file from being removed
- [[ -f "${T}"/dnsmasq.leases ]] && cp "${T}"/dnsmasq.leases /var/lib/misc/dnsmasq.leases
-}