summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/libsamplerate/Manifest1
-rw-r--r--media-libs/libsamplerate/libsamplerate-0.1.9.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/media-libs/libsamplerate/Manifest b/media-libs/libsamplerate/Manifest
index 3575a6b0f5cb..9c39646573f8 100644
--- a/media-libs/libsamplerate/Manifest
+++ b/media-libs/libsamplerate/Manifest
@@ -1 +1,2 @@
DIST libsamplerate-0.1.8.tar.gz 4303330 SHA256 93b54bdf46d5e6d2354b7034395fe329c222a966790de34520702bb9642f1c06 SHA512 85d93df24d9d62e7803a5d0ac5d268b2085214adcb160e32fac316b12ee8a0ce36ccfb433a3c0a08f6e3ec418a5962bdb84f8a11262286a9b347436983029a7d WHIRLPOOL 5aff2290372570178752fedb5cafe1cb8d30cd8aa0910f8f7a2333d41746ac7a88e5cc7f7228eb8ba60aa2908fad0242214ac3e29346db04cc1e9cc66386eddf
+DIST libsamplerate-0.1.9.tar.gz 4336641 SHA256 0a7eb168e2f21353fb6d84da152e4512126f7dc48ccb0be80578c565413444c1 SHA512 78596657963cbf06785e3e6e1190b093df71da52ca340e75bd8246a962cd79dd1c90fa5527c607cebcb296e2c1ee605015278b274e3b768f2f3fbeb0eadfb728 WHIRLPOOL 3591f08cd64f731a8bdd02daabec6b7bc6bcd9f6806bab4f687f3c120481d4cfbcf5fd7752052a6147358b7471549c99d963615bda89b9679b1e091b636e7b8e
diff --git a/media-libs/libsamplerate/libsamplerate-0.1.9.ebuild b/media-libs/libsamplerate/libsamplerate-0.1.9.ebuild
new file mode 100644
index 000000000000..b48dc71fd2d6
--- /dev/null
+++ b/media-libs/libsamplerate/libsamplerate-0.1.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+inherit autotools-multilib
+
+DESCRIPTION="Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for audio"
+HOMEPAGE="http://www.mega-nerd.com/SRC/"
+SRC_URI="http://www.mega-nerd.com/SRC/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="sndfile static-libs"
+
+RDEPEND="sndfile? ( >=media-libs/libsndfile-1.0.2 )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r6
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-0.1.3-dontbuild-tests-examples.patch"
+ "${FILESDIR}/${PN}-0.1.8-lm.patch"
+ )
+
+ AT_M4DIR="M4" \
+ autotools-multilib_src_prepare
+}
+
+src_configure() {
+ my_configure() {
+ local myeconfargs=(
+ --disable-fftw
+ )
+
+ if [ "${ABI}" = "${DEFAULT_ABI}" ] ; then
+ myeconfargs+=( $(use_enable sndfile) )
+ else
+ myeconfargs+=( --disable-sndfile )
+ fi
+
+ autotools-utils_src_configure
+
+ if [ "${ABI}" != "${DEFAULT_ABI}" ] ; then
+ sed -i -e "s/ doc examples//" "${BUILD_DIR}/Makefile" || die
+ fi
+ }
+ multilib_parallel_foreach_abi my_configure
+}
+
+src_install() {
+ autotools-multilib_src_install \
+ htmldocdir="${EPREFIX}/usr/share/doc/${PF}/html"
+}