summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-plugins/kodi-screensaver-stars/Manifest1
-rw-r--r--media-plugins/kodi-screensaver-stars/kodi-screensaver-stars-2.4.0.ebuild32
-rw-r--r--media-plugins/kodi-screensaver-stars/kodi-screensaver-stars-9999.ebuild32
-rw-r--r--media-plugins/kodi-screensaver-stars/metadata.xml15
4 files changed, 80 insertions, 0 deletions
diff --git a/media-plugins/kodi-screensaver-stars/Manifest b/media-plugins/kodi-screensaver-stars/Manifest
new file mode 100644
index 000000000000..d953f7e95937
--- /dev/null
+++ b/media-plugins/kodi-screensaver-stars/Manifest
@@ -0,0 +1 @@
+DIST kodi-screensaver-stars-2.4.0.tar.gz 281246 BLAKE2B 7371c880feefe567c1d85a19fb03bdddf7534cf51bc16de64199d14e9456d26ada4c8a478f8e8badcfe19948319fc220403933952ae86f0d6dc70c88ac8dbe0b SHA512 faf30c7df759a5c0dd0212369e83835f5949b37f476bf67f03f310d405aa0fd1daa62d0bbb899be11e4ee0ac1f1bb5321be647b0e7792d7c3a730d3ffcd256ad
diff --git a/media-plugins/kodi-screensaver-stars/kodi-screensaver-stars-2.4.0.ebuild b/media-plugins/kodi-screensaver-stars/kodi-screensaver-stars-2.4.0.ebuild
new file mode 100644
index 000000000000..45acfbb6c5b1
--- /dev/null
+++ b/media-plugins/kodi-screensaver-stars/kodi-screensaver-stars-2.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kodi-addon
+
+DESCRIPTION="Stars screensaver for Kodi"
+HOMEPAGE="https://github.com/xbmc/screensaver.stars"
+KODI_PLUGIN_NAME="screensaver.stars"
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/xbmc/${KODI_PLUGIN_NAME}.git"
+ inherit git-r3
+ DEPEND="~media-tv/kodi-9999"
+ ;;
+*)
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/xbmc/${KODI_PLUGIN_NAME}/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${KODI_PLUGIN_NAME}-${PV}-${CODENAME}"
+ DEPEND="=media-tv/kodi-19*:="
+ ;;
+esac
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${DEPEND}"
diff --git a/media-plugins/kodi-screensaver-stars/kodi-screensaver-stars-9999.ebuild b/media-plugins/kodi-screensaver-stars/kodi-screensaver-stars-9999.ebuild
new file mode 100644
index 000000000000..45acfbb6c5b1
--- /dev/null
+++ b/media-plugins/kodi-screensaver-stars/kodi-screensaver-stars-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kodi-addon
+
+DESCRIPTION="Stars screensaver for Kodi"
+HOMEPAGE="https://github.com/xbmc/screensaver.stars"
+KODI_PLUGIN_NAME="screensaver.stars"
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/xbmc/${KODI_PLUGIN_NAME}.git"
+ inherit git-r3
+ DEPEND="~media-tv/kodi-9999"
+ ;;
+*)
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/xbmc/${KODI_PLUGIN_NAME}/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${KODI_PLUGIN_NAME}-${PV}-${CODENAME}"
+ DEPEND="=media-tv/kodi-19*:="
+ ;;
+esac
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${DEPEND}"
diff --git a/media-plugins/kodi-screensaver-stars/metadata.xml b/media-plugins/kodi-screensaver-stars/metadata.xml
new file mode 100644
index 000000000000..2c0479894d04
--- /dev/null
+++ b/media-plugins/kodi-screensaver-stars/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>k2k@narod.ru</email>
+ <name>Karlson2k (Evgeny Grin)</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">xbmc/screensaver.stars</remote-id>
+ </upstream>
+</pkgmetadata>