summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-power/thermald/thermald-2.4.8-r1.ebuild (renamed from sys-power/thermald/thermald-2.4.8.ebuild)4
1 files changed, 4 insertions, 0 deletions
diff --git a/sys-power/thermald/thermald-2.4.8.ebuild b/sys-power/thermald/thermald-2.4.8-r1.ebuild
index 2a2134ef6d2f..608411e5ceb4 100644
--- a/sys-power/thermald/thermald-2.4.8.ebuild
+++ b/sys-power/thermald/thermald-2.4.8-r1.ebuild
@@ -32,6 +32,9 @@ src_prepare() {
sed -i -e "/group=/s/power/wheel/g" \
data/org.freedesktop.thermald.conf || die
+ sed -i -e '/tdrundir/s@\$localstatedir/run@\$runstatedir@' \
+ configure.ac || die
+
default
eautoreconf
}
@@ -39,6 +42,7 @@ src_prepare() {
my_src_configure() {
ECONF_SOURCE="${S}" econf \
--disable-werror \
+ --runstatedir="${EPREFIX}"/run \
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
}